Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11th November 2010, 00:36
dinsdale dinsdale is offline
Junior Member
 
Join Date: Jun 2008
Posts: 18
Thanks: 2
Thanked 5 Times in 3 Posts
Default problems after secondary install (mysql ispconfig user+dbispconfig)

I reinstalled ispconfig a second time after uninstalling a botched first install by running the uninstall script. I think I used dbispconfig1 as db name in the first install but dbispconfig in the second install. It appears that the uninstall procedure did not delete the previous config files in /etc/postfix as I seem to have all files backed up in the directory /etc/postfix/

HTML Code:
body_checks         mysql-virtual_client.cf        mysql-virtual_mailboxes.cf~           mysql-virtual_transports.cf
dynamicmaps.cf      mysql-virtual_client.cf~       mysql-virtual_recipient.cf            mysql-virtual_transports.cf~
header_checks       mysql-virtual_domains.cf       mysql-virtual_recipient.cf~           nested_header_checks
main.cf             mysql-virtual_domains.cf~      mysql-virtual_relaydomains.cf         postfix-files
main.cf~            mysql-virtual_email2email.cf   mysql-virtual_relaydomains.cf~        postfix-script
main.cf~2           mysql-virtual_email2email.cf~  mysql-virtual_relayrecipientmaps.cf   post-install
master.cf           mysql-virtual_forwardings.cf   mysql-virtual_relayrecipientmaps.cf~  sasl
master.cf~          mysql-virtual_forwardings.cf~  mysql-virtual_sender.cf               smtpd.cert
mime_header_checks  mysql-virtual_mailboxes.cf     mysql-virtual_sender.cf~              smtpd.key
While I was able to log on to the ispconfig webinterface after the second install I was not able to send email. After checking the credentials in the /etc/postfix/mysql-* files (without the ~) they still pointed to the db dbispconfig1 (from previous install) and a password which didin't work when trying to connect to the mysqldb dbispconfig.

I then changed the password of the mysql user ispconfig to what was in the .cf files and matched the db name in the .cf files to dbispconfig. I was now able to send email - but instead I lost the connection to my ispconfig interface . I found the db pwd can be changed easily in /usr/local/ispconfig/interface/lib/config.inc.php

What do you think happened? Is this maybe a bug in the uninstaller or my own fault. I maybe have to add that I have a 3 server setup:
1 dedicated webserver , 1 dedicated mail server and a backup server which is supposed to mirror the two for redundancy (not implemented yet) but this was all on the webserver.
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
mysql, posftix, virtual users

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 14:31
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
log files cruz Technical 3 15th May 2007 14:35
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41


All times are GMT +2. The time now is 12:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.