Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd November 2010, 13:38
vmos vmos is offline
Member
 
Join Date: Nov 2008
Posts: 57
Thanks: 1
Thanked 0 Times in 0 Posts
Default postfix: sender non-delivery notifications go to root, not the sender

Hi there, I'm porting a couple of our anti-virus servers from debian lenny to ubuntu 10.04.

On the old server, if you send a virus, it stuffs the mail in a black hole somewhere and then sends notification to the sender.

What I'd really like it to do is send a message to the intended recipient but right now the new server sends the notification to the root user.

I can't figure out why this is happening, I've got the same aliases, postfix, amavis, clamav and spamassassin configs.
I've run newaliases and rebooted about a billion times

any suggestions?
Reply With Quote
Sponsored Links
  #2  
Old 3rd November 2010, 15:21
vmos vmos is offline
Member
 
Join Date: Nov 2008
Posts: 57
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

I seem to have figured it out, but I don't quite understand it.

In my amavis/conf.d/20_debian_defaults, on the debian server I have this line

$final_virus_destiny = D_DISCARD;

according to this page
http://www200.pair.com/mecham/spam/a...-settings.html

that means it should dump the mail and tell no-one, however it dumps the mail and tells the sender

On the ubuntu server, D_Discard behaves as it should (IE, telling no-one) so I've changed that to D_BOUNCE and now the sender is getting notifications.

Anyway, does anyone have an idea about how to send notifications to the reicipient?
Reply With Quote
Reply

Bookmarks

Tags
debian, non delivery, notification, postfix, ubuntu

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Too many ispconfig_access_log_* files cryptic Installation/Configuration 15 28th September 2010 13:31
ISPConfig 2 Upgrade pineapple General 53 23rd June 2010 16:25
Perfect Server Ubuntu 9.10 ISPConfig2 AppArmor Issue dwtj01 HOWTO-Related Questions 9 18th November 2009 13:47
Postfix email server problems Access denied 554 554 5.7.1 state 14 AceRimmer Server Operation 4 19th June 2008 14:36
ISPConfig pop3 problem mphayesuk General 21 31st October 2005 10:53


All times are GMT +2. The time now is 09:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.