Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 25th October 2010, 11:02
jscholes jscholes is offline
Junior Member
 
Join Date: Oct 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Asterisk/FreePBX on Linode: High load averages with Linux EC2 Image

Hi all.

I currently have a Linode VPS, and would like to set up a small PBX for my own personal use using Asterisk 1.6 and FreePBX 2.8.

My Linode is currently running Ubuntu 10.10 (Maverick). Over the last couple of years, I've been slowly learning my way around Linux, and Ubuntu is the distro I feel most comfortable with. However, I often still follow tutorials and articles such as those in the Linode Library, especially for software, such as Asterisk and especially FreePBX where I feel the documentation could perhaps be made much more intuitive for the end user. I used the following guide to set up my system:

http://library.linode.com/communications/voip-services/

The following section, however, is causing me some concern:

Quote:
Asterisk uses the "dahdi_dummy" kernel module, which requires you to edit a few things in the kernel as well as your Linode's configuration profile. You will need to use the EC2 image in order to use Asterisk without compiling your own kernel. This is a straightforward process; issue the following command:
apt-get install linux-image-ec2
I followed those instructions, as well as the steps below it to get my kernel set up for the DAHDI modules/drivers. And in fact, did get a system running with Asterisk and FreePBX. However, I noticed that my load averages were quite high; they were constantly staying around the 1.50 mark. As this was a fresh install of Ubuntu 10.10, I was slightly concerned; the main processes that were running were MySQL, Apache and obviously Asterisk. I thought it may be possible that some fine-tuning of configuration of one or more of these processes might be required, so to test this theory, I killed MySQL, Asterisk and Apache. The load averages only dropped by about 0.10.

My concern increased somewhat when I looked through the list of running processes with ps -e. It seemed to me that there were a lot of processes running that I a. didn't know the use of, and b. hadn't purposely started myself. One of these was something along the lines of sfc-netfront/0. I Googled this, and came across a mailing list post about high load averages on Amazon EC2 Ubuntu 10.04 AMIs.

The mailing list did not provide much, if any useful information, however I am now almost convinced, until it is shown otherwise, that the EC2 Linux Image is to blame for the high load averages. I can only assume this is the case at the moment as I don't have any further information.

So, can anyone shine a light on the reason for these high load averages? Is there something in the Linux EC2 Image that can be removed, disabled etc that would prevent such high loads? Is there an alternative to using this image, such as another Linux kernel image that has the required DAHDI modules? Am I barking up the wrong tree completely thinking that the EC2 Image is to blame?

Running Asterisk without DAHDI was suggested to me, which would be fine - I can't see myself really needing conferencing functionality. However, the Asterisk package in Apt requires DAHDI as a dependency. I did install DAHDI to satisfy this dependency, and as you would expect, got tons of errors. However, Asterisk seemed happy to install. I then ran:
asterisk -r
and was told that communication with Asterisk failed and to check that asterisk.ctl exists. I can only assume that the only way to run Asterisk without DAHDI modules is to compile it from source?

Thanks in advance.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Problems Rocky Installation/Configuration 22 14th September 2006 09:03
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
Problems installing NForce4 sound drivers Wraithfire Installation/Configuration 21 16th April 2006 17:30
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 12:59


All times are GMT +2. The time now is 07:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.