#1  
Old 22nd October 2010, 00:21
vlados vlados is offline
Junior Member
 
Join Date: Dec 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgrade apache

Hi,
I have ubuntu with (according to apt latest version) apache 2.12. How can I upgrade to 2.17 or 2.3?
Reply With Quote
Sponsored Links
  #2  
Old 22nd October 2010, 15:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

If there's no such package available from the Ubuntu repositories, you have to build Apache yourself (which I don't recommend!).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd October 2010, 16:00
vlados vlados is offline
Junior Member
 
Join Date: Dec 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, but hacker guardian tells me to upgrade, and that this is a security hole
Reply With Quote
  #4  
Old 23rd October 2010, 12:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

You can be sure that Ubuntu will release an update if there's a security hole. Just run
Code:
apt-get update && apt-get upgrade
to install the latest updates. If there's no update, then the hole is already fixed in the current package.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd October 2010, 13:01
vlados vlados is offline
Junior Member
 
Join Date: Dec 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Code:
IP Address

Vulnerabilities Noted per IP address

Severity level

CVSS Score

Exceptions, False Positives or Compensating Controls
Noted by ASV for this Vulnerability

Compliance Status

www.netlabs.bg


Apache 2.2 < 2.2.15 Multiple Vulnerabilities http (80/tcp) 
 CVE-2009-3555, CVE-2010-0408, CVE-2010-0425, CVE-2010-0434

High


 10.


 


Fail


www.netlabs.bg


Apache 2.2 < 2.2.15 Multiple Vulnerabilities http-alt (8080/tcp) 
 CVE-2009-3555, CVE-2010-0408, CVE-2010-0425, CVE-2010-0434

High


 10.


 


Fail


www.netlabs.bg


Apache 2.2 < 2.2.15 Multiple Vulnerabilities https (443/tcp) 
 CVE-2009-3555, CVE-2010-0408, CVE-2010-0425, CVE-2010-0434

High


 10.


 


Fail


www.netlabs.bg


Apache 2.2 < 2.2.14 Multiple Vulnerabilities http (80/tcp) 
 CVE-2009-2699, CVE-2009-3094, CVE-2009-3095

High


 7.5


 


Fail


www.netlabs.bg


Apache 2.2 < 2.2.14 Multiple Vulnerabilities http-alt (8080/tcp) 
 CVE-2009-2699, CVE-2009-3094, CVE-2009-3095

High


 7.5


 


Fail


www.netlabs.bg


Apache 2.2 < 2.2.14 Multiple Vulnerabilities https (443/tcp) 
 CVE-2009-2699, CVE-2009-3094, CVE-2009-3095

High


 7.5


 


Fail
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Upgrade apache 2.0. to 2.2 at ispconfig 2.0? gmchun83 HOWTO-Related Questions 1 22nd June 2010 16:33
trying to install roundcubemail ressel Installation/Configuration 13 24th December 2009 20:13
problems with suexec gobokster Installation/Configuration 7 7th May 2009 13:33
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45


All times are GMT +2. The time now is 00:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.