Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd October 2010, 04:41
cambob cambob is offline
Junior Member
 
Join Date: Oct 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default SMTP test fails during qmailrocks install CentOS 5.5

I am trying to run though the qmailrocks setup on a centos 5.5 and I am running into an issue when trying to telnet to port 25:
telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.

Everything else seems to be working (telnet to 110), and I turned off the firewall entirely, but I still cannot telnet to port 25. I also get a blank error within squirrelmail when attempting to send mail out (ERROR:
Message not sent. Server replied: ).

I apologize for not going directly to the qmailrocks forum, but they are currently closed down (due to lack of funds). I also am a newbie, so I apologize for the lack of needed information. If anyone has any ideas, please let me know what information you would need.

Thank you in advance
Reply With Quote
Sponsored Links
  #2  
Old 2nd October 2010, 14:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Are there any errors in your mail log?

What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 2nd October 2010, 14:51
cambob cambob is offline
Junior Member
 
Join Date: Oct 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dear Falko,
Thank you for your help with my issue.

my outputs are as follows:
[root@chris-primary ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 chris-primary:2208 *:* LISTEN 2809/hpiod
tcp 0 0 *oppassd *:* LISTEN 3446/xinetd
tcp 0 0 *:mysql *:* LISTEN 2923/mysqld
tcp 0 0 *:11211 *:* LISTEN 2947/memcached
tcp 0 0 *op3 *:* LISTEN 4344/tcpserver
tcp 0 0 *:sunrpc *:* LISTEN 2536/portmap
tcp 0 0 chris-primary:ipp *:* LISTEN 2836/cupsd
tcp 0 0 *:smtp *:* LISTEN 4331/tcpserver
tcp 0 0 chris-primary:2207 *:* LISTEN 2814/python
tcp 0 0 *:msdp *:* LISTEN 2577/rpc.statd
tcp 0 0 *:imaps *:* LISTEN 4080/couriertcpd
tcp 0 0 *:11211 *:* LISTEN 2947/memcached
tcp 0 0 *:imap *:* LISTEN 4072/couriertcpd
tcp 0 0 *:http *:* LISTEN 2971/httpd
tcp 0 0 *:ssh *:* LISTEN 2827/sshd
tcp 0 0 *:https *:* LISTEN 2971/httpd
tcp 0 36 ::ffff:192.168.1.34:ssh ::ffff:192.168.1.:mc-client ESTABLISHED 8155/sshd: disneych
[root@chris-primary ~]#

I couldn't find the mail logs, not sure where they would be?
[root@chris-primary doc]# locate mail.log
[root@chris-primary doc]#


Thank you
Reply With Quote
  #4  
Old 3rd October 2010, 02:21
cambob cambob is offline
Junior Member
 
Join Date: Oct 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I found that an error pointed to the softlimit, made the following change:
exec /usr/local/bin/softlimit -m 50000000
to the /var/qmail/supervise/qmail-smtpd/run file
and now I can telnet to port 25

Now I am having an authentication error, but at least I am closer now and I think that I can find leads to the auth error in qmail (Message not sent. Server replied:

Authentication failed
535 authorization failed (#5.7.0))
Reply With Quote
  #5  
Old 3rd October 2010, 13:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

The mail log should be somewhere in the /var/log directory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Maia MailGuard in ISPC3 warlock Tips/Tricks/Mods 7 23rd December 2010 05:51
ISPC3 on CentOS 5.5 64 Bit - Installation fails with Path Errors & DB not imported kweitzel Installation/Configuration 10 17th July 2010 22:27
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 08:29
Notes for CentOS 4.1 install felipegeek Installation/Configuration 6 19th December 2005 10:21


All times are GMT +2. The time now is 09:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.