Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd October 2010, 02:03
Hamra Hamra is offline
Junior Member
 
Join Date: Oct 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPconfig and apache on centos 5.5

i've been trying to understand ispconfig for few days now.
i have a VPS running centos 5.5 x86_64, i followed the instruction of the perfect server, to install ispconfig 3 on the VPS. after a day of messing with bind, i am finally running my own nameserver, and now to the important part... apache!
ok, while fixing my nameserver problems, i noticed ispconfig was pointing to wrong directories for bind, not the files of my chrooted bind.
so now, i noticed some very debian-like configuration entries for apache in ispconfig, which makes me wonder if these need changing or not.
it says the enabled dir is "/etc/httpd/conf/sites-enabled", but does apache on centos look in this directory?
i am asking because after creating a test site on a subdomain of mine, entering the subdomain in my browser loaded the file at /var/www/http (centos' default web root)... what am i missing?
Reply With Quote
Sponsored Links
  #2  
Old 3rd October 2010, 14:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,490
Thanks: 835
Thanked 5,527 Times in 4,347 Posts
Default

This are the correct directories for Centos and ispconfig, no changes needed.

Regarding your problem, make sure that you created a website for this subdomain in ispconfig and that you selected the correct IP address in the website settings. You can not use * as this causes problems on centos, you have to select a IP address.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 3rd October 2010, 19:31
Hamra Hamra is offline
Junior Member
 
Join Date: Oct 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks for the reply. ok, i think i jumped to conclusions fast. i took the time to read the configuration files, and i noticed how everything is corect, even the sites-enabled is mentioned in httpd.conf.
and thanks for the IP tip, indeed, i was having an overlap problem when using IPs.
so all done, i setup 2 websites. one for domain.com, with auto-subdomain www.domain.com, and another website for info.domain.com, which i want it to run phpsysinfo.
i unchecked suExec, and set it to use suPHP.
i got a 500 error while trying to load it. i looked in its error log, and saw a complaint that index.php is writeable by others. so i went to "/etc/suphp.conf", and changed the security options regarding others, to "true".
loaded the page, another 500 error, but now different one in the error log. a complaint that index.php is having an ID below min_id.
a little googling, and i founf its talking about owner's UID, my files are owned by root (i put them there using a root SSH shell). i changed ownership to "apache", which still resulted in same error (apache turned out to be very low too), so i changed min_id to 10.
again, another 500 error, this time that the directory "web" is not owned by apache... by that time, i was really getting pissed off, specially that it's asking for it to be owned by apache, while apache is lower than the min_id, anyway, i complied and changed ownership from webX:clientX into apache:apache.
tried loading the page, and it loaded fine.

but now to the point.... i hardly think what i've done is an optimal solution, but more of dirty hacking. what IS the appropriate way of dealing with suPHP and ISPconfig/apache?
Reply With Quote
  #4  
Old 4th October 2010, 11:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,490
Thanks: 835
Thanked 5,527 Times in 4,347 Posts
Default

Quote:
i got a 500 error while trying to load it. i looked in its error log, and saw a complaint that index.php is writeable by others. so i went to "/etc/suphp.conf", and changed the security options regarding others, to "true".
Please undo that in suphp.conf. The index.php file may not be writable by others as this is a security risk. Run a chmod 755 on index.php instead and ensure that it is owned by the web user and client group.

And do not change any foilder ownerships. It is not nescessary.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 9th October 2010, 02:16
Hamra Hamra is offline
Junior Member
 
Join Date: Oct 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

thanks a lot for the help till
i did as you said, and restored all ownerships to webX:clientY, and chmodded the file, everything is working fine now.
thanks a lot.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig shows Apache 2 Test Page powered by CentOS onastvar Installation/Configuration 1 27th October 2009 16:23
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Tips/Tricks/Mods 1 30th September 2009 19:08
Install a Comodo InstantSSL Certificate for ISPconfig Apache, Postfix, Imap & Pop gwa7 Installation/Configuration 0 10th April 2009 05:54
ISPConfig kill apache and ports, not work ISPconfig JaBa Installation/Configuration 8 19th March 2009 18:51
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 01:45


All times are GMT +2. The time now is 01:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.