#1  
Old 28th September 2010, 02:47
Asharru Asharru is offline
Junior Member
 
Join Date: Sep 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Combining Tutorials

I have followed the guides for:
'The Perfect Server - Ubuntu Lucid Lynx (Ubuntu 10.04) [ISPConfig 2]'
'Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)'

However I am having problems getting PHPMYADMIN page to load (doesn't seem to have installed anywhere I can find it), and trying to log into Squirrelmail tells me that the username/password is wrong (the virtual mail folders are not being created in /home/vmail), etc.

Instead of trying to troubleshoot the separate issues, would it be possible to get a tutorial that combines the two above (without ISPConfig and DNS server)?
Reply With Quote
Sponsored Links
  #2  
Old 28th September 2010, 13:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by Asharru View Post
Instead of trying to troubleshoot the separate issues, would it be possible to get a tutorial that combines the two above (without ISPConfig and DNS server)?
If you don't need ISPConfig, then just follow the second tutorial (Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th September 2010, 08:46
Asharru Asharru is offline
Junior Member
 
Join Date: Sep 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
If you don't need ISPConfig, then just follow the second tutorial (Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)).
I had tried that four or five times before trying the Perfect Server guide. But just in case, I blew away the partitions, redid the "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 10.04)" and yet again I get "Connection dropped by IMAP server" and there is nothing in /home/vmail after sending a test email using mailx. From what I have seen on the forums here and searching on Google, this is a common issue, but none of the suggested resolutions seems to correct the issue.

What should I try next?
Reply With Quote
  #4  
Old 29th September 2010, 09:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,190
Thanks: 829
Thanked 5,418 Times in 4,260 Posts
Default

Please take a look into the log file /var/log/mail.log and post the error messages that you get there when you try to send a email to a local mailbox.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 29th September 2010, 20:03
Asharru Asharru is offline
Junior Member
 
Join Date: Sep 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Please take a look into the log file /var/log/mail.log and post the error messages that you get there when you try to send a email to a local mailbox.
Code:
Sep 29 10:57:27 optimus postfix/pickup[18938]: 82581280D7A: uid=0 from=<root>
Sep 29 10:57:27 optimus postfix/cleanup[19036]: 82581280D7A: message-id=<20100929175727.82581280D7A@asharru.net>
Sep 29 10:57:27 optimus postfix/qmgr[18425]: 82581280D7A: from=<root@asharru.net>, size=337, nrcpt=1 (queue active)
Sep 29 10:57:38 optimus postfix/smtpd[19046]: connect from localhost[127.0.0.1]
Sep 29 10:57:38 optimus postfix/trivial-rewrite[19039]: warning: do not list domain asharru.net in BOTH mydestination and virtual_mailbox_domains
Sep 29 10:57:38 optimus postfix/trivial-rewrite[19039]: warning: do not list domain asharru.net in BOTH mydestination and virtual_mailbox_domains
Sep 29 10:57:38 optimus postfix/smtpd[19046]: A14B0280D60: client=localhost[127.0.0.1]
Sep 29 10:57:38 optimus postfix/cleanup[19036]: A14B0280D60: message-id=<20100929175727.82581280D7A@asharru.net>
Sep 29 10:57:38 optimus postfix/qmgr[18425]: A14B0280D60: from=<root@asharru.net>, size=765, nrcpt=1 (queue active)
Sep 29 10:57:38 optimus postfix/trivial-rewrite[19039]: warning: do not list domain asharru.net in BOTH mydestination and virtual_mailbox_domains
Sep 29 10:57:38 optimus amavis[16630]: (16630-03) Passed CLEAN, <root@asharru.net> -> <asharru@asharru.net>, Message-ID: <20100929175727.82581280D7A@asharru.net>, mail_id: fDeA46b+pHRJ, Hits: -0.001, size: 337, queued_as: A14B0280D60, 11111 ms
Sep 29 10:57:38 optimus postfix/smtpd[19046]: disconnect from localhost[127.0.0.1]
Sep 29 10:57:38 optimus postfix/smtp[19040]: 82581280D7A: to=<asharru@asharru.net>, relay=127.0.0.1[127.0.0.1]:10024, delay=11, delays=0.17/0.02/0.01/11, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=16630-03, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as A14B0280D60)
Sep 29 10:57:38 optimus postfix/qmgr[18425]: 82581280D7A: removed
Sep 29 10:57:38 optimus postfix/local[19047]: A14B0280D60: to=<asharru@asharru.net>, relay=local, delay=0.17, delays=0.08/0.03/0/0.07, dsn=2.0.0, status=sent (delivered to mailbox)
Sep 29 10:57:38 optimus postfix/qmgr[18425]: A14B0280D60: removed
And when I next login, the system tells me :"You have new mail in /var/mail/asharru"
It should be creating it in the virtual mail folder in /home/vmail though

Last edited by Asharru; 30th September 2010 at 00:57.
Reply With Quote
  #6  
Old 30th September 2010, 01:17
Asharru Asharru is offline
Junior Member
 
Join Date: Sep 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Okay, got it. Took the domain name out of "mydestinations" in /etc/postfix/main.cf and restarted postfix. Folders are being created now.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perfect Server Setups/Upgrades Video Tutorials cvgeeks Suggest HOWTO 2 8th August 2010 00:03
ISPConfig video tutorials available lubos General 4 28th April 2010 09:04
Linux video tutorials Hans Desktop Operation 0 12th December 2009 12:29
A Couple Questions To Ask On Apache Tutorials giganet HOWTO-Related Questions 1 18th February 2009 21:26
perfect desktop tutorials srip HOWTO-Related Questions 1 28th December 2008 12:56


All times are GMT +2. The time now is 16:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.