#1  
Old 28th September 2010, 21:06
u4david u4david is offline
Member
 
Join Date: Nov 2009
Posts: 99
Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation suPHP Issues.Please help

SecurityException in Application.cpp:511: Unknown Interpreter: Premature end of script headers: index.php


This is my log files.

I'm sure it have to do with Suphpthat I enabled.
Any tips.

Some tips that i have in my head to may try
-disabling php globaly
-is php isnatlled at all
-config files?

Not sure what to do here.

Thank you
Reply With Quote
Sponsored Links
  #2  
Old 28th September 2010, 22:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

Please post the suphp.conf file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th September 2010, 22:32
u4david u4david is offline
Member
 
Join Date: Nov 2009
Posts: 99
Thanks: 1
Thanked 0 Times in 0 Posts
Post suphp.conf

[global]
;Path to logfile
logfile=/var/log/suphp/suphp.log

;Loglevel
loglevel=info

;User Apache is running as
webserver_user=www-data

;Path all scripts have to be in
docroot=/var/www:${HOME}/public_html

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=false

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=0022

; Minimum UID
min_uid=100

; Minimum GID
min_gid=100


[handlers]
;Handler for php-scripts
application/x-httpd-suphp="php:/usr/bin/php-cgi"

;Handler for CGI-scripts
x-suphp-cgi="execute:!self"
x-httpd-suphp=php:/usr/bin/php-cgi




ispconfig 3.0.2.2
ubuntu 10.04 LTS
Fresh install

Location /etc/suphp/suphp.conf
root is the owner and group
Reply With Quote
  #4  
Old 29th September 2010, 00:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

Please edit the line:

x-httpd-suphp=php:/usr/bin/php-cgi

in suphp.conf and change it to:

x-httpd-suphp="php:/usr/bin/php-cgi"

Then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 29th September 2010, 00:29
u4david u4david is offline
Member
 
Join Date: Nov 2009
Posts: 99
Thanks: 1
Thanked 0 Times in 0 Posts
Default that did not work

adding or removing the quotation = No results ,same error.

Last edited by u4david; 29th September 2010 at 00:57.
Reply With Quote
  #6  
Old 29th September 2010, 00:49
u4david u4david is offline
Member
 
Join Date: Nov 2009
Posts: 99
Thanks: 1
Thanked 0 Times in 0 Posts
Default how about this?

[handlers]
;Handler for php-scripts
application/x-httpd-suphp="php:/usr/bin/php-cgi"


and changing it to:
x-httpd-suphp="php:/usr/bin/php-cgi"

well I tell you if this worked or not

Is this mean that ISPconfig3 scripts fail to adjust this when installed?

Last edited by u4david; 29th September 2010 at 01:08.
Reply With Quote
  #7  
Old 29th September 2010, 01:42
u4david u4david is offline
Member
 
Join Date: Nov 2009
Posts: 99
Thanks: 1
Thanked 0 Times in 0 Posts
Default still no resolution

still not solved =same problem

please advise
Reply With Quote
  #8  
Old 29th September 2010, 10:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

Quote:
Is this mean that ISPconfig3 scripts fail to adjust this when installed?
This means that different suphp versions ahve different configuration file requirements. Most bersions dont need this setting to be in quotes while your version might require that. Thats why I asked you to test that.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 29th September 2010, 10:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

Please post the "ls -la" output for the index.php file which is causing this error.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 29th September 2010, 10:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
 
Default

Quote:
Originally Posted by u4david View Post
adding or removing the quotation = No results ,same error.
And you restarted the apache webserver after the changes? The changes get applied when apache is restarted.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Security - mod_php with FTP vs SuPHP or SuExec ethanlifka Installation/Configuration 1 22nd February 2010 11:18
suPHP 0.7.0 compatible with ISPConfig2 ? Hans Installation/Configuration 9 30th January 2009 13:52
Problem installing and configuring suPHP on Debian 4.0 Etch DirtyMonkey Installation/Configuration 5 2nd October 2008 13:18
Debian suPHP security patch pjdevries Installation/Configuration 8 21st May 2008 09:36
Goal: user separation (but apache can't read what suPHP wrote) berny Installation/Configuration 1 26th April 2008 19:22


All times are GMT +2. The time now is 21:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.