#1  
Old 25th September 2010, 00:21
dynaguy dynaguy is offline
Junior Member
 
Join Date: Aug 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default MailScanner ERROR

I setup a mail server followed the instruction here:
http://www.howtoforge.com/virtual-us...atch-centos5.1

So far everything seems fine. Lots spam mails has been catched. But in the maillog I see a lots errors:

Code:
Sep 24 15:19:06 zeta MailScanner[3229]: Clamd::ERROR:: UNKNOWN CLAMD RETURN ./razor-agent.log/Access denied. ERROR :: /var/spool/MailScanner/incoming/3229
How do I fix this error? Do I need manual install razor? Where is the razor-agent.log?

Please help. Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 25th September 2010, 00:27
dynaguy dynaguy is offline
Junior Member
 
Join Date: Aug 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default

There is another thing bothers me:
Code:
[root@zeta ~]# MailScanner --lint
......
MailScanner.conf says "Virus Scanners = clamd"
Found these virus scanners installed: clamd
===========================================================================
Filename Checks: Windows/DOS Executable (1 eicar.com)
Other Checks: Found 1 problems
Virus and Content Scanning: Starting
Clamd::INFECTED:: Eicar-Test-Signature :: ./1/
Clamd::INFECTED:: Eicar-Test-Signature :: ./1/eicar.com
Virus Scanning: Clamd found 2 infections
Infected message 1 came from 10.1.1.1
Virus Scanning: Found 2 viruses
===========================================================================
Virus Scanner test reports:
Clamd said "eicar.com was infected: Eicar-Test-Signature"

......
Reply With Quote
  #3  
Old 25th September 2010, 15:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Is Razor installed? What's the output of
Code:
updatedb
locate razor-agent.log
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 27th September 2010, 17:55
dynaguy dynaguy is offline
Junior Member
 
Join Date: Aug 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thank you falko for the reply.

Code:
[root@zeta /]# updatedb
[root@zeta /]# locate razor-agent.log
/var/spool/MailScanner/incoming/10086/razor-agent.log
/var/spool/MailScanner/incoming/10111/razor-agent.log
/var/spool/MailScanner/incoming/10717/razor-agent.log
I noticed:
Code:
[root@zeta /]# ps aux | grep MailScanner
postfix   4996  0.0  2.2  29984 23384 ?        Ss   Sep24   0:00 MailScanner: starting child
postfix  10086  0.0  5.1  68688 53044 ?        S    06:41   0:02 MailScanner: waiting for messages
postfix  10111  0.0  5.1  68680 53028 ?        S    06:44   0:02 MailScanner: waiting for messages
postfix  10717  0.0  5.1  68648 53156 ?        S    07:05   0:02 MailScanner: waiting for messages
postfix  14439  0.2  5.1  68184 52732 ?        S    08:37   0:01 MailScanner: waiting for messages
postfix  14496  0.7  5.0  68024 52472 ?        S    08:47   0:01 MailScanner: waiting for messages
root     14911  0.0  0.0   4004   704 pts/0    S+   08:52   0:00 grep MailScanner
So I have 5 instances of MailScanner but I only have 3 corresponding razor-agent.log files. Could this be the problem?
Reply With Quote
  #5  
Old 27th September 2010, 20:04
dynaguy dynaguy is offline
Junior Member
 
Join Date: Aug 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
Default

some updates:

1. It seems this ERROR message happens randomly. Some time happens, sometime doesn't.

2. I checked the permission and ownership of the log file:
Code:
[root@zeta ~]# ll /var/spool/MailScanner/incoming/
total 84
drwxr-x--- 2 postfix clamav   4096 Sep 27 10:51 2374
drwxr-x--- 2 postfix clamav   4096 Sep 27 10:52 2545
drwxr-x--- 2 postfix clamav   4096 Sep 27 10:07 2631
drwxr-x--- 2 postfix clamav   4096 Sep 27 10:51 2633
drwxr-x--- 2 postfix clamav   4096 Sep 27 10:51 2635
drwxr-x--- 2 postfix postfix  4096 Sep 27 09:25 Locks
-rwxrwxr-x 1 postfix clamav   4096 Sep 27 10:52 Processing.db
-rwxrwxr-x 1 postfix clamav  35840 Sep 27 10:52 SpamAssassin.cache.db
drwx------ 2 postfix clamav   4096 Sep 27 10:52 SpamAssassin-Temp
and
Code:
[root@zeta ~]# ll /var/spool/MailScanner/incoming/2545/
total 4
-rw------- 1 postfix postfix 796 Sep 27 10:52 razor-agent.log
3. I think Razor is a plugin of MailScanner. I did not install razor separately.

4. I really confused here: The error entry in maillog is from MailScanner. The ERROR seems from clamd (running as user clamav). And the razor-agent.log owned by user postfix. How this things(Postfix/MailScanner/Clamav/Spamassassin) working together? If it is a permission problem, why it doesn't happen all the time?
Reply With Quote
  #6  
Old 27th September 2010, 22:13
dynaguy dynaguy is offline
Junior Member
 
Join Date: Aug 2010
Posts: 8
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

I manually installed razor and razor-sdk. configured following instruction at http://wiki.apache.org/spamassassin/RazorSiteWide

So far the error seems gone. I'll keep monitor it and hope this solve the problem.
Reply With Quote
The Following User Says Thank You to dynaguy For This Useful Post:
falko (28th September 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CP210x USB to UART Bridge Linux VCP Drivers(SILICON Labs) perfectpol7 Kernel Questions 13 9th November 2010 07:30
Webmin upgrade lishaw1968 Installation/Configuration 15 26th August 2010 15:23
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
64-bit Debian 3.1 Install Issue naruto Installation/Configuration 14 5th September 2006 04:12
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 16:14


All times are GMT +2. The time now is 06:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.