Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th September 2010, 06:27
YbeddyJ YbeddyJ is offline
Junior Member
 
Join Date: Sep 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default The Perfect Server - Ubuntu 10.04 [ISPConfig 3]

I'm using the x86_64 server version and i'm getting the following errors after these cmds

aptitude install amavisd-new spamassassin clamav clamav-daemon zoo unzip bzip2 arj nomarch lzop cabextract apt-listchanges libnet-ldap-perl libauthen-sasl-perl clamav-docs daemon libio-string-perl libio-socket-ssl-perl libnet-ident-perl zip libnet-dns-perl
...
Setting up clamav-base (0.96.1+dfsg-0ubuntu0.10.04.1) ...
newaliases: fatal: open /etc/postfix/main.cf: No such file or directory

...
Setting up amavisd-new (1:2.6.4-1ubuntu5) ...
Creating/updating amavis user account...
Starting amavisd: head: cannot open `/etc/mailname' for reading: No such file or directory
amavisd-new.
.....
Configuring Jailkit
Configuring SASL
Configuring PAM
Configuring Courier
Configuring Spamassassin
Configuring Amavisd
PHP Warning: copy(/etc/postfix/main.cf): failed to open stream: No such file or directory in /tmp/ispconfig3_install/install/lib/installer_base
.lib.php on line 752
Configuring Getmail
Configuring Pureftpd
Configuring BIND
Configuring Apache
Configuring vlogger
Configuring Apps vhost
Configuring Firewall
Installing ISPConfig
ISPConfig Port [8080]:

.....

any ideas


(i did touch /etc/mailname but i'm not sure of its supposed contents, so i decided to ask here....even though it think it should be{example.com})
Reply With Quote
Sponsored Links
  #2  
Old 8th September 2010, 17:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,715
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

You missed to install postfix (step 12 of the tutorial).

http://www.howtoforge.com/perfect-se...ispconfig-3-p4

Execute all commands of step 12, then download ispconfig again, run the update.php script and select to reconfigure services during update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th September 2010, 21:14
YbeddyJ YbeddyJ is offline
Junior Member
 
Join Date: Sep 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
You missed to install postfix (step 12 of the tutorial).

http://www.howtoforge.com/perfect-se...ispconfig-3-p4

Execute all commands of step 12, then download ispconfig again, run the update.php script and select to reconfigure services during update.
actually i did do that step...
i'll copy /paste cmd again

aptitude install postfix postfix-mysql postfix-doc mysql-client mysql-server courier-authdaemon courier-authlib-mysql courier-pop courier-pop-ssl courier-imap courier-imap-ssl libsasl2-2 libsasl2-modules libsasl2-modules-sql sasl2-bin libpam-mysql openssl getmail4 rkhunter binutils maildrop
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done

maybe i need to reconfigure postfix then..i'm gonna try that now
Reply With Quote
  #4  
Old 9th September 2010, 19:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Please uninstall (purge) Postfix and then reinstall it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th September 2010, 14:14
YbeddyJ YbeddyJ is offline
Junior Member
 
Join Date: Sep 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default

ok i will do that but i did the dpkg-reconfigure and it seem fixed now.


my new problem is that when i <dig domaint.tld @serverip> i'm not getting any response, i checked /etc/bind/pri.domain.tld ad all seem to be fine. is there a reason for not using mydns?

;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 16572
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;domain.tld. IN A

;; Query time: 9 msec
;; SERVER: xx.xx.xx.xx#53(xx.xx.xx.xx)
;; WHEN: Fri Sep 10 07:09:34 2010
;; MSG SIZE rcvd: 32
Reply With Quote
  #6  
Old 11th September 2010, 13:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Does
Code:
dig @localhost yourdomain.com
work?

What's in your named.conf and /etc/bind/pri.domain.tld?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 22nd September 2010, 05:41
YbeddyJ YbeddyJ is offline
Junior Member
 
Join Date: Sep 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default

# dig @localhost xxx.xxx.xx

; <<>> DiG 9.7.0-P1 <<>> @localhost xxx.xxx.xx
; (2 servers found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 38883
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;xxx.xxx.xx IN A

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Sep 21 22:32:54 2010
;; MSG SIZE rcvd: 32



# cat /etc/bind/named.conf
// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
Reply With Quote
  #8  
Old 23rd September 2010, 14:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What's in /etc/bind/named.conf.options, /etc/bind/named.conf.local, and /etc/bind/named.conf.default-zones?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 4th October 2010, 05:09
blaisep blaisep is offline
Junior Member
 
Join Date: Oct 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default step 12: what if I picked "Yes" to directories?

Oooops... I think I screwed up step 12. I picked YES to the create directories question.
Is there a way to recover that or do I have to start over?

http://www.howtoforge.com/perfect-se...nx-ispconfig-3

Thanks!
Blaise

Last edited by blaisep; 4th October 2010 at 05:19. Reason: I meant ispconfig-3
Reply With Quote
  #10  
Old 5th October 2010, 16:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

That's not important - you can go on with the tutorial.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Howtoforge the perfect Server(links) rini90 Installation/Configuration 0 14th December 2008 10:58
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30


All times are GMT +2. The time now is 12:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.