Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 18th September 2010, 13:47
LinuxNoob LinuxNoob is offline
Junior Member
 
Join Date: Sep 2010
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail in wrong mailbox

Hi Guys,

I followed the following guide ( http://www.howtoforge.com/perfect-se...64-ispconfig-2 ) about 9 - 10 months ago. Prior to this, I was running Mandriva - and again was via a server setup guide via HowtoForge ( good work guys )

Current OpenSuse server has been running with no problems for the last 9 months or so - but yesterday I noticed that mail being sent to any of the 3 local domains are being delivered to just 1 catch-all account ( other domains also have catch all's and no forwards in place ) they are received in the catch-all on web1 even though the mail is addressed to domains within web2 web3 etc.

I've searched the forums and found a lot of posts relating to the same sort of issue, and that this was being referenced to an issue in with /etc/postfix/main.cf
referencing $mydomain

Would someone be able to help me out with this weird issue as I cant seem to find the problem - and this server, and mail has been running fine for 9 months. I havent changed / amended anything, and cant see any recent updates from my Disto that has amended anything relating to postfix.

Thanks

Edit - adding main.cf - i have changed the domain to mydomain.co.uk

Code:
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
virtual_alias_domains = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = fury.mydomain.co.uk
delay_warning_time = 1h
message_strip_characters = \0
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
mynetworks_style = subnet
disable_dns_lookups = no
relayhost =
content_filter =
mailbox_command =
mailbox_transport =
strict_8bitmime = no
disable_mime_output_conversion = no
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 0
mydomain = mydomain.co.uk
mynetworks = 127.0.0.0/8
relayhost = cluster8out.eu.messagelabs.com
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

Last edited by LinuxNoob; 18th September 2010 at 13:53. Reason: adding main.cf
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot send or receive mail after setup 50CentOS HOWTO-Related Questions 3 11th June 2010 15:10
Sending emails with custom FROM email address merisor Installation/Configuration 4 8th February 2010 16:27
Need help get mail to work (can't recieve and apperently can't send) omega13a Installation/Configuration 19 20th August 2009 21:06
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39


All times are GMT +2. The time now is 00:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.