Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th September 2010, 18:37
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default [SOLVED] postfix-policy pb with How to:iRedMail 0.6.1: Mail Server On Ubuntu 10.04

I tried to install IRedMail on ubuntu 10.04 (server edition x64) following the how to which titile in the thread title.

It stopped before end of configuration with a (google well known) problem of postfix-policyd. My terminal output is:

Code:
Errors were encountered while processing:
 postfix-policyd
E: Sub-process /usr/bin/dpkg returned an error code (1)
< ERROR > Installation failed, please check the terminal output.
As this how to is dedicated to ubuntu 10.04 and last revision of IRedMail, I wonder if something could have been forgot in the how to or there is still persistent problem between postfix-policyd and ubuntu 10.04 ?

REgards

Snarf

Last edited by snarf77; 17th September 2010 at 11:22. Reason: thread is solved
Reply With Quote
Sponsored Links
  #2  
Old 17th September 2010, 02:37
ZhangHuangbin ZhangHuangbin is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Did you run 'apt-get update' and 'apt-get upgrade' before install?
Reply With Quote
  #3  
Old 17th September 2010, 07:56
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default

Yes as always when I did a fresh install...

>> sudo apt-get update && apt-get upgrade....

Did you personnally follow this how to and succeed to go through this configuration step ?

thanks for further replies....

Snarf
Reply With Quote
  #4  
Old 17th September 2010, 07:59
ZhangHuangbin ZhangHuangbin is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Then try this installation guide:
http://code.google.com/p/iredmail/wi...tion_on_Ubuntu
Reply With Quote
  #5  
Old 17th September 2010, 09:08
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default

Thanks for the link.

I quickly had a look inside but don't see much differences in the first steps of installation compared to the how to in how to forge. I guess doing the same things will produce same effects ...

Perhaps I will try the link inside to get help from IRedMAil people in parallel ...

Thanks again

Snarf
Reply With Quote
  #6  
Old 17th September 2010, 09:12
ZhangHuangbin ZhangHuangbin is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default

As i mentioned, "apt-get update" and "apt-get upgrade" is required before install iRedMail. that's the point.
Reply With Quote
The Following User Says Thank You to ZhangHuangbin For This Useful Post:
snarf77 (17th September 2010)
  #7  
Old 17th September 2010, 10:01
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default

I get the point but as I said I did it for sure...

Anyway, let's do another try with your tuto and I'll give feedback within hours...

thanks

Snarf
Reply With Quote
  #8  
Old 17th September 2010, 11:20
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
Default

Second trial was the good one...

Now installation is completed.

The only difference I have noticed is that this time I install ubuntu with only ssh server as installation option package. Last time I used ssh server and lamp server.

I guess mysql install could be at the problem origin ????

If that is the problem I think that the "recommendation" concerning a "light" install of Ubuntu can be perhaps modified into a "mandatory" one

anyway it's working fine now following the main how to forge tutorial.

Thanks for your help

Snarf
Reply With Quote
  #9  
Old 17th September 2010, 11:27
ZhangHuangbin ZhangHuangbin is offline
Junior Member
 
Join Date: Apr 2009
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default

In official installation guide, it contains a warning message:
Code:
***************************** WARNING ********************************
* iRedMail is designed to deploy on a FRESH server system, which     *
* means it doesn't have mail related components installed, e.g.      *
* Apache, MySQL, OpenLDAP, Postfix, Dovecot, Amavisd, etc. Otherwise *
* it may override your existing files/configurations althought it    *
* will backup files before modify.                                   *
***************************** WARNING ********************************
Reply With Quote
  #10  
Old 17th September 2010, 11:35
snarf77 snarf77 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 14
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

Yes that is more detailed in your link than the initial how to forge tuto...But you're right I've been to quick on that remark.

Nevertheless perhaps it's my english (sorry for being french) but I understand the line
Quote:
Otherwise *
* it may override your existing files/configurations althought it *
* will backup files before modify.
as it will erase all previous installation (ie I will lose existing data) but not that it can't install...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47


All times are GMT +2. The time now is 22:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.