#1  
Old 16th September 2010, 21:10
cante93 cante93 is offline
Junior Member
 
Join Date: Sep 2010
Location: Switzerland
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question Getmail problem

hello, follow the tutorial http://www.howtoforge.com/perfect-se...nx-ispconfig-3 I could install everything is ok.
The only problem is that getmail does not transfer messages from the server of my ISP to the local users.
In the log file cronjob I reads:

Deprecated PHP:Comments starting with '#' are deprecated in / etc/php5/cli/conf.d/mcrypt.ini online 1 in Unknown on line 0
Deprecated PHP: Comments starting with '#' are deprecated in / etc/php5/cli/conf.d/imagick.ini in Unknown on line 1 on line 0 "

which is repeated continuously for several pages.

I think its the wrong configuration GetMail.

Forgive me if I write a number of errors, but my mother tongue is not English.
Reply With Quote
Sponsored Links
  #2  
Old 17th September 2010, 01:49
matty matty is offline
Member
 
Join Date: Apr 2010
Location: Australia
Posts: 85
Thanks: 2
Thanked 12 Times in 11 Posts
Default

I have no idea about those erors, but when I tried setting up getmail through the ISPC3 interface, I didn't have much luck as it's setup to deliver to only one mailbox. I needed to come up with my own configuration to distribute to many mailboxes. Try changing (or creating) the file /etc/getmail/<whatever>.conf to the following:

Code:
[options]
message_log_syslog = 1
delivered_to = false
# Change this to delete = 1 to remove messages from server
delete = 0

[retriever]
type = MultidropPOP3Retriever
server = pop3.example.com
username = user@example.com
password = thepassword
envelope_recipient = Envelope-to:1

[destination]
type = MDA_external
path = /usr/sbin/sendmail
arguments = ("-i", "-bm", "%(recipient)")
unixfrom = true
I also had to add the following to the top of /etc/postfix/header_checks
Change it to suit your own domain/s.
Code:
# Getmail doesn't like it if "Delivered-To" exists prior to processing.
# Change the line to be X-Delivered-To instead
/^(Delivered-To:.*@example\.com\.au)$/ REPLACE X-$1
Reply With Quote
  #3  
Old 17th September 2010, 08:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Quote:
Originally Posted by cante93 View Post
hello, follow the tutorial http://www.howtoforge.com/perfect-se...nx-ispconfig-3 I could install everything is ok.
The only problem is that getmail does not transfer messages from the server of my ISP to the local users.
In the log file cronjob I reads:

Deprecated PHP:Comments starting with '#' are deprecated in / etc/php5/cli/conf.d/mcrypt.ini online 1 in Unknown on line 0
Deprecated PHP: Comments starting with '#' are deprecated in / etc/php5/cli/conf.d/imagick.ini in Unknown on line 1 on line 0 "

which is repeated continuously for several pages.

I think its the wrong configuration GetMail.

Forgive me if I write a number of errors, but my mother tongue is not English.
Regarding the php messages, thats a known bug in Ubuntu and will be hopefully fixed with one of the next ubuntu updates. These errors are uncritical and not related to getmail, they can be ignored.

Regarding your getmail error, please atke a look into the mail.log file and post the errors that you get there from getmail.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 17th September 2010, 21:28
cante93 cante93 is offline
Junior Member
 
Join Date: Sep 2010
Location: Switzerland
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default I think....

Quote:
Originally Posted by till View Post
Regarding the php messages, thats a known bug in Ubuntu and will be hopefully fixed with one of the next ubuntu updates. These errors are uncritical and not related to getmail, they can be ignored.

Regarding your getmail error, please atke a look into the mail.log file and post the errors that you get there from getmail.
Sep 17 19:14:09 server amavis[978]: starting. /usr/sbin/amavisd-new at server amavisd-new-2.6.4 (20090625), Unicode aware
Sep 17 19:14:09 server amavis[978]: Perl version 5.010001
Sep 17 19:14:11 server spamd[1264]: logger: removing stderr method
Sep 17 19:14:18 server spamd[1269]: spamd: server started on port 783/tcp (running version 3.3.1)
Sep 17 19:14:18 server spamd[1269]: spamd: server pid: 1269
Sep 17 19:14:18 server spamd[1269]: spamd: server successfully spawned child process, pid 1274
Sep 17 19:14:18 server spamd[1269]: spamd: server successfully spawned child process, pid 1275
Sep 17 19:14:18 server spamd[1269]: prefork: child states: II
Sep 17 19:14:35 server authdaemond: modules="authmysql", daemons=5
Sep 17 19:14:35 server authdaemond: Installing libauthmysql
Sep 17 19:14:35 server authdaemond: Installation complete: authmysql
Sep 17 19:14:37 server postfix/master[1800]: daemon started -- version 2.7.0, configuration /etc/postfix
Sep 17 19:36:17 server postfix/qmgr[1808]: 114CC1AA03D5: removed
Sep 17 20:24:37 server postfix/qmgr[1808]: B3D8A1AA1A11: from=<info@mydomain.net>, size=677, nrcpt=1 (queue active)
Sep 17 20:24:37 server postfix/qmgr[1808]: 8E5731AA1A0D: from=<luca@mydomain.net>, size=698, nrcpt=1 (queue active)
Sep 17 20:24:37 server postfix/qmgr[1808]: 5EF2D1AA1A0C: from=<getmail@server>, size=3530, nrcpt=1 (queue active)
Sep 17 20:24:37 server postfix/qmgr[1808]: 5683C1AA1A07: from=<www-data@server>, size=552, nrcpt=1 (queue active)
Sep 17 20:24:37 server postfix/qmgr[1808]: 59B331AA1A24: from=<luca@mydomain.net>, size=677, nrcpt=1 (queue active)
Sep 17 20:24:37 server postfix/qmgr[1808]: 486FB1AA1A08: from=<getmail@server>, size=3530, nrcpt=1 (queue active)
Sep 17 20:24:37 server postfix/qmgr[1808]: 452251AA19FB: from=<info@mydomain.net>, size=850, nrcpt=1 (queue active)
Sep 17 20:24:37 server postfix/qmgr[1808]: 6C7C81AA19F5: from=<www-data@server>, size=552, nrcpt=1 (queue active)
Sep 17 20:24:37 server postfix/smtp[21137]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 17 20:24:37 server postfix/smtp[21138]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 17 20:24:37 server postfix/smtp[21138]: 8E5731AA1A0D: to=<info@mydomain.net>, relay=none, delay=256002, delays=256002/0.04/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 17 20:24:37 server postfix/smtp[21137]: B3D8A1AA1A11: to=<info@mydomain.net>, relay=none, delay=255785, delays=255785/0.02/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 17 20:24:37 server postfix/smtp[21138]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 17 20:24:37 server postfix/smtp[21137]: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused
Sep 17 20:24:37 server postfix/smtp[21138]: 5EF2D1AA1A0C: to=<luca@mydomain.net>, relay=none, delay=256172, delays=256172/0.14/0.01/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 17 20:24:37 server postfix/smtp[21137]: 5683C1AA1A07: to=<info@mydomain.net>, relay=none, delay=256322, delays=256322/0.15/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 17 20:24:37 server postfix/error[21142]: 59B331AA1A24: to=<luca@mydomain.net>, relay=none, delay=254496, delays=254496/0.2/0/0.05, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 17 20:24:37 server postfix/error[21144]: 452251AA19FB: to=<luca@mydomain.com>, relay=none, delay=256083, delays=256083/0.23/0/0.04, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 17 20:24:37 server postfix/error[21143]: 486FB1AA1A08: to=<info@mydomain.net>, relay=none, delay=256173, delays=256173/0.21/0/0.07, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 17 20:24:37 server postfix/error[21146]: 6C7C81AA19F5: to=<luca@mydomain.net>, relay=none, delay=256375, delays=256375/0.24/0/0.07, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
Sep 17 20:27:57 server postfix/scache[21141]: statistics: start interval Sep 17 20:24:37
Sep 17 20:27:57 server postfix/scache[21141]: statistics: domain lookup hits=0 miss=2 success=0%
Sep 17 20:27:57 server postfix/scache[21141]: statistics: address lookup hits=0 miss=2 success=0%

but, I think is an amavis problem....
Reply With Quote
  #5  
Old 18th September 2010, 09:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

The problem is that mavis is not started, please start amavis to fix the problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 19th September 2010, 16:34
cante93 cante93 is offline
Junior Member
 
Join Date: Sep 2010
Location: Switzerland
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question

Quote:
Originally Posted by till View Post
The problem is that mavis is not started, please start amavis to fix the problem.
how can I start amavis?
Reply With Quote
  #7  
Old 20th September 2010, 14:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
 
Default

Try
Code:
/etc/init.d/amavisd restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
BIG Problem Postfix issue admins Installation/Configuration 11 13th November 2009 10:05
TLS Problem admins Installation/Configuration 1 19th September 2009 10:55
postfix mysql on fedora core5 igongora Installation/Configuration 7 17th April 2007 04:40
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56


All times are GMT +2. The time now is 06:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.