Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 19th April 2006, 16:29
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Falko,

Just did as requested. Redo the 'Postfix/saslauthd' configuration from "Perfect Setup".

Still having the same problem:
================================================== ========
Sending failed:
Authentication failed.
Most likely the password is wrong.
The server responded: "Error: authentication failed"
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
PLANIMA
================================================== ========
I'm really stucked! HELP

Jaf Faizal
jaf@mileswork.com
+6012-210-1991
Reply With Quote
Sponsored Links
  #32  
Old 19th April 2006, 21:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by jaffaizal
Still having the same problem:
================================================== ========
Sending failed:
Authentication failed.
Most likely the password is wrong.
The server responded: "Error: authentication failed"
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
PLANIMA
================================================== ========
I'm really stucked! HELP
I've never seen an error like this before. When you followed the tutorial, did you copy & paste the commands? Maybe you have a typo somewhere...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #33  
Old 22nd April 2006, 21:55
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Falko,

This is what I did (executed each line one-by-one):
=====================

apt-get install cyrus-sasl cyrus-sasl-crammd5 cyrus-sasl-devel cyrus-sasl-digestmd5 cyrus-sasl-gssapi cyrus-sasl-otp cyrus-sasl-plain cyrus-sasl-saslauthd

chkconfig --add saslauthd

/etc/init.d/saslauthd start

mkdir /etc/postfix/ssl

cd /etc/postfix/ssl/

openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024

chmod 600 smtpd.key

openssl req -new -key smtpd.key -out smtpd.csr

openssl x509 -req -days 3650 -in smtpd.csr -signkey smtpd.key -out smtpd.crt

openssl rsa -in smtpd.key -out smtpd.key.unencrypted

mv -f smtpd.key.unencrypted smtpd.key

openssl req -new -x509 -extensions v3_ca -keyout cakey.pem -out cacert.pem -days 3650

postconf -e 'mydomain = mileswork.com'

postconf -e 'myhostname = suse1.$mydomain'

postconf -e 'smtpd_sasl_local_domain ='

postconf -e 'smtpd_sasl_auth_enable = yes'

postconf -e 'smtpd_sasl_security_options = noanonymous'

postconf -e 'broken_sasl_auth_clients = yes'

postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains'

postconf -e 'inet_interfaces = all'

postconf -e 'alias_maps = hash:/etc/aliases'

postconf -e 'smtpd_tls_auth_only = no'

postconf -e 'smtp_use_tls = yes'

postconf -e 'smtpd_use_tls = yes'

postconf -e 'smtp_tls_note_starttls_offer = yes'

postconf -e 'smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key'

postconf -e 'smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt'

postconf -e 'smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem'

postconf -e 'smtpd_tls_loglevel = 1'

postconf -e 'smtpd_tls_received_header = yes'

postconf -e 'smtpd_tls_session_cache_timeout = 3600s'

postconf -e 'tls_random_source = dev:/dev/urandom'

=====================

After restarting postfix and
telnet localhost 25 and
ehlo localhost,
this is what I get:
=====================

suse1:~ # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 suse1.mileswork.com ESMTP Postfix
ehlo localhost
250-suse1.mileswork.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME

=====================

BTW, in ISPConfig.

1. Management TAB/Server/Settings:
Server Name : Suse1
Hostname : suse1
Domain : mileswork.com

And, in KMail. SMTP settings tabs.

1. Is it Port 25?
2. Server requires authentication selected. Used the same Login/Password as for POP setting.
3. Under the Security Tabs - Encryption = NONE, Authentication Method = LOGIN.
4. In the Sending Tab, do I set, Message Property = "Allow 8-bit" OR "MIME Compliant (Quoted Printable)"?

Is the above settings in KMail correct?

Thanks
Reply With Quote
  #34  
Old 23rd April 2006, 18:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by jaffaizal
1. Is it Port 25?
Yes.

Quote:
Originally Posted by jaffaizal
2. Server requires authentication selected. Used the same Login/Password as for POP setting.
Correct.

Quote:
Originally Posted by jaffaizal
3. Under the Security Tabs - Encryption = NONE, Authentication Method = LOGIN.
Should work like that.

Quote:
Originally Posted by jaffaizal
4. In the Sending Tab, do I set, Message Property = "Allow 8-bit" OR "MIME Compliant (Quoted Printable)"?
Don't know about this one as I don't use KMail, but I don't think it has something to do with your problem.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #35  
Old 23rd April 2006, 20:39
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

What about the installation steps? Are they correct? Else... how else can I check to rectify my problems. OR is there a possibility of you logging into my system?

My clients using Outlook Express/Outlook is also experiencing the same problem I am experiencing.

BTW, GMAIL set to port 465. Do I set to port 465 as well?

Falko... appreciate your help. I do not want to jump onto another platform to manage my hosting.

Thanks.
Reply With Quote
  #36  
Old 24th April 2006, 10:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

Quote:
Originally Posted by jaffaizal
What about the installation steps? Are they correct?
This:
Code:
postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains'
should be
Code:
postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains'
Quote:
Originally Posted by jaffaizal
OR is there a possibility of you logging into my system?
We would have to charge you for that kind of support: http://www.ispconfig.org/support.htm

Quote:
Originally Posted by jaffaizal
BTW, GMAIL set to port 465. Do I set to port 465 as well?
No.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
Relay access denied maxx Installation/Configuration 17 4th April 2011 12:34
Can Send Email, But Not Recieve; Relay access denied jazzgillum Installation/Configuration 21 31st May 2007 12:46
relay access denied (i've readen the previous post about this ) jeanjacquesjeanjacques Installation/Configuration 5 21st April 2006 23:34
Relay access denied KamiTsunami Server Operation 6 7th March 2006 10:25


All times are GMT +2. The time now is 05:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.