Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th August 2010, 16:16
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default relay domain + Spam filter + Local postbox

Hi,

I'm using latest version of Ispconifg 3.

This is what I have:
Scanning for viruses + spam
Relay Email Domain to Customers SMTP (Customer has own SMTP host)

This what I like to have:
Scanning for viruses + spam
if spam or Virus-> put to local mailbox (doesn't need to be customers Domain - just a specific mailbox)
Relay Email Domain to Customers SMTP

Is such a setup possible? And if howto?

Many thanks for any hint

Patrick

Last edited by carg; 30th August 2010 at 16:50. Reason: some changes
Reply With Quote
Sponsored Links
  #2  
Old 31st August 2010, 09:03
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Create records for the email addresses or email domains of the forwarded accounts in ispconfig under email > spamfilter > user/domain

Then edit the spamfilter policy that you selected for this email address or domain and enter the target email address for the spam emails in the field "Forward spam to email".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 31st August 2010, 13:05
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi Till,

many thanks for the answer - sometimes it's simple BUT
the forwarding is not working. The subject is marked as spam (I set the Spam values to -9) but delivered normal way. It should get forwared to the account given at the filter. In maillog I can see that it gets normal out which it should not as the forward address is a local postbox (spam@somedomain.com).
Any idea where to look at?

Cheers, Patrick
Reply With Quote
  #4  
Old 31st August 2010, 13:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Enable debugging in amavisd and then check which rules get applied and if your plicy gets selected for a specific email. See amavisd.conf or the 50-user file on debian / ubuntu for log level settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 31st August 2010, 16:59
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

after switching the level to 5 (btw. bad idea to have the same variable 2 times in the same script -> last one matches ..) the sql showed me that it has the right rule: policy_name=>"Spambox". All the settings are from that rule like subject rewrite etc. I can see that the email where to forward the mail to is there as well. (spam_quarantine_to=>"spam-admin@spamadmindomain.com" )
spam_tag_level=>"-10", spam_tag2_level=>"-5" this makes sure that more or less every email will be spam (good for testing). The email get the spam header + subject etc. etc.
Everything is looking fine but the last rewrite to the "spam-admin" email I can't see anywhere.
Code:
----
lookup [spam_subject_tag2] => true,  "support@todomain.zz" matches, result="*S _SCORE_* X", matching_key="/cached/"
headers CLUSTERING: NEW CLUSTER <support@todomain.zz>: score=0.1, tag=1, tag2=1, local=1, bl=, s=*S 0.1* X, mangle=
header: X-Virus-Scanned: amavisd-new at co4.mailhost.zz\n
header: X-Spam-Flag: YES\n
header: X-Spam-Score: 0.1\n
header: X-Spam-Level: \n
header: X-Spam-Status: Yes, score=0.1 tagged_above=-10 required=-5\n\ttests=[RDNS_NONE=0.1] autolearn=no\n
header: Received: from co4.mailhost.zz ([127.0.0.1])\n\tby localhost (co4.mailhost.zz [127.0.0.1]) (amavisd-new, port 10024)\n\twith ESMTP id i51hHhuKsDOr for <support@todomain.zz>;\n\tTue, 31 Aug 2010 14:56:36 +0200 (CEST)\n
headers CLUSTERING: done all 1 recips in one go
SPAM-TAG, <a@fromdomain.zz> -> <support@todomain.zz>, Yes, score=0.1 tagged_above=-10 required=-5 tests=[RDNS_NONE=0.1] autolearn=no
(about to connect to [127.0.0.1]:10025) FWD via SMTP: <a@fromdomain.zz> -> <support@todomain.zz>
----
Can you point my nose where I should look at please?

Cheers, Patrick

ps.: found this http://howtoforge.net/forums/showthread.php?p=238105 same problem

Last edited by carg; 31st August 2010 at 18:57. Reason: found something ...
Reply With Quote
  #6  
Old 1st September 2010, 17:54
carg carg is offline
Junior Member
 
Join Date: Aug 2010
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Hi,

I installed a fresh Debian + ISPconfig 3
the forward is not working there as well.

Any further ideas?

Cheers, Patrick
Reply With Quote
Reply

Bookmarks

Tags
relay domain, spam filter

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot send or receive mail farbrorc Installation/Configuration 6 24th January 2010 12:56
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 14:06
Postfix - Relay access denied gotting Server Operation 3 23rd April 2008 15:06
php eating cpu shajazzi Server Operation 15 15th August 2007 02:19
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 12:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.