Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th August 2010, 21:02
chr1s_at chr1s_at is offline
Junior Member
 
Join Date: Aug 2010
Location: Vienna, Austria
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default PureFTP Problem - Won't start, no errors

Hey guys!

First let me say that I find ISPConfig totally amazing. Im using it for 5 years when I started my garage-project company.

My company expanded and I just bought another server on which I'll be using ISPConfig 3

I set it up by following all steps on the Perfect Setup for Debian Lenny and everything is working..

well.. except for PureFTP and I have no clue why..


I installed everything without getting an error, the mysql database is up and running. ISPConfig says that the FTP Server is offline.. Im starting it like this:

Code:
debian:~# /etc/init.d/pure-ftpd-mysql start
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -O clf:/var/log/pure-ftpd/transfer.log -H -u 1000 -E -Y 1 -A -B
lvps83-169-37-161:~#
All log files are empty, no error messages and the port is not in use.. but the server simply isnt running

Has anyone any clues?
Reply With Quote
Sponsored Links
  #2  
Old 30th August 2010, 22:30
damir damir is offline
Senior Member
 
Join Date: Jun 2006
Posts: 375
Thanks: 11
Thanked 51 Times in 42 Posts
Default

Make sure that your /etc/default/pure-ftpd-common contains:

Code:
STANDALONE_OR_INETD=standalone
VIRTUALCHROOT=true
Open /etc/inetd.conf and uncomment following line and restart inetd:

Code:
ftp    stream  tcp     nowait  root    /usr/sbin/tcpd /usr/sbin/pure-ftpd-wrapper
Code:
/etc/init.d/openbsd-inetd restart

Last thing is if you are on VPS like OpenVZ than you need to recompile pureftpd without capabilities enabled.

http://www.faqforge.com/linux/contro...ities-enabled/
Reply With Quote
  #3  
Old 30th August 2010, 22:40
chr1s_at chr1s_at is offline
Junior Member
 
Join Date: Aug 2010
Location: Vienna, Austria
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by damir View Post
Open /etc/inetd.conf and uncomment following line and restart inetd:[..]

I have to uncomment this line? cause in the perfect setup it says "comment out"..

But I just tried to uncomment it and it seems like the server started.. but if I connect it says

Code:
Can't exec "/usr/sbin/pure-ftpd": No such file or directory at /usr/sbin/pure-ftpd-wrapper line 174.
/usr/sbin/pure-ftpd-wrapper: Cannot exec /usr/sbin/pure-ftpd: No such file or directory at /usr/sbin/pure-ftpd-wrapper line 174.
everything else is set up according to the perfect setup
Reply With Quote
  #4  
Old 30th August 2010, 23:01
damir damir is offline
Senior Member
 
Join Date: Jun 2006
Posts: 375
Thanks: 11
Thanked 51 Times in 42 Posts
Default

Yes you need to remove # in front of the line and than restart the intetd.

Are you on OpenVZ?
Reply With Quote
  #5  
Old 31st August 2010, 08:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

1) Which Linux distribution do you use?
2) Which tutorial did you use to install the server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 31st August 2010, 08:30
chr1s_at chr1s_at is offline
Junior Member
 
Join Date: Aug 2010
Location: Vienna, Austria
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm using debian Lenny and did everything according to the Perfect Setup Debian 5 + ISPConfig3 tutorial

I'm not using any virtualization software
Reply With Quote
  #7  
Old 31st August 2010, 08:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

Quote:
I have to uncomment this line? cause in the perfect setup it says "comment out"..
Thats the same. It means that you shall add a # in fron of the line.

Quote:
I'm using debian Lenny and did everything according to the Perfect Setup Debian 5 + ISPConfig3 tutorial
ok. It seems that pure-ftpd is not fully installed as the pure-ftpd binary is missing please reinstall pure-ftpd with this command:

Code:
apt-get install --reinstall pure-ftpd-common pure-ftpd-mysql
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 31st August 2010, 22:38
chr1s_at chr1s_at is offline
Junior Member
 
Join Date: Aug 2010
Location: Vienna, Austria
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
ok. It seems that pure-ftpd is not fully installed as the pure-ftpd binary is missing please reinstall pure-ftpd with this command:

Code:
apt-get install --reinstall pure-ftpd-common pure-ftpd-mysql
Interesting.. it seems like theres a problem while (re)installing..


Code:
debian:~# apt-get install --reinstall pure-ftpd-common pure-ftpd-mysql
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0B/173kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]?
Preconfiguring packages ...
(Reading database ... 37291 files and directories currently installed.)
Preparing to replace pure-ftpd-common 1.0.21-11.4 (using .../pure-ftpd-common_1.0.21-11.4_all.deb) ...
Unpacking replacement pure-ftpd-common ...
Setting up pure-ftpd-common (1.0.21-11.4) ...
Setting up pure-ftpd-mysql (1.0.21-11.4) ...
Starting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -b -O clf:/var/log/pure-ftpd/transfer.log -H -u 1000 -E -Y 1 -A -B
invoke-rc.d: initscript pure-ftpd-mysql, action "start" failed.
dpkg: error processing pure-ftpd-mysql (--configure):
 subprocess post-installation script returned error exit status 252
Errors were encountered while processing:
 pure-ftpd-mysql
E: Sub-process /usr/bin/dpkg returned an error code (1)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix/trivial-rewrite digitalage HOWTO-Related Questions 19 13th March 2013 19:02
TLS Problem admins Installation/Configuration 1 19th September 2009 10:55
Problem: Pureftpd won't start! (Fedora 7) tanakskool HOWTO-Related Questions 3 19th October 2007 13:06
/sbin/service vz start -- problem starting miltongoh Installation/Configuration 1 18th June 2006 13:42
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06


All times are GMT +2. The time now is 20:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.