Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th August 2010, 21:53
michaeldasilvapereira michaeldasilvapereira is offline
Junior Member
 
Join Date: Aug 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default mod_speling ubuntu + ispconfig3

Hi there,

I have a issue with a few sites I'd like to move from a windows server to a ispconfig server. Mostly static html content, but with FuNkY CasE problems.

I'm having an issue using mod_speling, I've spent a lot of time trying to find a solution / fix. So far I have got nothing

I have enabled the module:
# cat mods-enabled/speling.load
LoadModule speling_module /usr/lib/apache2/modules/mod_speling.so
CheckSpelling on

I haven't seen anything in the apache logs, I have no clue what I'm doing wrong. Any Ideas?

Thanks,
Mike
Reply With Quote
Sponsored Links
  #2  
Old 26th August 2010, 09:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,424
Thanks: 812
Thanked 5,205 Times in 4,081 Posts
Default

Try to add the line:

CheckSpelling on

in the apache directives field of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th August 2010, 09:18
michaeldasilvapereira michaeldasilvapereira is offline
Junior Member
 
Join Date: Aug 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have tried putting it in the vhost file in sites-available/.
Still nothing

Vhost below:
<Directory /var/www/xxxxx.com>
CheckSpelling on
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<VirtualHost *:80>
DocumentRoot /var/www/xxxxx.com/web

ServerName xxxxx.com
ServerAlias www.xxxxx.com
ServerAdmin webmaster@xxxxx.com

ErrorLog /var/log/ispconfig/httpd/xxxxx.com/error.log

CheckSpelling on


<Directory /var/www/xxxxx.com/web>
CheckSpelling on
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web1/web>
CheckSpelling on
Options FollowSymLinks
AllowOverride All
Order allow,deny
Allow from all
</Directory>

# suexec enabled
SuexecUserGroup web1 client1
# Clear PHP settings of this website
<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>
# php as fast-cgi enabled
<IfModule mod_fcgid.c>
# SocketPath /tmp/fcgid_sock/
IdleTimeout 3600
ProcessLifeTime 7200
# MaxProcessCount 1000
DefaultMinClassProcessCount 3
DefaultMaxClassProcessCount 100
IPCConnectTimeout 8
IPCCommTimeout 360
BusyTimeout 300
</IfModule>
<Directory /var/www/xxxxx.com/web>
CheckSpelling on
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>
<Directory /var/www/clients/client1/web1/web>
CheckSpelling on
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web1/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride All
Order allow,deny
Allow from all
</Directory>

# add support for apache mpm_itk
<IfModule mpm_itk_module>
AssignUserId web1 client1
</IfModule>

</VirtualHost>
Reply With Quote
  #4  
Old 11th December 2012, 22:58
d4kr d4kr is offline
Junior Member
 
Join Date: Nov 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

hi,

I have the same issue, did you find a solutions?
thx
dk
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem send/receive Courier+Postfix+Squirrelmail Pirk Installation/Configuration 2 21st May 2010 13:26
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 20:31
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 13:49
ISPConfig3 mail issues warlock Developers' Forum 19 26th January 2009 10:34


All times are GMT +2. The time now is 09:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.