#1  
Old 31st July 2010, 15:15
PeekNPoke PeekNPoke is offline
Junior Member
 
Join Date: Jul 2010
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Unhappy Reverse DNS

Hi all,

Ok, before I get flamed. I've read about reverse DNS for the last week. I've also checked on this forum for answers, but with no luck.

My problem is that I configure ISPConfig 3 with PTR records to point to my domain on the server, but it still doesn't get resolved locally on the box and remotely from some other box. Obviously this means I'm not configuring my DNS PTR record correctly.

The hosting company I host my server with setup NS records that point to my server so I can resolve the in-addr.arpa address my self. The problem is ... how the hell do you do that. I've created PTR records on the domain I've setup on ISPConfig under the DNS tab. But it still doesn't resolve.

I'm totally out of my depth now, and don't know how to go forward anymore.

I've created the PTR record like so :

Name : 194.72.45.204.in-addr.arpa.
Canonical Hostname : ns2.unad.co.za.
TTL : 86400
Active : Checked

No matter if I change them arround or not. I can't get 'n "dig @localhost -x 204.45.72.194" or a "host 204.45.72.194" or a "nslookup 204.45.72.194" to return any result.

I obviously don't understand what I'm doing. Can anybody please give me a pointer or two ... please please please ....

Last edited by PeekNPoke; 31st July 2010 at 15:20.
Reply With Quote
Sponsored Links
  #2  
Old 1st August 2010, 17:43
PeekNPoke PeekNPoke is offline
Junior Member
 
Join Date: Jul 2010
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default

Anybody get a suggestion ?
Reply With Quote
  #3  
Old 1st August 2010, 19:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

You must create a new zone, 72.45.204.in-addr.arpa, and in that zone you create a PTR record for 194 that points to ns2.unad.co.za.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 2nd August 2010, 00:07
PeekNPoke PeekNPoke is offline
Junior Member
 
Join Date: Jul 2010
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Unhappy

Hi Falko,

Thanks for the answer ... but I've just tried it and .. nope ...

I've created a new DNS zone with :

Zone (SOA) : 72.45.204.in-addr.arpa.
NS : ns1.unad.co.za.

Then added PTR records with:

Name : 194
Canonical Hostname : ns1.unad.co.za.

With a "dig @localhost 204.45.72.194" ... no luck. Any other suggestions would be welcomed, thanks for your response.
Reply With Quote
The Following User Says Thank You to PeekNPoke For This Useful Post:
AbannyvabVask (6th December 2013)
  #5  
Old 2nd August 2010, 03:24
matty matty is offline
Member
 
Join Date: Apr 2010
Location: Australia
Posts: 85
Thanks: 2
Thanked 12 Times in 11 Posts
Default

Quote:
Originally Posted by PeekNPoke View Post
:

Zone (SOA) : 72.45.204.in-addr.arpa.
NS : ns1.unad.co.za.

Then added PTR records with:

Name : 194
Canonical Hostname : ns1.unad.co.za.
Can you edit your zone file manually and check that the record you are looking at is like this:

194.72.45.204.in-addr.arpa. IN PTR ns1.unad.co.za.


Quote:
With a "dig @localhost 204.45.72.194" ... no luck. Any other suggestions would be welcomed, thanks for your response.
You need to use dig -x for reverse lookups.

Last edited by matty; 2nd August 2010 at 04:31.
Reply With Quote
  #6  
Old 2nd August 2010, 15:11
PeekNPoke PeekNPoke is offline
Junior Member
 
Join Date: Jul 2010
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Unhappy

Hi Matty,

Thanks for your reply as well. The problem is that ISPConfig 3 uses MyDNS, so no conf file is created. I've tried the "dig -x 204.45.72.194" on the server directly and it still didn't resolve. Check the output:

:~# dig -x 204.45.72.194

; <<>> DiG 9.6-ESV-R1 <<>> -x 204.45.72.194
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 51364
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;194.72.45.204.in-addr.arpa. IN PTR

;; Query time: 76 msec
;; SERVER: 76.73.0.3#53(76.73.0.3)
;; WHEN: Mon Aug 2 14:07:04 2010
;; MSG SIZE rcvd: 44

As you can see the Question is send but no answer is received. I'm really at my wits end ...

Any other suggestion will be appreciated. Also please let me know if more info is required.
Reply With Quote
  #7  
Old 2nd August 2010, 15:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Originally Posted by PeekNPoke View Post
The hosting company I host my server with setup NS records that point to my server so I can resolve the in-addr.arpa address my self.
Are you absolutely sure that this is true? Please double-check.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 3rd August 2010, 05:19
matty matty is offline
Member
 
Join Date: Apr 2010
Location: Australia
Posts: 85
Thanks: 2
Thanked 12 Times in 11 Posts
 
Default

Quote:
Originally Posted by falko View Post
Are you absolutely sure that this is true? Please double-check.
Yeah, it looks like it. Doing a trace shows this

Quote:
<snipped>
45.204.in-addr.arpa. 86400 IN NS ns3.fdcservers.net.
45.204.in-addr.arpa. 86400 IN NS ns4.fdcservers.net.
;; Received 94 bytes from 199.71.0.63#53(X.ARIN.NET) in 211 ms

194.72.45.204.in-addr.arpa. 28800 IN NS ns1.unad.co.za.
;; Received 72 bytes from 66.90.66.138#53(ns4.fdcservers.net) in 324 ms

. 518400 IN NS A.ROOT-SERVERS.NET.
. 518400 IN NS B.ROOT-SERVERS.NET.
. 518400 IN NS C.ROOT-SERVERS.NET.
. 518400 IN NS D.ROOT-SERVERS.NET.
. 518400 IN NS E.ROOT-SERVERS.NET.
. 518400 IN NS F.ROOT-SERVERS.NET.
. 518400 IN NS G.ROOT-SERVERS.NET.
. 518400 IN NS H.ROOT-SERVERS.NET.
. 518400 IN NS I.ROOT-SERVERS.NET.
. 518400 IN NS J.ROOT-SERVERS.NET.
. 518400 IN NS K.ROOT-SERVERS.NET.
. 518400 IN NS L.ROOT-SERVERS.NET.
. 518400 IN NS M.ROOT-SERVERS.NET.
;; BAD REFERRAL
;; Received 255 bytes from 67.159.14.2#53(ns1.unad.co.za) in 325 ms
Hopefully, PeekNPoke's nameserver is actually ns1.unad.co.za/67.159.14.2. Interestingly, they delegated the entire IP address, so the solution is to create the zone as 194.72.45.204.in-addr.arpa, and have a record for 204.45.72.194 (194.72.45.204.in-addr.arpa.). I just tested this on my server and it works fine.
Reply With Quote
Reply

Bookmarks

Tags
dns, ptr, reverse

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 20:51
Google Apps dayjahone General 19 29th March 2008 18:25
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 15:40
DNS Default TTL and Reverse Zone WEX General 2 16th June 2006 01:46
Reverse DNS disasm General 3 13th January 2006 20:43


All times are GMT +2. The time now is 20:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.