Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st August 2010, 06:14
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default adding mail boxes

i have Ubuntu Linux 9.10 server... i want to add mailboxes for postfix per domain name... i have add these through ISPConfig 3.0.1.6 and can log into the accounts through squirrel mail but can not receive mail or send mail...do i have to enter these mailboxes and users in postfit? if so how? thanks for any input



kwick
Reply With Quote
Sponsored Links
  #2  
Old 2nd August 2010, 13:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Any errors in your mail log?

Do the MX records for your domains point to the correct server? You can check that with
Code:
dig mx yourdomain.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd August 2010, 01:13
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default

Code:
root@kwickservers:/home/kwick# dig mx blackmagicpe.com                          
; <<>> DiG 9.6.1-P2 <<>> mx blackmagicpe.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42396
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 5

;; QUESTION SECTION:
;blackmagicpe.com.              IN      MX

;; ANSWER SECTION:
blackmagicpe.com.       3350    IN      MX      10 mail.authsmtp.com.

;; ADDITIONAL SECTION:
mail.authsmtp.com.      5953    IN      A       62.13.128.193
mail.authsmtp.com.      5953    IN      A       62.13.128.194
mail.authsmtp.com.      5953    IN      A       62.13.128.187
mail.authsmtp.com.      5953    IN      A       62.13.128.188
mail.authsmtp.com.      5953    IN      A       62.13.128.189

;; Query time: 21 msec
;; SERVER: 68.87.64.150#53(68.87.64.150)
;; WHEN: Mon Aug  2 19:12:33 2010
;; MSG SIZE  rcvd: 144
Reply With Quote
  #4  
Old 3rd August 2010, 11:54
koressak koressak is offline
Junior Member
 
Join Date: Aug 2010
Location: Prague, Czech Republic
Posts: 13
Thanks: 0
Thanked 1 Time in 1 Post
Default

Well, it could be many things, that are wrong.

For instance - check the priviledges of those mail directories, whether postfix can access them for writing and reading.

If yes, there must be some errors in the log. Try to send email to yourself from that machine and post a mail.log output.
Reply With Quote
  #5  
Old 3rd August 2010, 18:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

I guess mail.authsmtp.com is not your server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 3rd August 2010, 21:22
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default

no my server is kwickservers.com


should it read main.kwickservers.com

Last edited by kwickcut; 3rd August 2010 at 21:25.
Reply With Quote
  #7  
Old 4th August 2010, 17:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

The MX record must point to your own server. You can create an A record like mail.kwickservers.com that points to your server's IP and then create an MX record for blackmagicpe.com that points to mail.kwickservers.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
kwickcut (7th August 2010)
  #8  
Old 5th August 2010, 04:20
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
Default

ok i have made some changes i think i am on the rite path does this look rite now?
Code:
root@kwickservers:/home/kwick# dig mx blackmagicpe.com

; <<>> DiG 9.6.1-P2 <<>> mx blackmagicpe.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 55218
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;blackmagicpe.com.              IN      MX

;; ANSWER SECTION:
blackmagicpe.com.       3600    IN      MX      10 mail.kwickservers.com.

;; Query time: 83 msec
;; SERVER: 68.87.64.150#53(68.87.64.150)
;; WHEN: Wed Aug  4 22:18:57 2010
;; MSG SIZE  rcvd: 68

root@kwickservers:/home/kwick#
or is this wat i want

Code:
root@kwickservers:/home/kwick# dig mx blackmagicpe.com

; <<>> DiG 9.6.1-P2 <<>> mx blackmagicpe.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 48833
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;blackmagicpe.com.              IN      MX

;; ANSWER SECTION:
blackmagicpe.com.       3600    IN      MX      10 mail.blackmagicpe.com.

;; Query time: 66 msec
;; SERVER: 68.87.64.150#53(68.87.64.150)
;; WHEN: Wed Aug  4 23:03:12 2010
;; MSG SIZE  rcvd: 55

root@kwickservers:/home/kwick#

some more info i have dynamic ip so i have to user a redirect site so i can host below is the dns record for hostname used when building server
Code:
;
;
; zone for kwickservers.com
; built on 2010-08-04 21:41:26
;

$TTL    3600

@       86400	IN      SOA     ns1.afraid.org. dnsadmin.afraid.org.  (
                                1008040001    ; Serial
                                86400    ; Refresh
                                7200     ; Retry
                                3600000    ; Expire
                                3600 )  ; Minimum

@		86400	IN	NS	ns1.afraid.org.
@		86400	IN	NS	ns2.afraid.org.
@		86400	IN	NS	ns3.afraid.org.
@		86400	IN	NS	ns4.afraid.org.

localhost		IN	A	127.0.0.1

; username:username|tag:4789342
@	3600	IN	A	XX.44.214.20

; username:username|tag:4789343
@	3600	IN	MX	10 mail.kwickservers.com.

; username:username|tag:4789341
ftp	3600	IN	A	XX.44.214.20

; username:username|tag:4789344
irc	3600	IN	A	XX.44.214.20

; username:username|tag:4789340
mail	3600	IN	A	XX.44.214.20

; username:username|tag:4789339
www	3600	IN	A	XX.44.214.20
and this is teh dns for one of the sites hosted by me

Code:
;
; zone for blackmagicpe.com
; built on 2010-08-04 20:29:48
;

$TTL    3600

@       86400	IN      SOA     ns1.afraid.org. dnsadmin.afraid.org.  (
                                1008040004    ; Serial
                                86400    ; Refresh
                                7200     ; Retry
                                3600000    ; Expire
                                3600 )  ; Minimum

@		86400	IN	NS	ns1.afraid.org.
@		86400	IN	NS	ns2.afraid.org.
@		86400	IN	NS	ns3.afraid.org.
@		86400	IN	NS	ns4.afraid.org.

localhost		IN	A	127.0.0.1

; username:username|tag:47239XX
@	3600	IN	A	XX.44.214.20

; username:username|tag:4723969
@	3600	IN	MX	10 mail.blackmagicpe.com.

; username:username|tag:4723965
mail	3600	IN	A	XX.44.214.20

; username:username|tag:4723966
www	3600	IN	A	XX.44.214.20
and one last thing this is the dig for the hosname

Code:
root@kwickservers:/home/kwick# dig mx kwickservers.com

; <<>> DiG 9.6.1-P2 <<>> mx kwickservers.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54818
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;kwickservers.com.              IN      MX

;; ANSWER SECTION:
kwickservers.com.       3600    IN      MX      10 mail.kwickservers.com.

;; Query time: 126 msec
;; SERVER: 68.87.64.150#53(68.87.64.150)
;; WHEN: Thu Aug  5 01:12:18 2010
;; MSG SIZE  rcvd: 55

root@kwickservers:/home/kwick#

Last edited by kwickcut; 5th August 2010 at 07:13.
Reply With Quote
  #9  
Old 5th August 2010, 15:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

It doesn't matter if the MX record points to mail.kwickservers.com or mail.blackmagicpe.com as long as both point to the same server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
kwickcut (7th August 2010)
  #10  
Old 5th August 2010, 16:51
kwickcut kwickcut is offline
Senior Member
 
Join Date: Nov 2005
Location: nj usa
Posts: 223
Thanks: 14
Thanked 11 Times in 10 Posts
 
Default

ok well they all point at the server ip but when sending email to the account it never makes the box it is bounced back this is the message i get from the bounced email

Code:
Sorry, we were unable to deliver your message to the following address.

<admin@kwickbid.com>:
Remote host said: 550 5.1.1 <admin@kwickbid.com>: Recipient address rejected: User unknown in virtual alias table [RCPT_TO]

--- Below this line is a copy of the message.

Received: from [76.13.12.64] by n13.bullet.mail.ac4.yahoo.com with NNFMP; 05 Aug 2010 04:49:07 -0000
Received: from [76.13.10.174] by t5.bullet.mail.ac4.yahoo.com with NNFMP; 05 Aug 2010 04:49:07 -0000
Received: from [127.0.0.1] by omp115.mail.ac4.yahoo.com with NNFMP; 05 Aug 2010 04:49:07 -0000
X-Yahoo-Newman-Property: ymail-3
X-Yahoo-Newman-Id: 490595.31315.bm@omp115.mail.ac4.yahoo.com
Received: (qmail 73948 invoked by uid 60001); 5 Aug 2010 04:49:07 -0000
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=yahoo.com; s=s1024; t=1280983747; bh=OHLuYcS6I++Mk2WotXaeAdkOLUkEs6YKY8oNDwuVECc=; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type; b=pKAB6Wbn/eQK1EdK8e4FmaOPFTuTVdEVpscso/MUi6+AVraCC+HEOK5p8J2WkYusjUVnPd391JTJmSDFRv2s9SE5FGM3DfQAQQ2NbIXLq0VuWBYn0Kb0aXxVcuykXW6aiCO3xXSa48pOPEweBWf7yEMHyH4hcfQEHMXnKVBc6bk=
DomainKey-Signature:a=rsa-sha1; q=dns; c=nofws;
  s=s1024; d=yahoo.com;
  h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:MIME-Version:Content-Type;
  b=qKVy4uSIqM54XDPTBXGRXP+MwJuiglo8A9G7tda30XvmN5lMxYMCaQL7hJQOB6pT1C+/3osrsLBOR/+U4nnvAr08ODRfqZWwiJfkMkPIhD20DmmkGDViP/v5KrzNaGOQmiBGpGbVjFyCTABeAaL9xj5SZ0kx7dZDanjOKAfNNVs=;
Message-ID: <225916.72817.qm@web65511.mail.ac4.yahoo.com>
X-YMail-OSG: ECgYUT8VM1lqxp5KhLswx7ULKxbvq.LlueaDZ9Sj.vNIIp1
z3bnQe_UKyaEDpZQiowVaCIpYA1htkbGeWlBZJaScBVmo0xnXEaWnorxEqy_
UWIwAcUg1zuoT0by_NcgFqTKa4Y76B8S8c5zMUsVfZ5zgQY0UJF3jXdLuYzH
l_ECBgb4YHEbn86fm47BHgfFEAXLf1YxLC3KsSYohLpKDw__GmMzWNALwBVm
Fe77GwPwdU4YBZ8HZQBjT3kElFtuzpz1i5ZJJ.n8jJooEKwKB7MLzWYR9O46
pQDWxvnLV8dVR.hQD43FycVzRo4lOKTS3IDq0iQ4gh_4-
Received: from [68.44.214.20] by web65511.mail.ac4.yahoo.com via HTTP; Wed, 04 Aug 2010 21:49:07 PDT
X-Mailer: YahooMailClassic/11.3.2 YahooMailWebService/0.8.105.279950
Date: Wed, 4 Aug 2010 21:49:07 -0700 (PDT)
From: kwick <kwickcuts@yahoo.com>
Subject: test
To: admin@kwickbid.com
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="0-1935756675-1280983747=:72817"

--0-1935756675-1280983747=:72817
Content-Type: text/plain; charset=us-ascii

test 103



     
--0-1935756675-1280983747=:72817
Content-Type: text/html; charset=us-ascii

<table cellspacing="0" cellpadding="0" border="0" ><tr><td valign="top" style="font: inherit;">test 103<br></td></tr></table><br>

     
--0-1935756675-1280983747=:72817--

Last edited by kwickcut; 6th August 2010 at 00:55.
Reply With Quote
The Following User Says Thank You to kwickcut For This Useful Post:
michy51032 (10th August 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix problem and few questions Gimly Installation/Configuration 12 7th July 2009 16:27
Postfix + postfixadmin = SMTP errors... Rashef Server Operation 4 25th June 2009 16:12
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50
Problem with dcc-client installation (Postfix) swap-as Installation/Configuration 9 18th September 2008 20:47
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 14:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.