Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th July 2010, 05:48
cvgeeks cvgeeks is offline
Member
 
Join Date: Mar 2010
Posts: 48
Thanks: 1
Thanked 7 Times in 6 Posts
Smile Kernel Panic after yum update on Fedora 13.

After doing an update today my server would not reboot. Keeping in mind I'm not a guru just a guy trying to learn is all.
I searched all over and to no avail everything I found was pointing me to the fact that the person was trying to update their kernel when their problem happened however in my case yum was the one doing the update from 33.5 to 33.6. Anyway I received a message:
kernel panic - not syncing: VFS: unable to mount root fs on unknown-block (0,0).. All I could say was Oh Shi*!

Not knowing what to do I booted to my Fedora Live cd to run a mem test so I could eleviate that as an issue. Then I booted to my Fedora boot disc and went into RESCUE MODE: (seemed appropriate at the time)

I then mounted my file system by running the command like it told me too.
chroot /mnt/sysimage. Bang! I was in like flyn. (happy now I can see I have not lost anything).

Next I went to: cd /
cd boot/grub
vi grub.conf
In vi I put a # infront of hidden then set my timeout period from 0 to 10.

I then rebooted the server to see if I could boot to my old kernel and infact YES I could. (ahhhhhh ).

Smilingly now I went back into the system and removed the newly created kernel thingy in my grub.conf file. It looked somthing like below:
--------------------------------------------------------------------------title Fedora (2.6.33.6-124.fc13.i686.PAE)
root (hd0,0)
kernel /vmlinuz-2.6.33.5-124.fc13.i686.PAE ro root=/dev/mapper/vg_webhost-lv_root rd_LVM_LV=vg_webhost/lv_root rd_LVM_LV=vg_webhost/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet
--------------------------------------------------------------------------
Then I went into boot and found the new kernel config file and rm -f'd it!

Still having no idea whats really going on other than a new kernel came to town and shut me down! So I x'd him out.

Now the real question for me is: Will this happen once again when I perform another yum update? hmm doesnt look good for me if this kernel 33.6 guy comes back!
Reply With Quote
Sponsored Links
  #2  
Old 26th July 2010, 14:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by cvgeeks View Post
Now the real question for me is: Will this happen once again when I perform another yum update? hmm doesnt look good for me if this kernel 33.6 guy comes back!
I think this can happen again - there's no guarantee that it will work. But did you check the Fedora bugtracker if this is a known issue? Maybe it has already been fixed.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th July 2010, 15:53
cvgeeks cvgeeks is offline
Member
 
Join Date: Mar 2010
Posts: 48
Thanks: 1
Thanked 7 Times in 6 Posts
 
Default

Thanks for the pointer.
No I did not check that out. I didn't even know there was a bug tracker
I'll check it out.

Thanks again.


Quote:
Originally Posted by falko View Post
I think this can happen again - there's no guarantee that it will work. But did you check the Fedora bugtracker if this is a known issue? Maybe it has already been fixed.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
domains not accessible gillesdevals Installation/Configuration 3 17th June 2009 09:12
Ispconfig IE7 Xen aurelius Installation/Configuration 8 19th October 2008 10:46
Google Apps dayjahone General 19 29th March 2008 17:25
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
WG311v2 almost working with Edgy (w/o ndiswrapper) need help with the rest caudata Server Operation 11 13th November 2006 20:02


All times are GMT +2. The time now is 04:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.