Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th July 2010, 06:03
DrJohn DrJohn is offline
Member
 
Join Date: Aug 2007
Location: Portland, OR, USA
Posts: 66
Thanks: 8
Thanked 2 Times in 2 Posts
Default Upgrade 2.2.36 can't change users' information

I upgraded from 2.2.35 to 2.2.36 in a Ubuntu 9.10 KVM server instance. The upgrade required two passes through setup because I forgot about the issue with /usr/include/stdio.h, which had been reverted after the original 2.2.35 install, and so I had to restart the upgrade from the tar.gz unpacking. The second time through it ran as a new install (), although I entered the existing dbase names and password, and then ispConfig seemed to be configured correctly. It was working just fine until I needed to change a password for an existing user.

Went to the site, User & Email tab, clicked the username, entered new password, clicked Save, and saw "The username already is in use". The username is listed in /home/admispconfig/ispconfig/users (logically as this is an existing and active user). The same error occurs if I try to make other changes, such as add a site to the user's email whitelist.

What do I need to do to allow changes to users' information? I hesitate to delete the username from /home/admispconfig/ispconfig/users due to the convoluted path to the upgrade -- in case there is something misconfigured.

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 19th July 2010, 07:28
DrJohn DrJohn is offline
Member
 
Join Date: Aug 2007
Location: Portland, OR, USA
Posts: 66
Thanks: 8
Thanked 2 Times in 2 Posts
Default

Later on -- I checked and the password was changed after all, so the problem with the password at least seems to be only that the error message appeared.
Reply With Quote
  #3  
Old 20th July 2010, 13:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please delete the username from /home/admispconfig/ispconfig/users.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 23rd July 2010, 16:44
DrJohn DrJohn is offline
Member
 
Join Date: Aug 2007
Location: Portland, OR, USA
Posts: 66
Thanks: 8
Thanked 2 Times in 2 Posts
Default

OK, that removed the error message. Should I not then delete all users from /home/admispconfig/ispconfig/users?
Reply With Quote
  #5  
Old 24th July 2010, 12:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Only the users that you created with ISPConfig. You must leave all other users in there so that ISPConfig knows that it must not create such a user (because it already exists).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
DrJohn (24th July 2010)
  #6  
Old 24th July 2010, 22:47
DrJohn DrJohn is offline
Member
 
Join Date: Aug 2007
Location: Portland, OR, USA
Posts: 66
Thanks: 8
Thanked 2 Times in 2 Posts
 
Default

Thank you, Falko, for the clarification!
Reply With Quote
Reply

Bookmarks

Tags
2.2.36, upgrade

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade / Change from ISPConfig 2 > 3 foxfirediego General 4 30th June 2009 09:58
How to change mailbx size on a postfix install on Etch with Virt users jakev383 HOWTO-Related Questions 5 25th January 2009 19:38
ProFTP & SuSe 10 latcarf Server Operation 26 28th March 2006 03:23
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 08:03
VSFTPD is not working after install the ISPConfig gimhan90 Server Operation 8 3rd February 2006 09:25


All times are GMT +2. The time now is 10:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.