Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 22nd July 2010, 18:26
MrCompTech MrCompTech is offline
Member
 
Join Date: Jul 2010
Posts: 92
Thanks: 1
Thanked 19 Times in 8 Posts
Default Emails can be sent to external account but not received from them.

How-To used to setup this server: "The Perfect Server - Fedora 13 x86_64 [ISPConfig 3]"

On this server I have two domains mrcomptech.com and rtmdfanc.com and used the ISPConfig3 DNS wizard to setup both.
Have websites for both of these domains mrcomptech.com and rtmdfanc.com
Have Email Domains mrcomptech.com and rtmdfanc.com
Have Email Mailboxes mrcomptech@mrcomptech.com and rtmdfanc@rtmdfanc.com

On my local LAN I can send email between mrcomptech@mrcomptech.com and rtmdfanc@rtmdfanc.com.

I use RoadRunner cable internet and have to send my mail through smtp-server.neo.rr.com.
This is in System --> Server Config --> (select server) --> Server Config Mail tab --> Relayhost

I can send e-mail from both of these accounts to my Yahoo email account.

I cannot send e-mail from my Yahoo account to either mrcomptech@mrcomptech.com or rtmdfanc@rtmdfanc.com.
After 12 hours I get NO e-mail error or warning messages back to my Yahoo account.

I use PurchaseYour.com as my external DNS.
The MX settings for both mail domains were put in yesterday, about 15 hours ago.

DNS Records on Purchase Your:

========================================
For mrcomptech.com:
========================================
A (Host)
host Points To
@ 75.187.182.146

CNames (Aliases)
host Points To
ftp @
imap @
pop @
smtp @
www @

MX (Mail Exchange)
Pri Host Goes To
10 @ mrcomptech.com

NS (Name Server)
ns49.domaincontrol.com

========================================
For domain/website rtmdfanc.com:
========================================
A (Host)
host Points To
@ 75.187.182.146

CNames (Aliases)
host Points To
ftp @
imap @
pop @
smtp @
www @

MX (Mail Exchange)
Pri Host Goes To
10 @ rtmdfanc.com

NS (Name Server)
ns57.domaincontrol.com
ns58.domaincontrol.com


I have been checking the ISPConfig web admin logs "Show Mail Log", "Show Mail Warn-Log", "Show Mail Error-Log" and never see any attempt from any mail server to connect to the mail server on my ISPConfig3 Server.

A note here on these logs, they show exactly the same thing.
Shouldn't one be for warnings, one for errors and one for general entries?

I have ports 25 and 110 on my LAN router forwarding to the internal IP of my server, which is connected to the cable modem.

When I had my websites and mail server setup on Windows 2008 Server (Trial Edition) I was able to send and recieve e-mail between my Yahoo accounts and the mrcomptech@mrcomptech.com account. I did not have any mail accounts setup for rtmdfanc.com when on the Win2K8 Server.

One thing that has changed is that when on the Win2K8 Server mrcomptech.com DNS setup was on NetworkSolutions.com.
I did not take note of what DNS records were setup for mrcomptech.com when on NetworkSolutions.com.

This is the first time I have tried to test e-mail for mrcomptech@mrcomptech.com or rtmdfanc@rtmdfanc.com since switching to linux ( Fedora 13 / ISPConfig3 ) and changing external DNS servers.

I did just just notice IMAP was not open on my router so added port 143 to forward to my server, but I don't think this has anything to do with my problem since port 25 is used for mail delivery and that port was already being forwarded.

The obvious question is - can anyone help me figure this out?

Some other questions:

Am I watching the correct logs ( "Show Mail Log", "Show Mail Warn-Log", "Show Mail Error-Log" ) within ISPConfig web admin for connections from external mail servers?

Shouldn't I be getting something back from Yahoo's mail server letting me know that the mail was not delayed or not deliverable?

Is there any way to test a connection to my mail server from the Internet other than sending an email from another email address?

How do I check the firewall that was installed during the How-To "The Perfect Server - Fedora 13 x86_64 [ISPConfig 3]" to be sure ports 25, 110 and 143 are open for incoming connections?

In ISPConfig System --> Firewall there were no entries.

Since the web site is accessible from another computer on the LAN and from the internet does this mean that the firewall is wide open?

If I click the Add Firewall Record button there is a automatically a bunch of ports listed.
TCP - 20,21,22,25,53,80,110,143,443,3306,8080,10000
UDP - 53,3306

After adding this default rule, just now, I ran server.sh with debug on and received the error:

/usr/local/ispconfig/server/server.sh
DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
DEBUG - Found 1 changes, starting update process.
DEBUG - Call function 'insert' in plugin 'firewall_plugin' raised by event 'firewall_insert'.
DEBUG - Writing firewall configuration /etc/Bastille/bastille-firewall.cfg
FATAL: Module ip_conntrack not found.
DEBUG - Restarting the firewall
DEBUG - Processed datalog_id 449
DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
finished.

So is my firewall working or not? If not then it's not the problem with the mail but it is still another problem yet to be delt with.

How and were do I install module "ip_conntrack" that appears to be part of the firewall?

When I restart the firewall Bastille with "/etc/rc.d/init.d/bastille-firewall restart" I get:

/etc/rc.d/init.d/bastille-firewall restart
FATAL: Module ip_conntrack not found.
Setting up IP spoofing protection... done.
Allowing traffic from trusted interfaces... done.
Setting up chains for public/internal interface traffic... done.
Setting up general rules... done.
Setting up outbound rules... done.

It appears that inbound rules are missing, is this correct?

I have turned off the firewall with "/etc/rc.d/init.d/bastille-firewall stop" and still do not recieve e-mail from my Yahoo account.

I can still receive from mrcomptech@mrcomptech.com to my yahoo account.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't recieve email from external account (no bounce message) sampson Installation/Configuration 4 30th April 2010 15:37
LocalMailserver that want to know from the main mailserver which emails have received voltron81 Server Operation 0 8th January 2010 11:34
Emails are not delivered to external mail server. kanour General 2 18th October 2006 11:36
webmail problem mphayesuk General 26 27th April 2006 12:46
Emails received but I cannot read them skeeta Installation/Configuration 2 28th August 2005 12:24


All times are GMT +2. The time now is 10:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.