Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th July 2010, 12:17
PerudoIS PerudoIS is offline
Junior Member
 
Join Date: Dec 2006
Location: The Netherlands
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail not delivered to local domain

Since an update of the server I have a problem. My mailqueue is growing and mail isn't delivered to <username>@<mydomain>. I can see incoming mail is queued for delivery to the local user but in the mailqueue I only see the count of mails waiting growing. I can't find any suggestions on the internet how to solve and the log files don't give a clear problem.

postconf -n

Code:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
inet_interfaces = all
inet_protocols = all
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
mydestination = /etc/postfix/local-host-names
myhostname = www1.perudo.eu
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
myorigin = /etc/mailname
readme_directory = no
recipient_delimiter = +
relayhost = 
smtp_tls_note_starttls_offer = yes
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_use_tls = yes
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_local_domain = 
smtpd_sasl_security_options = noanonymous
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
tls_random_source = dev:/dev/urandom
Can anybody please help me ?
Reply With Quote
Sponsored Links
  #2  
Old 13th July 2010, 17:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Please post the error messages that you get in the mail.log.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th July 2010, 10:00
PerudoIS PerudoIS is offline
Junior Member
 
Join Date: Dec 2006
Location: The Netherlands
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The problem was the load of the server, that problem is solved. But I now have a little other problem. When I send an email to it is delivered to VIRTUALDOMAIN@<server>

Jul 15 08:39:18 www1 postfix/local[20800]: 84CB9270803: to=<VIRTUALDOMAIN@**servername****, orig_to=<info@*******>, relay=local, delay=0.29, delays=0.28/0/0/0.01, dsn=5.1.1, status=bounced (unknown user: "virtualdomain")
Reply With Quote
  #4  
Old 16th July 2010, 14:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Is info listed in /etc/aliases?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th July 2010, 19:11
PerudoIS PerudoIS is offline
Junior Member
 
Join Date: Dec 2006
Location: The Netherlands
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No, info is not listed in /etc/aliases
Reply With Quote
  #6  
Old 17th July 2010, 14:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

IS the domain part of info@******* listed in /etc/postfix/local-host-names? Is info@******* listed in /etc/postfix/virtusertable? What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 17th July 2010, 21:41
PerudoIS PerudoIS is offline
Junior Member
 
Join Date: Dec 2006
Location: The Netherlands
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Problem solved!

The problem was that I had a few e-mailaddresses on the server mapping to a user with the same name as de domain. In virtusertable the domainname was mapping to VIRTUALDOMAIN so the e-mailwas mapped to VIRTUALDOMAIN@<servername>

Thank you anyway for your time!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Catchall and Forwarding not working simmo General 6 22nd March 2014 00:54
Postfix queue problem? murunix Server Operation 7 2nd May 2011 01:55
ISPconfig 3 some users cannot send email to outside Rockblade Installation/Configuration 7 29th April 2010 01:40
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17


All times are GMT +2. The time now is 23:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.