Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd July 2010, 08:00
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default PHP Security settings for websites?

Okay, I have been having a heck of a time trying to use automatic update with Wordpress. Finally, I'm realizing it has to do something with the settings for the PHP security on the websites.

ISPConfig2 had the SAFEMODE setting which would screw stuff up, but this does not.

Here's one of the errors:
Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(/var/www/clients/client1/web5/web/wp-content/advanced-cache.php) is not within the allowed path(s): (/var/www/clients/client1/web5/web:/var/www/clients/client1/web5/tmp:/var/www/areyouliberal.com/web:/srv/www/areyouliberal.com/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin) in /var/www/clients/client1/web5/web/wp-admin/includes/plugin.php on line 348

I'm using Mod-PHP.

Any thoughts on getting straight PHP operational without these restrictions?
Reply With Quote
Sponsored Links
  #2  
Old 2nd July 2010, 10:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
Default

Quote:
Any thoughts on getting straight PHP operational without these restrictions?
I run several wordpress sites on ispconfig, all work perfectly.

Quote:
I'm using Mod-PHP.
Thats the reason why it does not work. The automatic update needs write permissions to the folders and mod_php is only used if applications shall not have write permissions to the folders.

Chnage the php settings of the website to php-fcgi and enable the suexec checkbox. Then make sure that all files and folders in the "web§ folder of the website belong to the website user and group.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th July 2010, 18:37
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

Almost resolved! Now, I can do updates, but I gain a new error:

Warning: session_start() [function.session-start]: open(/var/www/clients/client1/web26/tmp/sess_ffa61689d606b9aa3ef614d4704eaa64, O_RDWR) failed: Permission denied (13) in /var/www/clients/client1/web26/web/wp-content/plugins/si-contact-form/si-contact-form.php on line 1068

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /var/www/clients/client1/web26/web/wp-content/plugins/si-contact-form/si-contact-form.php:1068) in /var/www/clients/client1/web26/web/wp-content/plugins/si-contact-form/si-contact-form.php on line 1068

Warning: Cannot modify header information - headers already sent by (output started at /var/www/clients/client1/web26/web/wp-content/plugins/si-contact-form/si-contact-form.php:1068) in /var/www/clients/client1/web26/web/wp-includes/pluggable.php on line 890

Warning: Unknown: open(/var/www/clients/client1/web26/tmp/sess_ffa61689d606b9aa3ef614d4704eaa64, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/www/clients/client1/web26/tmp) in Unknown on line 0

A support forum guru at Wordpress told me that it's a webhost problem:

Quote:
PHP sessions are required to set a cookie, or the CAPTCHA will not work.

This error is telling you the PHP sessions are broken on your server
installation because it cannot find or read the session directory. Make
a trouble ticket with your web host. Send them the error and a URL link
to the page with error. They will fix it.
So what would cause that?

Last edited by crypted; 5th July 2010 at 01:40.
Reply With Quote
  #4  
Old 5th July 2010, 01:45
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

This only occurs with FAST-CGI and not Mod-PHP...
Reply With Quote
  #5  
Old 5th July 2010, 16:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,171 Times in 4,055 Posts
Default

This happens because you had switched from mod_php to fast-cgi without closing the browser of the website you are using and / or without clearing the session directory. Run:

rm -f /var/www/clients/client1/web26/tmp/*

to clear the session dir.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 6th July 2010, 05:43
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
 
Default

Seems to work perfect. Thanks man!!!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 21:13
Error when install ISPConfig 2 with components built from source X-admin Installation/Configuration 5 30th April 2010 13:22
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 03:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.