Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd July 2010, 18:50
j.smith1981 j.smith1981 is offline
Member
 
Join Date: Nov 2008
Posts: 63
Thanks: 0
Thanked 3 Times in 3 Posts
Question Problems connecting my HTC Desire outgoing mail client to Postfix and ISP Config 2

I am having problems connecting my phones email client in the HTC Desire outgoing SMTP mail client.

It just wont connect, will with my mailbox though logs in fine when using that but fails for the outgoing, I am running an old centos distribution centos 4.8 and using ispconfig 2 like it said in the tutorials, the email servers acting fine can connect to it from work and at home just not by my phone, what could be the problem do you think?

I mean I will list the details I have entered (missing out a few for security as usual):

Username (setup when using this domain as a user on the shell commandline).

Password (same as above, created and works fine for the incoming mail POP3)

Security type: None (as I havent got it working either with any other so I thought it cant be that, could it?)

Server port: 25 (port I use when I want to test it from work, sending emails out using that server, that works, so why doesnt my phone?)

Can someone help? I'm clueless as to why this isnt working and its starting to really annoy me to no end, please any advice or help is greatly appreciated as usual.

Kind regards and I look forward to any replies in advance
Jeremy.
Reply With Quote
Sponsored Links
  #2  
Old 4th July 2010, 19:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th July 2010, 13:13
j.smith1981 j.smith1981 is offline
Member
 
Join Date: Nov 2008
Posts: 63
Thanks: 0
Thanked 3 Times in 3 Posts
Default

I will try and set it up again and just double check.

Last time I saw I couldnt even find any connection logs from my phone.

I could search through the find the IP address of it at the time (as I think its always on the internet), but I will just doubly make sure.

I wont need to add it to my hosts.allow list will I?

Hmm see googlemail works fine, but this is really starting to bug me lol.

Is there any good tutorials on setting up one outside of ispconfig admin interface?

Like so I can set one up for myself?

Just an idea incase I cant use this, just I tried squirrelmail on ispconfig but just couldnt work out how to set it up thats all.

Thanks for your help so far,
Jeremy.

PS Here is a log of the activity just as an example:

Quote:
Jul 5 12:16:54 centos pop3-login: Login: jeremy [::ffff:217.171.129.66]
Jul 5 12:21:58 centos postfix/smtpd[13936]: connect from unknown[117.241.16.140]
Jul 5 12:21:58 centos postfix/smtpd[13936]: NOQUEUE: reject: RCPT from unknown[117.241.16.140]: 550 <sneeseeh@xxxxx.co.uk>: Recipient address rejected: User unknown in local recipient table; from=<bestSoftWarem2@yahoo.com> to=<sneeseeh@xxxxx.co.uk> proto=SMTP helo=<admin>
Jul 5 12:21:58 centos postfix/smtpd[13936]: lost connection after RCPT from unknown[117.241.16.140]
Jul 5 12:21:58 centos postfix/smtpd[13936]: disconnect from unknown[117.241.16.140]
Jul 5 12:22:38 centos pop3-login: Login: jeremy [::ffff:84.12.98.134]
Jul 5 12:22:38 centos postfix/smtpd[13936]: connect from cwadsl04.gotadsl.co.uk[84.12.98.134]
Jul 5 12:22:38 centos postfix/smtpd[13936]: D03C338B0015: client=cwadsl04.gotadsl.co.uk[84.12.98.134]
Jul 5 12:22:39 centos postfix/cleanup[13951]: D03C338B0015: message-id=<20100705112238.D03C338B0015@centos.xxxxx.co.uk >
Jul 5 12:22:39 centos postfix/qmgr[3389]: D03C338B0015: from=<jeremy@xxxxx.co.uk>, size=711, nrcpt=1 (queue active)
Jul 5 12:22:39 centos postfix/smtpd[13936]: disconnect from cwadsl04.gotadsl.co.uk[84.12.98.134]
Jul 5 12:22:39 centos sendmail[13957]: o65BMdDa013957: from=jeremy, size=108, class=0, nrcpts=1, msgid=<201007051122.o65BMdDa013957@centos.xxxxx.co .uk>, relay=jeremy@localhost
Jul 5 12:22:39 centos postfix/smtpd[13936]: connect from localhost.localdomain[127.0.0.1]
Jul 5 12:22:39 centos postfix/smtpd[13936]: setting up TLS connection from localhost.localdomain[127.0.0.1]
Jul 5 12:22:39 centos postfix/smtpd[13936]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Jul 5 12:22:39 centos sendmail[13957]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jul 5 12:22:39 centos postfix/smtpd[13936]: 5642C38B0016: client=localhost.localdomain[127.0.0.1], sasl_sender=jeremy@centos.xxxxx.co.uk
Jul 5 12:22:39 centos postfix/cleanup[13951]: 5642C38B0016: message-id=<201007051122.o65BMdDa013957@centos.xxxxx.co.uk >
Jul 5 12:22:39 centos postfix/qmgr[3389]: 5642C38B0016: from=<jeremy@centos.xxxxx.co.uk>, size=747, nrcpt=1 (queue active)
Jul 5 12:22:39 centos sendmail[13957]: o65BMdDa013957: to=admispconfig@localhost.localdomain, ctladdr=jeremy (10001/10001), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30108, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 5642C38B0016)
Jul 5 12:22:39 centos postfix/smtpd[13936]: disconnect from localhost.localdomain[127.0.0.1]
Jul 5 12:22:39 centos postfix/local[13968]: 5642C38B0016: to=<admispconfig@localhost.localdomain>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 5 12:22:39 centos postfix/qmgr[3389]: 5642C38B0016: removed
Jul 5 12:22:52 centos pop3-login: Login: jeremy [::ffff:84.12.98.134]
Jul 5 12:22:53 centos postfix/smtpd[13936]: connect from cwadsl04.gotadsl.co.uk[84.12.98.134]
Jul 5 12:22:53 centos postfix/smtpd[13936]: 9399A38B0016: client=cwadsl04.gotadsl.co.uk[84.12.98.134], sasl_method=LOGIN, sasl_username=jeremy
Jul 5 12:22:53 centos postfix/cleanup[13951]: 9399A38B0016: message-id=<20100705112253.9399A38B0016@centos.xxxxx.co.uk >
Jul 5 12:22:53 centos postfix/qmgr[3389]: 9399A38B0016: from=<jeremy@xxxxx.co.uk>, size=711, nrcpt=1 (queue active)
Jul 5 12:22:53 centos postfix/smtpd[13936]: disconnect from cwadsl04.gotadsl.co.uk[84.12.98.134]
Jul 5 12:22:54 centos sendmail[13988]: o65BMsd3013988: from=jeremy, size=108, class=0, nrcpts=1, msgid=<201007051122.o65BMsd3013988@centos.xxxxx.co .uk>, relay=jeremy@localhost
Jul 5 12:22:54 centos postfix/smtpd[13936]: connect from localhost.localdomain[127.0.0.1]
Jul 5 12:22:54 centos postfix/smtpd[13936]: setting up TLS connection from localhost.localdomain[127.0.0.1]
Jul 5 12:22:54 centos postfix/smtpd[13936]: TLS connection established from localhost.localdomain[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Jul 5 12:22:54 centos sendmail[13988]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jul 5 12:22:54 centos postfix/smtpd[13936]: 364E538B0017: client=localhost.localdomain[127.0.0.1], sasl_sender=jeremy@centos.xxxxx.co.uk
Jul 5 12:22:54 centos postfix/cleanup[13951]: 364E538B0017: message-id=<201007051122.o65BMsd3013988@centos.xxxxx.co.uk >
Jul 5 12:22:54 centos sendmail[13988]: o65BMsd3013988: to=admispconfig@localhost.localdomain, ctladdr=jeremy (10001/10001), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30108, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as 364E538B0017)
Jul 5 12:22:54 centos postfix/qmgr[3389]: 364E538B0017: from=<jeremy@centos.xxxxx.co.uk>, size=747, nrcpt=1 (queue active)
Jul 5 12:22:54 centos postfix/smtpd[13936]: disconnect from localhost.localdomain[127.0.0.1]
Jul 5 12:22:54 centos postfix/local[13999]: 364E538B0017: to=<admispconfig@localhost.localdomain>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 5 12:22:54 centos postfix/qmgr[3389]: 364E538B0017: removed
Jul 5 12:23:06 centos postfix/local[13952]: D03C338B0015: to=<jeremy@centos.xxxxx.co.uk>, orig_to=<jeremy@xxxxx.co.uk>, relay=local, delay=28, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 5 12:23:06 centos postfix/qmgr[3389]: D03C338B0015: removed
Jul 5 12:23:19 centos postfix/local[13968]: 9399A38B0016: to=<jeremy@centos.xxxxx.co.uk>, orig_to=<jeremy@xxxxx.co.uk>, relay=local, delay=26, status=sent (delivered to command: /usr/bin/procmail -f-)
Jul 5 12:23:19 centos postfix/qmgr[3389]: 9399A38B0016: removed
The first in the list above is the pop3 login my phone is allowing me to login to, jeremy is my username on that domain, I enter exactly the same details prefix.xxxxx.co.uk as per my public domain name, nothing seems to make it work.

Its not actually coming up with any results for the smtp login though, doesnt seem to want to accept smtp logins, can someone help? (Jul 5 12:16:54 centos pop3-login: Login: jeremy [::ffff:217.171.129.66] is my phones IP address, the rest is just an example of my outlook from work connecting to my server at home, works perfectly, really am stuck as to why this is not working, any suggestions?

Last edited by falko; 2nd April 2012 at 17:36. Reason: Masked email address as requested by user.
Reply With Quote
  #4  
Old 5th July 2010, 13:40
j.smith1981 j.smith1981 is offline
Member
 
Join Date: Nov 2008
Posts: 63
Thanks: 0
Thanked 3 Times in 3 Posts
Lightbulb

Ahh got it!!!

Its amazing what a look on google does!

Thank god for google, searched forums for various problems people where having with mobile phone networks, and they commonly block port 25, so instead of changing my other email clients from friends and stuff.

I have opened ports 25-26, just to see if that works, wonderful it does!

Going to attempt some kind of authentication in that aswell, just to make sure it works more securely aswell.

Happy to know why though!
Reply With Quote
  #5  
Old 5th July 2010, 14:08
j.smith1981 j.smith1981 is offline
Member
 
Join Date: Nov 2008
Posts: 63
Thanks: 0
Thanked 3 Times in 3 Posts
Question

Its not receiving any mail.

Any suggestions?

Like it doesnt appear in my inbox, any help is greatly appreciated have opened 25-26 on both my NAT firewall and my server but the actual service is the problem, is there anyway of allowing postfix to receive this?

Thanks again.
Reply With Quote
  #6  
Old 6th July 2010, 14:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Does the MX record of your domain point to the correct server? You can check that by running
Code:
dig mx yourdomain.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 12th July 2010, 19:07
j.smith1981 j.smith1981 is offline
Member
 
Join Date: Nov 2008
Posts: 63
Thanks: 0
Thanked 3 Times in 3 Posts
 
Default

Since it works anyway yes it does.

The problem has nothing to do with my domain what so ever, its to do with the ports with postfix receiving a request to send out an email.

On my mobile phone network they block the standard smtp port, all I want to do is change postfix config to a port, anything other than the standard port its configured to, basic really.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Configure postfix to send and receive mail through ISP? xstax Server Operation 0 12th February 2010 15:03
How to retrieve email? (Postfix / Courier) Merritt General 20 5th April 2009 14:26
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50
ISP Config, Postfix , Recieving Mail issue. teknology Installation/Configuration 6 29th March 2008 17:23
Would the problem come from postfix? satimis Server Operation 10 27th January 2008 10:31


All times are GMT +2. The time now is 04:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.