#1  
Old 1st July 2010, 09:05
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default Cant receive mails

Hi in server with ispconfig 3 i can't receive mails.

The log of the server that send the mail is this:

Code:
Jul  1 08:54:23 ns1 postfix/smtp[13864]: 02588160000A: to=<xxxx@xxxxxxxx>, relay=none, delay=0.98, delays=0.98
/0/0/0, dsn=4.4.1, status=deferred (connect to name.ofmyserver.net[xxx.xxx.xxx.xxx]: Connection refused)
what is the problem?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 1st July 2010, 09:09
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

postfix running?

Code:
netstat -tapn
post that output here please.
Reply With Quote
  #3  
Old 1st July 2010, 09:14
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Code:
netstat -tapn
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      3498/apache2    
tcp        0      0 127.0.0.1:902           0.0.0.0:*               LISTEN      1150/famd       
tcp        0      0 127.0.0.1:10024         0.0.0.0:*               LISTEN      2135/amavisd (maste
tcp        0      0 127.0.0.1:10025         0.0.0.0:*               LISTEN      1114/master     
tcp        0      0 0.0.0.0:3306            0.0.0.0:*               LISTEN      433/mysqld      
tcp        0      0 127.0.0.1:783           0.0.0.0:*               LISTEN      493/spamd.pid   
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      262/portmap     
tcp        0      0 0.0.0.0:8080            0.0.0.0:*               LISTEN      3498/apache2    
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      3498/apache2    
tcp        0      0 0.0.0.0:8081            0.0.0.0:*               LISTEN      3498/apache2    
tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      26713/pure-ftpd (SE
tcp        0      0 94.23.xxx.xxx:53         0.0.0.0:*               LISTEN      1051/mydns      
tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      1051/mydns      
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      351/sshd        
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      1114/master     
tcp        0      0 127.0.0.1:57214         127.0.0.1:3306          ESTABLISHED 2137/amavisd (ch1-a
tcp        0      0 94.23.xxx.xxx:22         95.62.xxx.xxx:32925      ESTABLISHED 17317/0         
tcp        0      0 94.23.xxx.xxx:80         95.62.xxx.xxx:53189      TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:8080       95.62.xxx.xxx:41766      TIME_WAIT   -               
tcp       63      0 127.0.0.1:43800         127.0.0.1:10025         CLOSE_WAIT  2137/amavisd (ch1-a
tcp        0      0 94.23.xxx.xxx:80         62.149.xxx.xxx9:50304    TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         95.62.xxx.xxx:53186      TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         95.62.xxx.xxx:53185      TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         66.249.65.169:65472     TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         79.149.217.112:49299    TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         95.62.xxx.xxx:53188      TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         123.125.66.47:37613     TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         216.129.119.40:51736    TIME_WAIT   -               
tcp        0   3232 94.23.xxx.xxx:22         95.62.xxx.xxx:53269      ESTABLISHED 3953/4          
tcp        0      0 127.0.0.1:3306          127.0.0.1:57214         ESTABLISHED 433/mysqld      
tcp        0      0 94.23.xxx.xxx:8080       95.62.xxx.xxx:41765      TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         95.62.xxx.xxx:53190      TIME_WAIT   -               
tcp        0      0 94.23.xxx.xxx:80         95.62.xxx.xxx:53187      TIME_WAIT   -               
tcp6       0      0 :::993                  :::*                    LISTEN      1030/couriertcpd
tcp6       0      0 :::995                  :::*                    LISTEN      1048/couriertcpd
tcp6       0      0 :::110                  :::*                    LISTEN      1036/couriertcpd
tcp6       0      0 :::143                  :::*                    LISTEN      1018/couriertcpd
tcp6       0      0 :::21                   :::*                    LISTEN      26713/pure-ftpd (SE
tcp6       0      0 ::1:53                  :::*                    LISTEN      1051/mydns      
tcp6       0      0 :::22                   :::*                    LISTEN      351/sshd
Reply With Quote
  #4  
Old 1st July 2010, 09:18
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
Default

You only have SMTP listening on your local interface:
Code:
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 1114/master
what's the output of:
Code:
postconf inet_interfaces
Reply With Quote
The Following User Says Thank You to Mark_NL For This Useful Post:
esezako (1st July 2010)
  #5  
Old 1st July 2010, 09:19
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

after start postfix, i still have the problem
Reply With Quote
  #6  
Old 1st July 2010, 09:20
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

Code:
postconf inet_interfaces
inet_interfaces = loopback-only
Reply With Quote
  #7  
Old 1st July 2010, 09:34
esezako esezako is offline
Senior Member
 
Join Date: Dec 2008
Posts: 176
Thanks: 16
Thanked 4 Times in 3 Posts
Default

i comment this line in /etc/postfix/main.cf and after restart postfix everything is work

Thank you very much.
Reply With Quote
  #8  
Old 1st July 2010, 09:36
Mark_NL Mark_NL is offline
Senior Member
 
Join Date: Sep 2008
Location: The Netherlands
Posts: 912
Thanks: 12
Thanked 100 Times in 96 Posts
 
Default

oke as i suspected, postfix is only listening on your local interface, so you need to change that:

open /etc/postfix/main.cf and look for the inet_interface option .. change it from

Code:
inet_interfaces = loopback-only
to:
Code:
inet_interfaces = all
then restart postfix, and everything should work.
Reply With Quote
The Following User Says Thank You to Mark_NL For This Useful Post:
esezako (1st July 2010)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails in a domain tspau Installation/Configuration 4 18th June 2010 09:46
Postfix can't receive mails satimis Server Operation 4 17th October 2008 17:10
Postfix: REceive mails but Doesn't Send mails to others externals domains angelux General 4 10th August 2008 05:34
Can't receive any mails after update heinerlamprecht Installation/Configuration 2 6th April 2008 21:58
Sendmai can send mails but unable to receive mails satimis Server Operation 10 20th February 2007 17:10


All times are GMT +2. The time now is 06:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.