#1  
Old 19th June 2010, 16:16
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 264 Times in 208 Posts
Question Apps Apache vhost

The current apache ispc apps vhost looks like this:

Code:
######################################################
# This virtual host contains the configuration
# for the ISPConfig apps vhost
######################################################

 Listen 8081
# NameVirtualHost *:8081

<VirtualHost _default_:8081>
  ServerAdmin webmaster@localhost


  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/apps
    SuexecUserGroup ispapps ispapps
    <Directory /var/www/apps>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/apps/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  <IfModule mod_php5.c>
    DocumentRoot /var/www/apps
    AddType application/x-httpd-php .php
    <Directory /var/www/apps>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  ServerSignature Off

</VirtualHost>
Because I found it useful I set up a repository and installed phpmyadmin with the ispconfig3 package manager and a simple setup.sh script.
As expected the package was installed as user ispapps in /var/www/apps/phpmyadmin

The problem is that I get a 403 when accessing any php file there.
If i comment out one of the parts in the vhost file (fcgid or modphp) it works like charm but if both sections are in there - 403 all the time.

Is there a bug in the vhost template for the apps?
Reply With Quote
Sponsored Links
  #2  
Old 19th June 2010, 23:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Which Linux distribution do you use? I dont experience that problem on my debian system.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st June 2010, 09:17
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 264 Times in 208 Posts
Default

Quote:
Originally Posted by till View Post
Which Linux distribution do you use? I dont experience that problem on my debian system.
It's a debian lenny 5.0.4 with apache 2.2.9-10+lenny7
Reply With Quote
  #4  
Old 21st June 2010, 18:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Ok. I've added it to the bugtracker.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 22nd June 2010, 17:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

I tested it again on a new debian setup and the apps vhost works for me. Which is the exact error message that you get in the apache error log file for the 403 error?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 22nd June 2010, 20:15
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 932
Thanks: 16
Thanked 264 Times in 208 Posts
Default

Quote:
Originally Posted by till View Post
I tested it again on a new debian setup and the apps vhost works for me. Which is the exact error message that you get in the apache error log file for the 403 error?
There is no entry in the error log (only for missing favicon).
Just a 403 error in the browser.

Forbidden

You don't have permission to access /phpmyadmin/index.php on this server.


Access log is not enabled, i enabled it for testing in the app vhost but shows only 403 - no more info.


edit: access log entry:
xx.xx.xx.xx - - [22/Jun/2010:19:25:05 +0200] "GET /phpmyadmin/ HTTP/1.1" 403 193 "-" "Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.9) Gecko/20100501 Iceweasel/3.5.9 (like Firefox/3.5.9)"

edit 2: if i do a "a2dismod fcgid" and restart apache it works again, as soon as i a2enmod fcgid -> same as before: 403 - so if one is disabled either in vhost or in apache modules it works - as soon both are enabled in modules and in vhost - error 403

Last edited by Croydon; 22nd June 2010 at 20:31.
Reply With Quote
  #7  
Old 4th July 2010, 16:01
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 325
Thanks: 55
Thanked 95 Times in 60 Posts
Send a message via Skype™ to Horfic
 
Default

I got the same problem, regarding my apps. I can access all files except php.

Its a fresh Debian Lenny installation with ISPConfig latest trunk version.
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
Reply

Bookmarks

Tags
apache, apps, ispconfig 3, vhost

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to install roundcubemail ressel Installation/Configuration 13 24th December 2009 21:13
problems with suexec gobokster Installation/Configuration 7 7th May 2009 14:33
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 21:58
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 01:45


All times are GMT +2. The time now is 02:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.