Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Technical

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd June 2010, 15:56
jiandingzhe jiandingzhe is offline
Junior Member
 
Join Date: Jun 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default Permission deny after copy file

After I copied some files from one computer (linux system) to another (linux also), the files are not able to be accessed by normal account.
As it can be accessed by root, I chown those files to my username, but still cannot be accessed. While I try to ls -l those files, the accession limit, user and group are all displayed in "?", but can be seen normally when accessed as root. I guess it is something about security, but ls -Z provides same context as other normal files. What's the hell over there?
Thanks!!
Reply With Quote
Sponsored Links
  #2  
Old 3rd June 2010, 15:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Can you post the output of
Code:
ls -la
(run by root)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th June 2010, 03:14
jiandingzhe jiandingzhe is offline
Junior Member
 
Join Date: Jun 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default solved

I found if the whole dir is not set to 755, the problem occurs. The dir is previously set to 644, and there are files inside the dir set to 755. But why?
Reply With Quote
  #4  
Old 4th June 2010, 12:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Directories must always be executable.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 21:13
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 03:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 11:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.