Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd June 2010, 12:10
timefalls timefalls is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 5
Thanked 0 Times in 0 Posts
Question 403 Error with ISPConfig3

hey guys!


I just finished following the ISPConfig3 and SquirrelMail setup on Ubuntu 10.04LTS.

I have my domains setup correctly, so they forward nicely to my server. Unfortunately, when I was trying to install Wordpress to my domain, It suddenly switched to ERROR 403 Forbidden.

Naturally I was browsing this website for possible fixes, one suggested changing the permissions of /var/mydomain/web to 755, but this has absolutely no effect.

Can anybody help?
Reply With Quote
Sponsored Links
  #2  
Old 2nd June 2010, 19:37
bernholdt bernholdt is offline
Senior Member
 
Join Date: Jun 2007
Posts: 156
Thanks: 47
Thanked 13 Times in 11 Posts
Default

Look in your apache error.log should give you a hint on what to look for
Reply With Quote
The Following User Says Thank You to bernholdt For This Useful Post:
timefalls (5th June 2010)
  #3  
Old 2nd June 2010, 20:00
timefalls timefalls is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 5
Thanked 0 Times in 0 Posts
Default

thanks for your reply!

the lines of my error log are as follows:

Code:
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imagick.ini on line 1 in Unkno$
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/imap.ini on line 1 in Unknown $
PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/mcrypt.ini on line 1 in Unknow$
[Sun May 30 06:39:16 2010] [notice] Apache/2.2.14 (Ubuntu) mod_fcgid/2.3.4 PHP/5.3.2-1ubuntu4.1 with Suhosin-Patch mo$
[Sun May 30 06:39:16 2010] [warn] long lost child came home! (pid 9830)
[Sun May 30 06:44:14 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 07:00:12 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 07:17:58 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 07:33:32 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 07:49:20 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 08:05:18 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 08:21:51 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 08:40:58 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 09:00:50 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 09:21:09 2010] [error] [client 89.163.146.43] client sent HTTP/1.1 request without hostname (see RFC2616 $
[Sun May 30 09:21:16 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 10:07:05 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 10:18:48 2010] [error] [client 151.8.62.90] client sent HTTP/1.1 request without hostname (see RFC2616 se$
[Sun May 30 10:32:06 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 10:57:48 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 11:24:49 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 11:36:00 2010] [error] [client 216.145.11.94] File does not exist: /var/www/robots.txt
[Sun May 30 11:51:25 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 12:10:43 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 12:29:50 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 12:47:28 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 13:04:43 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 13:22:28 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 13:26:13 2010] [error] [client 91.212.12.60] client denied by server configuration: /htdocs
[Sun May 30 13:31:34 2010] [error] [client 89.16.175.101] File does not exist: /var/www/phpmyadmin
[Sun May 30 13:31:34 2010] [error] [client 89.16.175.101] File does not exist: /var/www/phpMyAdmin
[Sun May 30 13:39:59 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
[Sun May 30 13:56:27 2010] [error] [client 217.195.204.194] client sent HTTP/1.1 request without hostname (see RFC261$
i am unsure how to resolve these, any input would be greatly appreciated!
Reply With Quote
  #4  
Old 3rd June 2010, 15:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Do you use mod_php, suPHP, or FastCGI?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 3rd June 2010, 19:20
timefalls timefalls is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Do you use mod_php, suPHP, or FastCGI?
hi there falko, I actually followed your guide here:

http://www.howtoforge.com/perfect-se...nx-ispconfig-3

to the letter! I'm not sure if i have those installed, is there a command i can invoke to check if these plugins are active?

your guide worked perfectly for me, but when i added web content to my domain's folder it suddenly switched to a 403
Reply With Quote
  #6  
Old 3rd June 2010, 19:40
CSsab CSsab is offline
Senior Member
 
Join Date: Apr 2010
Posts: 174
Thanks: 19
Thanked 32 Times in 27 Posts
Lightbulb

Try putting this in the apache directives field of your site:

<Directory /var/www/yourwebsite.com/web>
AllowOverride All
</Directory>


Then restart apache
Reply With Quote
The Following User Says Thank You to CSsab For This Useful Post:
timefalls (5th June 2010)
  #7  
Old 3rd June 2010, 19:58
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

Did Wordpress install or change your .htaccess file? Look in there to see if a deny is affecting you.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
The Following User Says Thank You to BorderAmigos For This Useful Post:
timefalls (5th June 2010)
  #8  
Old 3rd June 2010, 19:58
timefalls timefalls is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by CSsab View Post
Try putting this in the apache directives field of your site:

<Directory /var/www/yourwebsite.com/web>
AllowOverride All
</Directory>


Then restart apache
thanks for your reply! i modified my sites-available file with the changes you suggested, and when i restarted apache i got this:

Code:
 * Restarting web server apache2                                                [Thu Jun 03 18:55:49 2010] [warn] NameVirtualHost [my ip here]:80 has no VirtualHosts
[Thu Jun 03 18:55:49 2010] [warn] NameVirtualHost [my ip here]:443 has no VirtualHosts
 ... waiting [Thu Jun 03 18:55:50 2010] [warn] NameVirtualHost  [my ip here]:80 has no VirtualHosts
[Thu Jun 03 18:55:50 2010] [warn] NameVirtualHost  [my ip here]:443 has no VirtualHosts
still getting a 403 forbidden error
Reply With Quote
  #9  
Old 3rd June 2010, 20:17
timefalls timefalls is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by BorderAmigos View Post
Did Wordpress install or change your .htaccess file? Look in there to see if a deny is affecting you.
my .htcaccess file is empty.
Reply With Quote
  #10  
Old 3rd June 2010, 20:19
timefalls timefalls is offline
Junior Member
 
Join Date: Jun 2010
Posts: 8
Thanks: 5
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by CSsab View Post
Try putting this in the apache directives field of your site:

<Directory /var/www/yourwebsite.com/web>
AllowOverride All
</Directory>


Then restart apache
I made the changes as you directed, by as i restarted apache I got these errors:

* Restarting web server apache2 [Thu Jun 03 18:55:49 2010] [warn] NameVirtualHost [my IP here]:80 has no VirtualHosts
[Thu Jun 03 18:55:49 2010] [warn] NameVirtualHost [my IP here]:443 has no VirtualHosts
... waiting [Thu Jun 03 18:55:50 2010] [warn] NameVirtualHost [my IP here]:80 has no VirtualHosts
[Thu Jun 03 18:55:50 2010] [warn] NameVirtualHost [my IP here]:443 has no VirtualHosts
[ OK ]

not too sure what's going on here! should i change it back?
Reply With Quote
Reply

Bookmarks

Tags
403, error, forbidden, ispconfig3

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VirtualBox Ubuntu 9.10 ISPConfig3 cosmotopper Installation/Configuration 5 12th April 2010 18:24
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
ISPConfig3 FTP problem karazy-k Server Operation 6 3rd September 2009 16:03
Questions about ISPConfig3 vs. ISPConfig2 atjensen11 General 1 14th March 2009 23:59
IMAP doesn't work..as i followed the Perfect Setup for Fedora 4 asokaajay Server Operation 11 10th June 2007 14:57


All times are GMT +2. The time now is 08:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.