Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd June 2010, 20:41
Rapid2214 Rapid2214 is offline
Senior Member
 
Join Date: Jun 2010
Posts: 105
Thanks: 3
Thanked 5 Times in 5 Posts
Exclamation Multiserver Setup - ERROR: Database...

Hi all,
I having this problem: ERROR: Stopped: Database already contains some tables. On my secoundry server .
I type 'y' for 'Shall this server join...' and just hit enter for the default database name.
Worked fine on my Virtual Mechines but in the real world it isn't working

Thanks in advance,

Marty

PS Primary server is working fine...
Reply With Quote
Sponsored Links
  #2  
Old 2nd June 2010, 22:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,715
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

The error means that there is already a database with that name on the slave server which contains database tables. Please delete that database on the slave before you install ispconfig on it. Also be sure that you have not accidently entered the login details for the master database when you got asked for the local mysql db. The details for the master are asked later after you selected to join a master server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd June 2010, 23:22
Rapid2214 Rapid2214 is offline
Senior Member
 
Join Date: Jun 2010
Posts: 105
Thanks: 3
Thanked 5 Times in 5 Posts
Unhappy

Thanks now im getting the following output, note im using a new user called 'remotesys' because i had problems with root remotly, i have granted remotesys all privilges


Adding ISPConfig server record to database.

ERROR: Unable to create database user in master database: ispcsrv2 Error: GRANT command denied to user 'remotesys'@'192.168.11.111' for table 'server'
Reply With Quote
  #4  
Old 3rd June 2010, 10:59
Rapid2214 Rapid2214 is offline
Senior Member
 
Join Date: Jun 2010
Posts: 105
Thanks: 3
Thanked 5 Times in 5 Posts
 
Default

Fixed it, the user needed to be able to GRANT:

Code:
mysql> GRANT ALL PRIVILEGES
    -> ON *.*
    -> TO root@192.168.11.111
    -> IDENTIFIED BY 'newpassword'
    -> WITH GRANT OPTION;
Thanks for your help
Reply With Quote
Reply

Bookmarks

Tags
database, error, ispconfig, tables

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Multiserver setup with mysql-only server Croydon Developers' Forum 4 21st February 2011 22:04
Chrome + Ubuntu + Flash player andor Desktop Operation 1 25th May 2010 16:59
Multiserver Master/Slave setup? warlock Installation/Configuration 1 15th July 2009 08:44
Multiserver setup bug Murder4Al Installation/Configuration 4 9th June 2009 16:27
Multiserver setup design documentation agoston Developers' Forum 4 4th June 2009 13:53


All times are GMT +2. The time now is 12:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.