Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 24th May 2010, 15:20
mhpcomputerservices mhpcomputerservices is offline
HowtoForge Supporter
 
Join Date: Dec 2006
Location: Walsall, England
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Send a message via MSN to mhpcomputerservices Send a message via Skype™ to mhpcomputerservices
Exclamation Can't start Apache after Ubuntu Upgrade

Hello

I have upgraded Ubuntu on my secondary server 9.10 -> 10.04LTS

All seems good, however I do have one small problem.

When a site is configured to use Fast-CGI apache refuses to start with the error:

Code:
 * Starting web server apache2    
Syntax error on line 58 of /etc/apache2/sites-enabled/testing.mhphosting.co.uk.vhost:                                                                                                                                                                                                   
SocketPath cannot occur within <VirtualHost> section
If the website is configured to use SuPHP or any other PHP handler this is not a problem. (Although - I'm not totally convinced suPHP is working either because PHPInfo shows 'Server API: Apache 2.0 Handler' ??)

Searching around only gives me bits of information and no solutions.

There seem to be some suggestions that it is an incompatibility with the new libapache2-mod-fcgid Version: 1:2.3.4-2.

Others suggest it is because my apache configuration was not updated during the upgrade.

As I have only upgraded my secondary server this is not a huge problem yet, the sites that require Fast-CGI are housed on the primary so I shall hold off upgrading that for now.

Here is one of the offending vhost files.

Code:
cat testing.mhphosting.co.uk.vhost
<Directory /var/www/testing.mhphosting.co.uk>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost *:80>
      DocumentRoot /var/www/testing.mhphosting.co.uk/web

    ServerName testing.mhphosting.co.uk
    ServerAdmin webmaster@testing.mhphosting.co.uk

    ErrorLog /var/log/ispconfig/httpd/testing.mhphosting.co.uk/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/testing.mhphosting.co.uk/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all

        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>
    <Directory /var/www/clients/client1/web55/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all

        # ssi enabled
        AddType text/html .shtml
        AddOutputFilter INCLUDES .shtml
        Options +Includes
    </Directory>

    # cgi enabled
        <Directory /var/www/clients/client1/web55/cgi-bin>
      Order allow,deny
      Allow from all
    </Directory>
    ScriptAlias  /cgi-bin/ /var/www/clients/client1/web55/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # suexec enabled
    SuexecUserGroup web55 client1
    # php as fast-cgi enabled
    <IfModule mod_fcgid.c>
      SocketPath /tmp/fcgid_sock/
      IdleTimeout 3600
      ProcessLifeTime 7200
      MaxProcessCount 1000
      DefaultMinClassProcessCount 3
      DefaultMaxClassProcessCount 100
      IPCConnectTimeout 8
      IPCCommTimeout 360
      BusyTimeout 300
    </IfModule>
    <Directory /var/www/testing.mhphosting.co.uk/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web55/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
        <Directory /var/www/clients/client1/web55/web>
        AddHandler fcgid-script .php .php3 .php4 .php5
        FCGIWrapper /var/www/php-fcgi-scripts/web55/.php-fcgi-starter .php
        Options +ExecCGI
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web55 client1
    </IfModule>


</VirtualHost>
So it seems this is the line it's complaining about:
Code:
SocketPath /tmp/fcgid_sock/
Please has anyone got any ideas here?

Thanks
__________________
Regards
Marcus

*Computer Cables
*Running on Multiserver Setup (5 Servers) Debian 6.0 & ISPConfig 3.0.5.2
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade ispconfig3 from ubuntu 9.10 to ubuntu 10.04 Lucid Lynx u4david Installation/Configuration 2 21st May 2010 14:53
VMware Won't Start On Ubuntu Hardy AlfredNoob HOWTO-Related Questions 5 5th August 2008 16:02
packet loss Chad Server Operation 2 12th June 2008 14:13
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58
How to Upgrade Apache on Suse Linux 9.3 Pro rfburn Installation/Configuration 2 1st July 2006 21:37


All times are GMT +2. The time now is 10:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.