Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 30th April 2010, 09:33
moiseev.igor moiseev.igor is offline
Junior Member
 
Join Date: Nov 2009
Posts: 8
Thanks: 0
Thanked 2 Times in 2 Posts
Default /etc/shadow and authentication problem on ispconfig + ubuntu

Hello we experience rare but constant problems with "perfect server" on Ubuntu 8.04 + ISPconfig 2 (different ispconfig releases and also the last one).

Problem description:
The main play is around the /etc/shadow (contains the linux users passwords in encrypted format, http://en.wikipedia.org/wiki/Shadow_password). The problem is that when we modify the datas for one user (ex. "web25_info") then the /etc/shadow will rewritten for all domain users "web25" even when no password was modified!!!

So the MAIN problem is that sometimes (could not reproduce it in vitro) the password changes to some uncertain one, so that any authentication versus /etc/shadow for the user under modification FAILS.
The problem causes authentication error with ftp, ssh, pop and other services.

The unique solution we found is to backup /etc/shadow, introduce any modification to the user settings (ex. activation antivirus/antispam for the user email) and then recover correct shadow from backup.

Any ideas or advice on the question are extremely welcome!!

Thank you.
PS. sorry this thread is a repost of ISPconfig2, problem with pop authentication, /etc/shadow. Neeeeed heeelp!
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig2, problem with pop authentication, /etc/shadow moiseev.igor General 6 26th May 2010 19:41
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 20:31
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Problem with installation of ISPConfig 3 on Ubuntu 8.10 VMartins Installation/Configuration 1 19th November 2009 19:07
SMTP authentication problem mphayesuk General 2 13th December 2007 11:33


All times are GMT +2. The time now is 18:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.