#1  
Old 16th April 2010, 19:54
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default pure-ftpd and ssl/tls

Hello all,

I want my ftp connection more secure, so I edited /etc/pure-ftpd/pure-ftpd.conf and un-commented TLS and gave it value 2.
After that I created the key
Code:
openssl req -x509 -nodes -newkey rsa:1024 -keyout /etc/ssl/private/pure-ftpd.pem -out /etc/ssl/private/pure-ftpd.pem
and chmod 600 pure-ftpd.pem.

Now I start Filezilla and change the log in methode from SFTP to FTPES and log in.


Filezilla ask me for the password and ask me to accept the certifiacate, to end with:
  • GnuTLS Error -53: error in the push function
  • Connection timed out
  • Failed to retrieve directory listing
Information given by Filezilla in pure-ftpd.txt
Info from /var/log/messages in varlogmessages.txt

Help would be apreciated.
Attached Files
File Type: txt pure-ftpd.txt (3.9 KB, 258 views)
File Type: txt varlogmessages.txt (6.8 KB, 227 views)
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
Sponsored Links
  #2  
Old 23rd April 2010, 13:28
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

Anyone ???
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #3  
Old 26th April 2010, 03:05
RogueCoder RogueCoder is offline
Junior Member
 
Join Date: Apr 2010
Location: Nova Scotia, Canada
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I had this issue just today. I'll assume you're using iptables to filter network traffic. It won't work with FTP/SSL, because it uses a wide port range and the ftp module that dynamically changes firewall rules can't see the FTP commands since they are encrypted. You must disable iptables or open all ports > 1024
__________________
"If at first you don't succeed; call it version 1.0"
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3.0.2.1, pure-ftpd, ssl/tls

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Document for setup Apache2 with SSL/TLS satimis Server Operation 2 25th November 2006 15:50
pop3 SSL/TLS not running, smtp+imap TLS/SSL ok st2xo Installation/Configuration 2 2nd February 2006 21:29


All times are GMT +2. The time now is 09:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.