Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #41  
Old 9th April 2010, 02:04
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

What would be the best way to check that? Based on /var/www/ subdirectories or am I wanting to compare it to the domains that are listed as SITES on ISPCONFIG's control panel?
Reply With Quote
Sponsored Links
  #42  
Old 9th April 2010, 14:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by crypted View Post
Based on /var/www/ subdirectories
Either that, or from your memory.

Quote:
Originally Posted by crypted View Post
or am I wanting to compare it to the domains that are listed as SITES on ISPCONFIG's control panel?
That doesn't help because ISPConfig gets the data from the database.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #43  
Old 10th April 2010, 21:33
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

Okay here are the results for those tables:

Checked the isp_isp_domain against the /var/named/ zonefiles on server

Code:
areyouracist.com dns does not have a ~ file
pwcsportsmanl.com dns does not have ~ file
peruvianprincess.org dns does not have ~ file
katiespivey.com dns does nto have ~ file
pri.franceskosak.com dns does not have ~ file
duplicate of areyouracist.com entry
duplicate of antonioparmatown.com entry

extra zone files for the following domains:
allsoentertainment.com
andovermeat.com
a-plusfence.com
area671.com
ballbustersinc.biz
ballbustersinc.com
ballbustersinc.net
ballbustersinc.org
frog-face.com
gimmeagame.com
melaniejessseminars.com
strayirc.net
wdfoxtrotters.net
in /var/www/, this domain/entry is still there but the website was deleted. there is no web106 dir. just the symlink hasn't been deleted by ISPCONFIG it seems:
www.antoniosparmatown.com -> /var/www/web106

this /var/www/ directory exists for a domain, with no symlink, and there is nothing but a /log/ dir within.
www.stalkerspub.com


no /var/www/ directory for the following domains:
(this domain is a codomain website)
skydrive.shiznt.net

no isp_isp_web entries exist for the following web directories in /var/www/:
(these domains should have been deleted)
www.antoniosparmatown.com -> /var/www/web106
www.DUWAHaven.com
www.melaniejessseminars.com
www.mercywireline.com
www.metropolitannightclub.com
www.proconsolutions.net



Also, I ran the writeconf.php again, and got new errors for EVERY user setup by ISPCONFIG:
Code:
hown: `web100_rrogers:web': invalid group
chown: `web100_rrogers:web': invalid group
UPDATE USER: 169
chown: `web105_antonios:web': invalid group
chown: `web105_antonios:web': invalid group
UPDATE USER: 170
chown: `web122_sky:web': invalid group
chown: `web122_sky:web': invalid group
UPDATE USER: 219
chown: `web3_nomail:web': invalid group
UPDATE USER: 187
chown: `web6_siteinquiries:web': invalid group
UPDATE USER: 185
chown: `web6_gawd:web': invalid group
chown: `web6_gawd:web': invalid group
UPDATE USER: 186
chown: `web51_poultrysch:web': invalid group
UPDATE USER: 218
chown: `web125_brett:web': invalid group
UPDATE USER: 223
chown: `web125_staftp:web': invalid group
UPDATE USER: 225
chown: `web128_fran:web': invalid group
chown: `web128_fran:web': invalid group
UPDATE USER: 227

Last edited by crypted; 10th April 2010 at 23:19.
Reply With Quote
  #44  
Old 11th April 2010, 11:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I don't understand why it uses the group web instead of web100, web105, web122, etc.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #45  
Old 11th April 2010, 17:41
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

I don't know either. This is the first time I have seen that in the years of using ISPCONFIG. All website directories are web# for the grouping. So, just being web is entirely off-basis for how it has been operating.
Reply With Quote
  #46  
Old 12th April 2010, 04:35
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

Code:
/etc/init.d/named start
....
zone fraternitassinelimitibus.info/IN: loading master file pri.fraternitassinelimitibus.info: file not found
_default/fraternitassinelimitibus.info/IN: file not found
zone intrac.net/IN: loaded serial 2010032301
zone antoniosparmatown.com/IN: loaded serial 2008111305
zone antoniosparma.com/IN: loaded serial 2008111303
zone forkup.info/IN: loaded serial 2008121104
zone a-plusfence.com/IN: loaded serial 2010010904
zone pwcsportsman.com/IN: loaded serial 2010030801
zone franceskosak.com/IN: loaded serial 2010031001
[FAILED]
As you see, I added a new domain. The HTTPD part was created. But, the NAMED files are not being created by ISPCONFIG. In the ISPCONFIG DNS Configuration Panel, the domain DNS exists. But, the ISPCONFIG writeconf isn't writing the DNS files. It did add the entry to the named.conf as you see. But, there was never a pri. file finished.

Last edited by crypted; 12th April 2010 at 07:13.
Reply With Quote
  #47  
Old 12th April 2010, 07:16
createch createch is offline
Senior Member
 
Join Date: Aug 2007
Posts: 118
Thanks: 24
Thanked 16 Times in 13 Posts
Default

A) Go to ISPConfig panel > server > setting > DNS. Make sure that the following settings:

named.conf
/var/named/chroot/etc/named.conf

zonefiles.dir
/var/named/chroot/var/named


B) Open a SSH terminal, login as root, and execute the following:

chmod 755 /var/named/
chmod 775 /var/named/chroot/
chmod 775 /var/named/chroot/var/
chmod 775 /var/named/chroot/var/named/
chmod 775 /var/named/chroot/var/run/
chmod 777 /var/named/chroot/var/run/named/
cd /var/named/chroot/var/named/
ln -s ../../ chroot
cp /usr/share/doc/bind-9.3.6/sample/var/named/named.local /var/named/chroot/var/named/named.local
cp /usr/share/doc/bind-9.3.6/sample/var/named/named.root /var/named/chroot/var/named/named.root
touch /var/named/chroot/etc/named.conf
chkconfig --levels 235 named on
/etc/init.d/named start


C) Now try to create a test domain (e.g www.test123.com) using the ISPConfig panel. See whether your system can create the pri record.

Last edited by createch; 12th April 2010 at 07:21.
Reply With Quote
  #48  
Old 12th April 2010, 07:30
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

So, doing that, the testsite.com created DNS entries and all that. But, upon deleting the website from ISPCONFIG, its DNS entry still exists...meaning in ISPCONFIG DNS Manager and in the zonefiles, testsite.com never got removed.
Reply With Quote
  #49  
Old 12th April 2010, 07:51
createch createch is offline
Senior Member
 
Join Date: Aug 2007
Posts: 118
Thanks: 24
Thanked 16 Times in 13 Posts
Default

Hi,

Please check whether the /home/admispconfig (and all directories underneath) are having the following owner permissions:

owner: admispconfig
group: admispconfig

if not, execute the correct chown and chgrp commands
(e.g.

cd /home
chown -R admispconfig admispconfig
chgrp -R admispconfig admispconfig

)

and retry to delete the testsite.com using the ISPConfig panel.
Reply With Quote
  #50  
Old 12th April 2010, 16:21
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
 
Default

Yeah, it's all owned by the same user/group of admispconfig:admispconfig
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Updates manarak General 17 15th August 2009 18:33
Since this morning SMTP Server OFFLINE qriz Installation/Configuration 14 28th July 2009 15:05
Webalizer 2.01 conf from old bug problem stefanos Installation/Configuration 3 6th April 2009 09:33
can't access the admin interface, apache lost the conf? Esuk Installation/Configuration 7 24th July 2006 11:35
drupal setup with several vhosts scherpenzeel Installation/Configuration 4 2nd June 2006 12:13


All times are GMT +2. The time now is 03:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.