Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th April 2006, 21:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,703
Thanks: 819
Thanked 5,320 Times in 4,173 Posts
Default ISPConfig 2.2.1 released

ISPConfig 2.2.1 is available for download.

This release adds support for Fedora Core 5 and CentOS 4.3,
clamassassin was added (replaces trashscan) and many bugs
were fixed.


Detailed Changelog
------------------

- New: Added support for Fedora Core 5.
- New: Added support for CentOS 4.3.
- Update: Update of the Italian translation.
- Update: Replaced trashscan with clamassassin.
- Update: Updated ClamAV to version 0.88.1.
- Bugfix: Server hostname is now recognized correctly in ISPConfig interface.
- Bugfix: Added some patches for more secure passwords.
- Bugfix: Create backup of existing ISPConfig installation in case of an update.
- Bugfix: When a client deletes a user from the recycle bin, the user is now
removed from /etc/passwd and /etc/shadow correctly.
- Bugfix: Default MX records now use the full hostname of the system.
- Bugfix: ISPConfig userdb passwords do not show up in logfile anymore.
- Bugfix: Missing newline at end of named.conf.
- Bugfix: Partitions are now shown correctly even with LVM partitions.
- Bugfix: Web space statistics: Usages of more than 1 GB are now shown as GB, not KB.
- Bugfix: Logsplit does not fail for "localhost" records anymore.
- Bugfix: Firewall and monitoring rules do not disappear anymore after an update.
- Bugfix: Removal of web groups is now working.
- Bugfix: The email addresses were shown with the full hostname. Example
name@www.domain.com instead of name@domain.com. This has been fixed.
- Bugfix: The monitoring summary (Management -> Server -> Services -> Monitoring)
now displays the port numbers that are monitored.
- Bugfix: /root/ispconfig/uninstall does now delete the ISPConfig entries from the
Apache configuration.


Download
--------

http://www.ispconfig.org/downloads.htm

Forums
------

http://www.howtoforge.com/forums


Installation Instructions
-------------------------

Download the ISPConfig-2.2.1.tar.gz from sourceforge.net

http://prdownloads.sourceforge.net/i...ar.gz?download


Installation on the shell as root User:

tar xvfz ISPConfig-2.2.1.tar.gz
cd install_ispconfig
./setup

The installer automatically detects the installed ISPConfig version and performs an update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #2  
Old 12th April 2006, 00:05
Cirox Cirox is offline
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

great work, guys

greetings cirox
Reply With Quote
  #3  
Old 12th April 2006, 00:59
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

I got problems here:
ISPConfig db has now cero tables. I thought It was a problem with my character collation in ispconfig db. I had utf8 and this lines in the mysql class constructor:
PHP Code:
mysql_query("SET character_set_client = 'latin1'");
mysql_query("SET character_set_results = latin1");
mysql_query("SET character_set_connection = utf8"); 
As with the update my db got dead, I decided to take out those lines and define ispconfig db as latin1. I did that and then uploaded a sql backup and began updating again. Same result. The database is there, but there are no tables. Also, the db dump found on /tmp did nothing for me. i had to use my own backup.

Here are the errors, but they say nothing really important
PHP Code:
All prerequisites are fulfilled.
Here we go...

Connected successfully to db isp_config

Warning
mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/dan/src/install_ispconfig/install.php on line 776

Warning
mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/dan/src/install_ispconfig/install.php on line 781

Warning
mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/dan/src/install_ispconfig/install.php on line 791

Warning
mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/dan/src/install_ispconfig/install.php on line 808

Warning
mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /home/dan/src/install_ispconfig/install.php on line 1114
Restarting some services
...
/
usr/sbin/apachectl restarthttpd restarted
 
Stopping Postfix Mail Transport Agent...                                                                                          [ ok ]
 * 
Starting Postfix Mail Transport Agent...                                                                                          [ ok ]
Restarting ProFTPD ftp daemon.proftpd.
.. - 
mod_tls/2.0.7using OpenSSL 0.9.7g 11 Apr 2005
 
parsing '/etc/proftpd.conf' configuration
 
parsing '/etc/proftpd_ispconfig.conf' configuration
proftpd
.
 
done.
Shutting down ISPConfig system...
/
root/ispconfig/httpd/bin/apachectl stophttpd (no pid filenot running
ISPConfig system stopped
!
Starting ISPConfig system...
/
root/ispconfig/httpd/bin/apachectl startsslhttpd started

Warning
mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/config.inc.php on line 47
No results found
!ISPConfig system is now up and running!
CongratulationsYour ISPConfig system is now installed. If you had to install quotaplease take the steps described in the installation manualOtherwise your system is now available without reboot
Anything to check?
Reply With Quote
  #4  
Old 12th April 2006, 01:34
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

Ok. So, this file is in /tmp/:
existing_db_04_11_2006__17_43_18.sql
So the following line works:
Code:
caselog("cp -f existing_db.sql /tmp/existing_db_".date("m_d_Y__H_i_s", $current_date).".sql", $FILE, __LINE__,"copied existing_db.sql to /tmp/existing_db_".date("m_d_Y__H_i_s", $current_date).".sql"
Could it be the -f option?
I read in man cp:
-----------
-f, --force
if an existing destination file cannot be opened, remove it and
try again
-----------
Could that be why I can't find anywhere the existing_db.sql file?
Reply With Quote
  #5  
Old 12th April 2006, 01:41
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
Default Error - Mysql keeps shutting down

Everytime I try to install the upgrade mysql dies...


[root@fc4 install_ispconfig]# service mysqld restart
Stopping MySQL: [FAILED]
Starting MySQL: [ OK ]
[root@fc4 install_ispconfig]# service mysqld status
mysqld (pid 28397) is running...

Mysql will run all night until

[root@fc4 install_ispconfig]# ./setup
Fedora 4.0

########## INSTALLATION ##########
[EDITED LICENCE CONTENT OUT OF POST]

ERROR: MySQL is not running! Please start your MySQL database and run the ISPConfig setup again.
[root@fc4 install_ispconfig]# service mysqld status
mysqld dead but subsys locked
[root@fc4 install_ispconfig]# service mysqld restart
Stopping MySQL: [FAILED]
Starting MySQL: [ OK ]
[root@fc4 install_ispconfig]# ./setup
Repeat.....
Reply With Quote
  #6  
Old 12th April 2006, 01:55
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

Buh, I think it was because I decompressed the files as my user and not root. I'm running the update again...
Reply With Quote
  #7  
Old 12th April 2006, 02:04
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

Buh, I think it was because I decompressed the files as my user and not root. I'm running the update again...
Reply With Quote
  #8  
Old 12th April 2006, 02:52
lyndros lyndros is offline
Senior Member
 
Join Date: Mar 2006
Location: Granada
Posts: 130
Thanks: 5
Thanked 3 Times in 2 Posts
Default

great work u all guys,
with people like u is a pleasure :-P

thks to all the ispconfig team
Reply With Quote
  #9  
Old 12th April 2006, 11:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by adamluz
Everytime I try to install the upgrade mysql dies...


[root@fc4 install_ispconfig]# service mysqld restart
Stopping MySQL: [FAILED]
Starting MySQL: [ OK ]
[root@fc4 install_ispconfig]# service mysqld status
mysqld (pid 28397) is running...

Mysql will run all night until

[root@fc4 install_ispconfig]# ./setup
Fedora 4.0

########## INSTALLATION ##########
[EDITED LICENCE CONTENT OUT OF POST]

ERROR: MySQL is not running! Please start your MySQL database and run the ISPConfig setup again.
[root@fc4 install_ispconfig]# service mysqld status
mysqld dead but subsys locked
[root@fc4 install_ispconfig]# service mysqld restart
Stopping MySQL: [FAILED]
Starting MySQL: [ OK ]
[root@fc4 install_ispconfig]# ./setup
Repeat.....
I experienced something like this on CentOS 4.3, and the solution was to change MySQL's init script as outlined here: http://www.howtoforge.com/perfect_setup_centos_4.3_p4
Given that Fedora and CentOS are very similar, you might have to do the same.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 13th April 2006, 01:09
adamluz adamluz is offline
Member
 
Join Date: Aug 2005
Location: Burbank, California
Posts: 76
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to adamluz Send a message via MSN to adamluz
 
Default

Quote:
Originally Posted by falko
I experienced something like this on CentOS 4.3, and the solution was to change MySQL's init script as outlined here: http://www.howtoforge.com/perfect_setup_centos_4.3_p4
Given that Fedora and CentOS are very similar, you might have to do the same.
Thanks

In /etc/init.d/mysqld

I changed:
restart(){
stop
start
}

to

restart(){
stop
sleep 3
start
}

and that fixed everything. Thought I would post it here for quicker results when searching.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.1.2 released till General 28 3rd July 2009 05:57
ISPConfig 2.2.0 released till General 17 7th April 2006 04:39
ISPConfig 2.1.0 released till General 21 10th February 2006 21:01
ISPConfig 2.0.9 released till General 41 16th October 2005 17:49
ISPConfig 2.0.8 released till General 6 29th August 2005 10:43


All times are GMT +2. The time now is 20:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.