#1  
Old 19th March 2010, 21:28
andreasnrb andreasnrb is offline
Junior Member
 
Join Date: Mar 2010
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default Pure FTPd not running

First I followed the install instructions here:http://www.ispconfig.org/docs/INSTALL_UBUNTU_8.04.txt
I skipped myDNS since I don't need that.

My problem is I can't seem to get pure ftp to run.
ISPConfig says FTP-server is offline and this:
Code:
Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Conf pure-ftpd-mysql (1.0.21-11.1ubuntu2 Ubuntu:8.04/hardy)
netstat -tap
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:10025         *:*                     LISTEN      30297/master
tcp        0      0 127.0.0.1:mysql         *:*                     LISTEN      30115/mysqld
tcp        0      0 *:webcache              *:*                     LISTEN      11833/apache2
tcp        0      0 *:www                   *:*                     LISTEN      11833/apache2
tcp        0      0 *:tproxy                *:*                     LISTEN      11833/apache2
tcp        0      0 *:smtp                  *:*                     LISTEN      26572/smtpd
tcp        0      0 *:https                 *:*                     LISTEN      11833/apache2
tcp        0      0 127.0.0.1:10024         *:*                     LISTEN      30383/amavisd (mast
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      32290/couriertcpd
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      32218/couriertcpd
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      1641/sshd
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      32257/couriertcpd
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      32329/couriertcpd
tcp6       0    248 server.example.com:ssh 55.114.227.87.stat:5464 ESTABLISHED 1784/0
I've googled and googled but can't seem to find an answer.
Thx in advance.
Reply With Quote
Sponsored Links
  #2  
Old 19th March 2010, 21:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Is this a vserver?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 19th March 2010, 22:08
andreasnrb andreasnrb is offline
Junior Member
 
Join Date: Mar 2010
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

if you by vserver mean VPS then yes.
Cant use the quota stuff on it, but I dont think lack of quota interferes with the FTP.
Could also add that ISPConfig says MySQL is not running but its running fine.
When I followed an instruction for ISPConfig 2 and used ProFTPd the FTP worked but couldn't login into it.

Last edited by andreasnrb; 19th March 2010 at 22:11.
Reply With Quote
  #4  
Old 19th March 2010, 22:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Then you most likely use a vps based on openvz or virtuozzo, some providers do not have capabilities enabled which causes pure-ftpd not to start. There are 2 options:

1) enable the capabilities (this has to be run on the host system and not within the vps):

Code:
VPSID=101
for CAP in CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE CHOWN DAC_READ_SEARCH SETGID SETUID NET_BIND_SERVICE NET_ADMIN SYS_CHROOT SYS_NICE
do
  vzctl set $VPSID --capability ${CAP}:on --save
done
2) Recompile purefpt without capability support:

http://www.howtoforge.de/howto/puref...-selbst-bauen/

These instructions are only available in german, but you might be able to follow them.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 19th March 2010, 22:25
andreasnrb andreasnrb is offline
Junior Member
 
Join Date: Mar 2010
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Yeah they have OpenVZ
Thanks for solution, I can read german so no problem there.
Have to say I learn a lot trying to config nix setup.
Is it required to use Pure or could I use another FTP server instead?
Reply With Quote
  #6  
Old 19th March 2010, 22:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Only pure-ftpd is supported.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 19th March 2010, 23:02
andreasnrb andreasnrb is offline
Junior Member
 
Join Date: Mar 2010
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ok thx.
Cant get apt-get source to work however. Only got two sources listed in my sources.list file.
deb http://archive.ubuntu.com/ubuntu/ hardy main restricted universe
deb http://archive.ubuntu.com/ubuntu/ hardy-updates main restricted universe

Which repository do I have to add to get apt-get source pure-ftpd to work?
[EDIT]
Nevermind found it =).

Last edited by andreasnrb; 19th March 2010 at 23:05. Reason: Solved it
Reply With Quote
  #8  
Old 19th March 2010, 23:21
andreasnrb andreasnrb is offline
Junior Member
 
Join Date: Mar 2010
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Well seems I can't use that method.
After fixing all the dependency crap I get
Code:
Can't exec "debian/rules": Permission denied at /usr/bin/dpkg-buildpackage line 477.
dpkg-buildpackage: failure: debian/rules clean failed with unknown exit code -1
when running dpkg-buildpackage -uc -b

I have done chmod +x debian/rules but denial persists.

Last edited by andreasnrb; 19th March 2010 at 23:40.
Reply With Quote
  #9  
Old 20th March 2010, 02:01
andreasnrb andreasnrb is offline
Junior Member
 
Join Date: Mar 2010
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

It was a noexec so thats why the permission denied happened.
The german instructions worked.
Thx for the help Till.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 4 TPS mail problem Hagforce HOWTO-Related Questions 13 10th February 2010 19:23
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 17:26
install Net::DNS chrno Installation/Configuration 4 5th September 2006 18:01
WARNING: services not running MicCo Installation/Configuration 31 4th September 2006 13:16
ftpd not running? Pelle Installation/Configuration 3 2nd October 2005 20:51


All times are GMT +2. The time now is 05:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.