Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 19th March 2010, 15:10
tony_simcock tony_simcock is offline
Junior Member
 
Join Date: Mar 2010
Posts: 22
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ah right... Symbolic links shouldnt be an issue with ISPConfig 3, as they work fine on Centos 5.4.
Ah, the security issue can be resolved by chmod'ing the webmail dir to root, then the user who ftp's in shouldn't be able to see the files (unless its root or has root privileges?)

If the directory exists in what apache thinks is the document root for the request, then appending /webmail on the end should view its contents. Does apache have access to view the dir?
Reply With Quote
Sponsored Links
  #12  
Old 19th March 2010, 15:34
afandino afandino is offline
Member
 
Join Date: May 2009
Posts: 35
Thanks: 1
Thanked 3 Times in 3 Posts
Default

tony,

sorry for sounding stupid but where can i find the apache settings for that website.
Reply With Quote
  #13  
Old 19th March 2010, 16:47
tony_simcock tony_simcock is offline
Junior Member
 
Join Date: Mar 2010
Posts: 22
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by afandino View Post
tony,

sorry for sounding stupid but where can i find the apache settings for that website.
Hi Afandino,
On mine there are individual vhost files in /etc/httpd/conf/sites-available/ (if you using ISPConfig to administer your apache setup
Failing that, the default conf file for apache is /etc/httpd/conf/httpd.conf then all the vhosts are defined at the bottom of the conf file.
Reply With Quote
  #14  
Old 19th March 2010, 18:10
afandino afandino is offline
Member
 
Join Date: May 2009
Posts: 35
Thanks: 1
Thanked 3 Times in 3 Posts
Default

I am trying to administrate through ispconfig3 . I have experienced in the past that if i try to alter settings outside of ispconfig things get all hosed up.
Reply With Quote
  #15  
Old 19th March 2010, 18:50
tony_simcock tony_simcock is offline
Junior Member
 
Join Date: Mar 2010
Posts: 22
Thanks: 0
Thanked 1 Time in 1 Post
Default

In that case just type:
Code:
grep "DocumentRoot" /etc/httpd/conf/sites-enabled/yourwebsite.vhost
Where yourwebsite is your website.
That'll tell you where the webmail symlink needs to be.

Last edited by tony_simcock; 19th March 2010 at 18:53.
Reply With Quote
  #16  
Old 26th May 2010, 17:54
Meph Meph is offline
Junior Member
 
Join Date: Jul 2009
Posts: 12
Thanks: 1
Thanked 2 Times in 2 Posts
Default

Not sure if afandino was able to resolve this issue or not, but I'm having the same problem under Debian 5.0 with ISPConfig 3.

I only have one SSL certificate that I use with my primary domain, so I want webmail to work by using https://www.domain.tld/webmail.

Created the symlink as follows:

ln -s /var/www/webmail/ /var/www/domain.tld/web/webmail

When I run 'grep "DocumentRoot" /etc/apache2/conf.d/sites-enabled/domain.tld.vhost' I get:

DocumentRoot /var/www/domain.tld/web
DocumentRoot /var/www/domain.tld/web

I have been looking around the web for a solution. One of them said to turn off cgi.force_redirect, but that didn't work. It was also suggested that I set a value for doc_root, but for obvious reasons that messes up my configuration. I'm under the impression that you are supposed to leave that blank when you are running virtual hosts, or maybe I just did it wrong.

Unlike afandino I am not afraid to change settings outside of ISPConfig3. I've already disabled ClamAV. For some reason the built-in SSL certificate generator doesn't work through the ISPConfig3 control panel so I had to general my private key and CSR manually.

Any suggestions?
Reply With Quote
  #17  
Old 27th May 2010, 18:19
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

After following the perfect Setup ispconfig 3 for your Linux distro, manually create an .vhost for your webmail.

Eg, I am running ubuntu and my squirrelmail.vhost looks like this:
Quote:
Alias /webmail /usr/share/squirrelmail

<Directory /usr/share/squirrelmail>
Options Indexes FollowSymLinks
<IfModule mod_php4.c>
php_flag register_globals off
</IfModule>
<IfModule mod_php5.c>
php_flag register_globals off
</IfModule>
<IfModule mod_dir.c>
DirectoryIndex index.php
</IfModule>

# access to configtest is limited by default to prevent information leak
<Files configtest.php>
order deny,allow
deny from all
allow from 127.0.0.1
</Files>
</Directory>
This file resides in:
/etc/apache2/sites-available

But you will have to create a symlink to have it added to:
/etc/apache2/sites-enabled

(This is Ubuntu's Apache setup, unsure about other distros).

Then just restart apache.

All domains you host should be able to access webmail now:
domain1.com/webmail
domain2.com/webmail
etc.
Reply With Quote
  #18  
Old 27th May 2010, 20:31
Meph Meph is offline
Junior Member
 
Join Date: Jul 2009
Posts: 12
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default

Thank you, that worked. The file did not exist in sites-available though so I just created a new file in sites-enabled, and copied and pasted the example you posted.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 memory configuration and Squirrel SamTzu General 4 30th August 2009 11:14
squirrel prob alf3299 Installation/Configuration 6 5th June 2009 19:53
Perfect Server 8.10+ISPC3 no mail e.gami Server Operation 4 24th April 2009 13:56


All times are GMT +2. The time now is 04:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.