Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th March 2010, 16:10
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default ftp authentication fails

I have been using ISPConfig for a while and I have had a number of working ftp accounts pointing at various sites.

The accounts were still working yesterday but today for some reason they stopped authenticating. I get a "530 Login authentication failed" message using saved account details that were working fine yesterday and if I use ISPConfig to setup a brand new user those details get the same error message.

The only thing I have done involving user accounts since yesterday is added an IP to mysql to allow a user to administer a couple of databases remotely.

Can this affect the ftp accounts?
Is there something I can try to get them working again? I definitely have the right connection details.
Reply With Quote
Sponsored Links
  #2  
Old 17th March 2010, 16:20
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

It looks as though the users are still being found but their passwords are being rejected...despite being correct:

Command: USER <myuser>
Response: 331 User <myuser> OK. Password required
Command: PASS ******
Response: 530 Login authentication failed
Reply With Quote
  #3  
Old 18th March 2010, 14:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Did you modify your firewall?
Did you try both active and passive transfers in your FTP client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 18th March 2010, 18:04
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

I didn't modify anything and the settings for my ftp client are exactly the same as when they were working. It's set to automatically try both types (I use filezilla).

I had working ftp accounts, modified mysql to allow remote access, started filezilla again and clicked on the same set of details and now it denies the password. I didn't change the firewall at all.
Reply With Quote
  #5  
Old 18th March 2010, 18:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Enable verbose logging in pure-ftpd and then check the log for errors:

http://www.faqforge.com/linux/contro...-debian-linux/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 18th March 2010, 18:08
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

It finds the server and accepts the username so I'm assuming the firewall is letting it through, it's just the password it rejects.
Reply With Quote
  #7  
Old 18th March 2010, 18:16
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

Hmm, my syslog isn't where that link thought it would be. I'll have to find it first :P
I use CentOS not Debian.
Reply With Quote
  #8  
Old 19th March 2010, 11:35
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

Whilst digging through my system yesterday I found out something that may be of relevance.
ISPConfig thinks my MySQL server is down. It reports it as such in the monitor section. I know it isn't because I have websites that use it and I've been using it in the command line.
I also noticed my fetchmail has stopped fetching my mail.
I wondering if ISPConfig thinking the MySQL server is down (for some unknown reason) is why ftp and fetchmail have stopped working? Could it possibly assume that the login details for both will be unavailable and therefore not try to carry out the task?

Some of the actions it carries out must be working and using MySQL as I can create accounts and see their details in the ispconfig database tables.

Another thing that makes me think maybe this is all MySQL related is that the problems occurred soon after I had modified a users remote access in the mysql command line.
I didn't touch the ispconfig database but I've use the following command to allow me to view several databases remotely:

mysql> GRANT ALL ON <db_name>.* TO root@'<my_ip>' IDENTIFIED BY '<my_root_password>';

I didn't do this to my ispconfig database but it was after I did this that my ftp went down and fetchmail stopped running.

Any ideas? Is there something I can do to the ispconfig configuration that would refresh it's MySQL settings or something and get this working again?
Reply With Quote
  #9  
Old 19th March 2010, 12:53
fooboo fooboo is offline
Member
 
Join Date: Sep 2009
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

Just scrolling through my rsyslog I noticed the line below:

warning: connect to mysql server 127.0.0.1: Can't connect to MySQL server on '127.0.0.1' (111)

But my websites still connect ok.
Reply With Quote
  #10  
Old 19th March 2010, 16:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
 
Default

What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubleshooting FTP bswinnerton Installation/Configuration 4 10th October 2008 19:34
proFTPd passive mode problems bisbell Server Operation 8 6th August 2008 21:12
Question about Virtual Hosting With Proftpd And MySQL (Incl. Quota) On Debian Etch ikkem HOWTO-Related Questions 30 26th February 2008 19:38
Mail server attack princebenin Server Operation 1 19th November 2007 14:02
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 14:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.