Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th March 2010, 15:32
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default Clamd.amavisd start error

Hello all,

Today I installed a perfect server Fedora 12 with ISPConfig 3.02 on i686 box.
After installing amavisd-new and clamav you run this command: /etc/init.d/clamd.amavisd start and this gives an error.
clamd.amavisd Local: Socket file /var/spool/amavisd/clamd.sock is in use by another process.

What to do now ?

Output of ls -l: /var/run/clamav/clamd.sock: cannot access /var/spool/amavisd/clamd.sock: No such file or directory

Output of ls -la /var/run/: drwxr-xr-x 2 amavisd amavisd 4096 2010-03-12 15:30 amavisd ( No other amavisd or clamd or clamd.amavisd in this output )
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
Sponsored Links
  #2  
Old 12th March 2010, 15:41
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default Update

Also I tried this http://www.howtoforge.net/forums/sho...t=clamd.sock#6 The file www mentioned does not exists on my server so I edited /etc/clamd.d/amavisd.conf
But that gives an other error: ERROR:Please define server type ( local and/or tcp )
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #3  
Old 13th March 2010, 14:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

What's the output of
Code:
updatedb
locate clamd.conf
?

What's in /etc/clamd.d/amavisd.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 14th March 2010, 06:48
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

Hello Falko,

The output of locate clamd.conf:
/user/share/doc/clamav-server-0.95.3/clamd.conf
/user/share/man/man5/clamd.conf.5.gz

I attached the amavisd.conf file.

Have a nice day
Attached Files
File Type: txt amavisd.conf.txt (536 Bytes, 328 views)
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #5  
Old 15th March 2010, 14:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Can you change
Code:
User amavis
to
Code:
User amavisd
in /etc/clamd.d/amavisd.conf and restart Clamd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 19th March 2010, 10:03
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

Hello Falko,

I have changed /etc/clamd/amavisd.conf like you suggested but when I restart clamd.amavisd it gives another error:
Code:
Error: Can't get information about user amavisd. Starting clamd.amavisd failed
Any other ideas ?
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #7  
Old 21st March 2010, 03:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

What's the output of
Code:
grep amavis /etc/passwd
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 23rd March 2010, 01:51
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
Default

Hello Falko,

Here is the output of grep amavis /etc/passwd:

amavis:x:490:475::/var/spool/amavisd:/sbin/nologin

Have a nice day !
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
  #9  
Old 23rd March 2010, 18:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Ok, then
Code:
User amavis
is correct in /etc/clamd.d/amavisd.conf, but /var/spool/amavisd/ should be owned by amavis, not amavisd.

Can you run
Code:
chown -R amavis:amavis /var/spool/amavisd/
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
robertlouwen (24th March 2010)
  #10  
Old 24th March 2010, 11:45
robertlouwen robertlouwen is offline
Senior Member
 
Join Date: Apr 2009
Location: Brielle, Netherlands
Posts: 141
Thanks: 20
Thanked 3 Times in 2 Posts
 
Default

Thanks again Falko, that did the trick !

In my humble opinion, does the tutorial "perfect server F12" need a little update at chapter 15 page 5 ? ( http://www.howtoforge.net/perfect-se...ispconfig-3-p5 ).

Now there is this:
Code:
chown amavis /var/run/amavisd /var/spool/amavisd /var/spool/amavisd/tmp /var/spool/amavisd/db
and maybe this:
Code:
chown -R amavis:amavis /var/spool/amavisd/
can / must be added ?

Thank you for your time and have a nice day
__________________
With Respect, Robert
------------------------------------------------
Fedora 15 - ISPConfig v3.0.3.3
On Dell Optiplex GX270, Pentium 4, 2.8 GHz, 1024 Mb
Reply With Quote
Reply

Bookmarks

Tags
amavisd, clamd, clamd.amavisd, fedora 12

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing ISPConfig on Suse10.1 nliebherr Installation/Configuration 18 14th September 2007 00:30
dns server error Hellbound General 7 2nd August 2007 09:18
Error on install igbe Installation/Configuration 7 28th February 2007 22:55
Apache trouble wont restart Domain coroption main3 Installation/Configuration 1 16th September 2006 12:09
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 16:14


All times are GMT +2. The time now is 21:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.