Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 5th March 2010, 18:08
willebanks willebanks is offline
Member
 
Join Date: Mar 2006
Location: connecticut
Posts: 75
Thanks: 2
Thanked 0 Times in 0 Posts
Default ispconfig wordpress and directory/file permissions

Howdy all,

Got a weird problem that I'm hoping someone else has had and fixed.
My Ubuntu 9.10 / ISPConfig installation went flawlessly.
I setup 3 wordpress sites with no problems. The 4th site has driven me nuts.

Here is the steps I used for all 4 sites...
1. I downloaded the WordPress file into a "download" folder I created on the web server.
2. I created each site via ISPConfig.
3. Copied the WordPress file to the /var/www/web# folder of each site.
4. Extracted (tar -xzvf) the WordPress file in the /var/www/web# folder of each site.
5. Copied the /var/www/web#/web folder to /var/www/web#/webold and deleted the orignal "web" folder.
6. Copied the /var/www/web#/wordpress folder to /var/www/web#/web
7. Followed the WordPress "5 minute" install.

I follow the above process for 4 sites. The first 3 sites went flawlessly. The forth site just wouldn't be "found" when I tried to browse to the site. After some head scratching I realized the I had elevated from my normal user to "super user" during the above process so all files and folder were owned by root...

Rather than try to change all the files to the proper user, I deleted the "4th" site and as a "normal" user followed the above process again. Almost the same problem...all files and folders for the new site were "owned" by "www-data" and "www-data" is the group.

On a hunch I reset the user password for the new site via ISPConfig. This changed the "owner" to the user but the group is still "www-data". The website now works but the user and group privileges are different from the user and group privileges for the other 3 sites. Example:
-rwxrwxr-x "username" "web#" "filename" First 3 sites
-rw-r--r-- "username" "www-data" "filename" Last 3 sites

I have tried to install 2 others sites with the above process and still run into the "owner" & "group" problem. Something has changed but I don't know enough Linux to figure it out.

I'm really sorry for such a long post but I want to give as much information as possible. If anyone can offer suggestions that would really make my day!

Thanks,
Will Banks
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.