Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th February 2010, 21:17
carlosinfl carlosinfl is offline
Member
 
Join Date: Dec 2009
Location: Orlando, FL
Posts: 70
Thanks: 3
Thanked 3 Times in 3 Posts
Send a message via AIM to carlosinfl
Question Postfix Config on Arch Linux

I was following this guide & noticed that during the section I was to modify my /etc/postfix/main.cf file, do I not need to add a mydomain = mydomain.tld?

For example:

Code:
# Domain settings
myhostname = mail.mydomain.tld
mydomain = mydomain.tld
myorigin = mydomain.tld
mydestination = $myhostname, localhost.$mydomain, localhost
The guide tells you to reference $mydomain parameter under the "mydestination =" section however we are never instructed to enter this parameter according to the link above. Should we add the "mydomain =" parameter or is it not necessary and only clutter?
Reply With Quote
Sponsored Links
  #2  
Old 28th February 2010, 16:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What are the outputs of
Code:
postconf -d | grep mydomain
and
Code:
postconf -n | grep mydomain
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 1st March 2010, 17:09
carlosinfl carlosinfl is offline
Member
 
Join Date: Dec 2009
Location: Orlando, FL
Posts: 70
Thanks: 3
Thanked 3 Times in 3 Posts
Send a message via AIM to carlosinfl
Exclamation

Code:
[root@mail ~]# postconf -d | grep -i "mydomain"
append_dot_mydomain = yes
mydestination = $myhostname, localhost.$mydomain, localhost
mydomain = localdomain

[root@mail ~]# postconf -n | grep -i "mydomain"
append_dot_mydomain = no
mydestination = $myhostname, localhost.$mydomain, localhost
Reply With Quote
  #4  
Old 2nd March 2010, 15:23
carlosinfl carlosinfl is offline
Member
 
Join Date: Dec 2009
Location: Orlando, FL
Posts: 70
Thanks: 3
Thanked 3 Times in 3 Posts
Send a message via AIM to carlosinfl
Default

Anyone?
Reply With Quote
  #5  
Old 2nd March 2010, 16:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

The default setting currently is mydomain = localdomain. If you want to change it, run
Code:
postconf -e 'mydomain = mydomain.tld'
and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
RoundCube Sends but will not receive. happz Installation/Configuration 33 17th April 2010 21:55
error: File /root/rpm/SOURCES/postfix-2.3.3-vda.patch: No such file or directory mxtdn Installation/Configuration 1 25th July 2009 09:20
Postfix not responding to telnet CarbonCopy Server Operation 6 8th May 2009 05:39
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
i dont recive any mail of any domain chua_jose Installation/Configuration 18 10th November 2008 18:55


All times are GMT +2. The time now is 19:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.