Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 1st March 2010, 14:57
Steveorevo Steveorevo is offline
Member
 
Join Date: Feb 2010
Posts: 33
Thanks: 6
Thanked 6 Times in 5 Posts
Default Fix WebDAV with PHP (files execute instead of GET)

There is bug that I've come across when running ISPConfig 2.2.35 where getting PHP files via WebDAV pulls down the executed script vs. the actual PHP content.

To fix this problem you'll want to add directives via ISPConfig's Apache Directives (Optional) setting. I add the following that prevents PHP scripts from executing when downloading via WebDAV

# Fix for PHP WebDAV
<IfModule mod_dav.c>
<Location /webdav>
php_value engine off
</Location>
</IfModule>

WebDAV is an excellent alternative to FTP because it can be secure (with optional SSL), HTTP(S) is optimized on most routers and networks, and its fast as hell. Its also supported on various OS's natively from OS X to Windows, and in 'professional' web IDEs like Dreamweaver (for designers) and phpED (for developers). With this fix I can develop faster using Dw and www.themedreamer.com developing WordPress themes.
Reply With Quote
The Following 2 Users Say Thank You to Steveorevo For This Useful Post:
falko (2nd March 2010), till (3rd March 2010)
Sponsored Links
 

Bookmarks

Tags
download, execute, php, run, webdav

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot add Mailboxes after PHP-Update hfr Installation/Configuration 5 7th November 2009 21:09
PHP code for PHPMyAdmin is not parsed parkerj Installation/Configuration 3 26th May 2009 14:40
ISPConfig virtual web pages not working mike_phi Installation/Configuration 8 7th May 2008 17:51
Power failiure Wwamphyri General 6 24th February 2007 22:21


All times are GMT +2. The time now is 21:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.