Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th February 2010, 12:49
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default Email problems: Cannt send and recieve! Help!

My server is CentOS 5.3 with ISPConfig 3.0.1


At first, I found the error information in the maillog:


fatal: parameter "smtpd_recipient_restrictions": specify at least one working instance of: check_relay_domains, reject_unauth_destination, reject, defer or defer_if_permit
Feb 5 18:44:15 wsttl postfix/master[18016]: warning: process /usr/libexec/postfix/smtpd pid 10592 exit status 1
Feb 5 18:44:15 wsttl postfix/master[18016]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling


So I add the option "reject_unauth_destination" to the smtpd_recipient_restrictions. Then i found:

Feb 5 19:01:07 wsttl postfix/qmgr[10786]: 2587E3650073: from=<jhuang@somedomain.com>, size=2960, nrcpt=1 (queue active)
Feb 5 19:01:07 wsttl maildrop[20598]: Cannot set my user or group id.
Feb 5 19:01:07 wsttl postfix/pipe[20597]: 2587E3650073: to=<hr@tiaotiao.la>, relay=maildrop, delay=360924, delays=360924/0.02/0/0.01, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Cannot set my user or group id. )


And I had checked "dig mx", the response is OK.


And I must tell you, that the Postfix I installed is a rpm (version 2.5.1) package with SPEC:

POSTFIX_ALT_PRIO=30
POSTFIX_CDB=0
POSTFIX_DB=4
POSTFIX_DOVECOT=0
POSTFIX_LDAP=1
POSTFIX_MYSQL=0
POSTFIX_MYSQL_PATHS=0
POSTFIX_MYSQL_REDHAT=1 #??Is this is a problem?
POSTFIX_PCRE=0
POSTFIX_PGSQL=0
POSTFIX_SASL=2
POSTFIX_SMTPD_MULTILINE_GREETING=0
POSTFIX_SPF=0
POSTFIX_TLS=1
POSTFIX_VDA=1

So i want to ask: Now I still can not send and rceieve any mail with my mail server. Is "POSTFIX_MYSQL_REDHAT=1" is a problem? How I could solve the problem "Cannot set my user or group id." ? And now except webmail, I cannt use any mail soft as outlook and so on. When I connection to the pop3 server, I got the error code: 0x800CCC0F.
Reply With Quote
Sponsored Links
  #2  
Old 6th February 2010, 19:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

You run a old ispconfig version (3.0.1), please update it to the current version 3.0.1.6 and choose to reconfigure services during the update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 6th February 2010, 19:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

How exactly did you install the server? Did you use a guide from HowtoForge? If so, which one (URL)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 7th February 2010, 12:36
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
How exactly did you install the server? Did you use a guide from HowtoForge? If so, which one (URL)?
I'd installed my server using the guid from the url:
http://www.howtoforge.com/perfect-se...64-ispconfig-3
but i must say that the php version in my server is 5.2.11 , and the mysql version is 5.1.42.
And now all others are ok except the postfix.
Reply With Quote
  #5  
Old 7th February 2010, 16:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

Please do what I suggested in #2 if you want to solve this problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 22nd February 2010, 07:45
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
You run a old ispconfig version (3.0.1), please update it to the current version 3.0.1.6 and choose to reconfigure services during the update.
Sorry, now ispconfig had beeb updated to the current version 3.0.1.6 , and service reconfiged, but the error still exists.

temporary failure. Command output: /usr/bin/maildrop: Cannot set my user or group id.
Reply With Quote
  #7  
Old 22nd February 2010, 10:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

And you have entered "yes" as the updater asked you to reconfigure services?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 22nd February 2010, 10:32
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes, i entered "yes" , and now i only fund these warnings and errors in the log:
(temporary failure. Command output: /usr/bin/maildrop: Cannot set my user or group id. )
warning: SASL authentication failure: Couldn't find mech NTLM
warning: SASL authentication failure: Couldn't find mech GSSAPI

and i found this in master.cf
maildrop unix - n n - - pipe
flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
but in MAILDROP_README IS:
maildrop unix - n n - - pipe
flags=ODRhu user=vmail argv=/path/to/maildrop -d ${recipient}

Are they problems?

thanks!

Last edited by bardo; 22nd February 2010 at 15:39.
Reply With Quote
  #9  
Old 23rd February 2010, 09:42
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have a test, here the result:
[root@wsttl ~]# su vmail
[vmail@wsttl root]$ echo "test" |maildrop -V 10 -d test@tiaotiao.la
maildrop: authlib: groupid=5000
maildrop: authlib: userid=5000
maildrop: Cannot set my user or group id.
[vmail@wsttl root]$

and i found there is no mailbox_command config in my main.cf
and in the MAILDROP_README
i found:
mailbox_command = /path/to/maildrop -d ${USER}

when i use outlook i got the error: '-ERR Maildir invalid (no 'cur' directory)', 0x800CCC92

when i use outlook i got the error: '-ERR Maildir invalid (no 'cur' directory)', 0x800CCC92

pls give a help. How can i solve the problem? thanks

Last edited by bardo; 23rd February 2010 at 09:54.
Reply With Quote
  #10  
Old 24th February 2010, 10:03
bardo bardo is offline
Junior Member
 
Join Date: Oct 2009
Location: shanghai
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

maildrop: authlib: groupid=5000
maildrop: authlib: userid=5000
maildrop: Cannot set my user or group id.

for this error, i resolved by changing the config of postfix:
virtual_gid_maps = static:5000
virtual_uid_maps = static:5000

virtual_gid_maps = static:504
virtual_uid_maps = static:504

504 is fact vmail usrid and groupid

or u can edit /etc/passwd and etc/group/ to change vmail usrid and groupid to 5000.

now i cant understand:
in master.cf
maildrop unix - n n - - pipe
flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
but in MAILDROP_README IS:
maildrop unix - n n - - pipe
flags=ODRhu user=vmail argv=/path/to/maildrop -d ${recipient}

who can tell me? thanks!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can send & recieve mail via local mail & linux acts but cannot recieve frm ext mail tyliong HOWTO-Related Questions 3 8th January 2009 05:14
Can send email but not recieve from a second domain-- first domain works perfect grandpagenocide General 3 31st July 2007 09:10
Can Send Email, But Not Recieve mfdp10 Installation/Configuration 15 4th June 2007 09:18
Can Send Email, But Not Recieve; Relay access denied jazzgillum Installation/Configuration 21 31st May 2007 12:46
Can Send Email, But Not Recieve; Relay access denied googlah Installation/Configuration 14 30th August 2006 00:11


All times are GMT +2. The time now is 22:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.