#1  
Old 23rd February 2010, 23:53
guanaco guanaco is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default disable sending emails

I have tried to look on your forum for this with no luck. I know that there is a way to disable receiving emails with ISPConfig but would it be possible to disable sending? I want some accounts to be able to only receive emails.

Thank you for your help
Reply With Quote
Sponsored Links
  #2  
Old 24th February 2010, 00:50
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
Default

One way of doing this is by adding the following to /etc/postfix/header_checks

Code:
/^From: .*@XYZ\.TLD>/ DISCARD
This will stop any email from domain xyz.tld to be send.
Make sure that you restart postfix after adding this.
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 24th February 2010, 02:18
guanaco guanaco is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the code doesnt seems to do anything.

I added the line to the header_checks file and restarted postfix but I can still send email locally and externally. Any other way to do this?
Reply With Quote
  #4  
Old 24th February 2010, 09:12
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,044
Thanks: 269
Thanked 154 Times in 133 Posts
 
Default

Make sure that "/etc/postfix/header_checks" is included in your "/etc/postfix/main.cf" like this.

Code:
header_checks = regexp:/etc/postfix/header_checks
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apche hangs ever few minutes after an update rslinks Server Operation 2 12th December 2009 19:57
Sending emails - Going to spam folders tech_paul Server Operation 16 31st July 2009 12:44
Sending emails with PHP Izinyoka General 8 9th April 2009 16:52
LB1 Not Taking Over Shared IP Using Heartbeat 2.1.3 On FC10 64Bit asyadiqin Installation/Configuration 5 11th February 2009 21:11
problem sending emails dannyrowe Server Operation 5 7th July 2008 23:51


All times are GMT +2. The time now is 22:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.