Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th February 2010, 18:00
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
Default www.domain.tld works but domain.tld doesn't

I installed ISPConfig2 on Debian Lenny (according to Howtoforge tutorial) and I'm having a little problem.

I added a Site and set up the records. But for some reason www.domain.tld brings up with the usual ISPConfig standard page, but domain.tld does not.

Can someone tell me what I'm doing wrong?
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
Sponsored Links
  #2  
Old 9th February 2010, 22:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,372
Thanks: 833
Thanked 5,477 Times in 4,313 Posts
Default

Add a co-domain domain.tld with empty host field.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th February 2010, 22:32
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
Default

The only domain in the "Co-Domains" Tab is already without a host.
Attached Images
 
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
  #4  
Old 9th February 2010, 22:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,372
Thanks: 833
Thanked 5,477 Times in 4,313 Posts
Default

Then the dns A-Record fo domain.com might be missing.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 10th February 2010, 06:25
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
Default

No, it's not that either.
I have an A record with www one without a host and one with mail.

So:
domain.tld
www.domain.tld
mail.domain.tld
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
  #6  
Old 10th February 2010, 06:30
Been Told Been Told is offline
HowtoForge Supporter
 
Join Date: Nov 2008
Posts: 123
Thanks: 29
Thanked 10 Times in 4 Posts
 
Default

I've just realized... It was a problem with the nameservers I've set up.
I'm using a Hetzner server. Now I've switched to Hetzner's nameservers, it's working with and without www.

So now I'm gonna have to figure that out. Thanks for trying to help guys.
__________________
My stats:
  • RootServer running ISPconfig 2 on Debian Lenny
  • vServer running PLESK 8.4 on openSUSE 10.3
  • vServer running PLESK 9 on Ubuntu
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50
NEW INSTALL WORKS GREAT BUT a few issues webwork Installation/Configuration 4 18th April 2008 20:58
There is no 'www' subdomain for domain.tld 2ndmouse Installation/Configuration 11 21st August 2007 17:18
One Domain Works Only Fedora Core 7 earthboi23 Installation/Configuration 1 6th July 2007 17:25
MYSQL Works but on start gives an Error nibb Installation/Configuration 1 6th June 2007 15:42


All times are GMT +2. The time now is 10:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.