Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th February 2010, 14:28
FeraTechInc FeraTechInc is offline
Senior Member
 
Join Date: Feb 2007
Posts: 136
Thanks: 3
Thanked 5 Times in 5 Posts
Default More frequent "Internal Server Error 500"

We've been having some problems with a flash based file uploader. While it started up very fast at uploading files lately it has been slowing down and throwing out Internal Server Error 500. Also, we have been getting this error with our other sites as well when loading pages from the MYSQL database.

We recently upgraded our server to Ubuntu 9.10

We have also made some changes to our php.ini and apache.conf files hoping to eliminate this error. It seems like it's a problem with the process timing out.

The server an AMD X3 processor, 8gigs of ram 1 terabyte of hard drive space in raid 5 and barely breaks a sweat during the day. PHP version 5.2.10 The slowness might be caused by our ISP.

However, we would like to eliminate the Internal 500 errors on our sites.
Reply With Quote
Sponsored Links
  #2  
Old 4th February 2010, 15:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,444
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Please take a look at the error log of the website, the reason for the error is logged there.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th February 2010, 23:07
FeraTechInc FeraTechInc is offline
Senior Member
 
Join Date: Feb 2007
Posts: 136
Thanks: 3
Thanked 5 Times in 5 Posts
Default

Strangely I am getting hundreds of these errors a day:

[error] [client XXX.XXX.XXX.XXX] File does not exist: /var/www/website.com/web/error/404.html, referer: http://www.website.com/userinfo.php?uid=188

[error] [client XXX.XXX.XXX.XXX] File does not exist: /var/www/website.com/web/SPA/jseffects

Also there are these errors which are less common:

[warn] (103)Software caused connection abort: mod_fcgid: ap_pass_brigade failed in handle_request function


The "File Does Not Exist" errors are happening to all my sites.
Reply With Quote
  #4  
Old 4th February 2010, 23:19
FeraTechInc FeraTechInc is offline
Senior Member
 
Join Date: Feb 2007
Posts: 136
Thanks: 3
Thanked 5 Times in 5 Posts
Default

Also, I would like to mention this error pretty includes all files in the website. It seems like all access to the site generates this error.
Reply With Quote
  #5  
Old 5th February 2010, 11:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,444
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

The above errors are 404 errors and the lines do not belong to the 500 error. Most likely you checked the wrong error log file as a 500 error is always logged.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 5th February 2010, 11:44
FeraTechInc FeraTechInc is offline
Senior Member
 
Join Date: Feb 2007
Posts: 136
Thanks: 3
Thanked 5 Times in 5 Posts
Default

Where is the log supposed to be?

I am checking in the /var/www/website.com/log/error.log

Is there another log for the site I should be checking?
Reply With Quote
  #7  
Old 5th February 2010, 11:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,444
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
Default

Yes, thats the correct file for the site. If the error is not listed there, take a look at the global apache error login in /var/log/apache2/ (path varies depending on Linux distribution).
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 5th February 2010, 20:04
FeraTechInc FeraTechInc is offline
Senior Member
 
Join Date: Feb 2007
Posts: 136
Thanks: 3
Thanked 5 Times in 5 Posts
Default

Any idea what I should be looking for? Are there any key words I can use to sort through all the errors?
Reply With Quote
  #9  
Old 5th February 2010, 22:43
damir damir is offline
Senior Member
 
Join Date: Jun 2006
Posts: 375
Thanks: 11
Thanked 51 Times in 42 Posts
Default

Are you using php_fcgid for you website?
Reply With Quote
  #10  
Old 6th February 2010, 19:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,444
Thanks: 813
Thanked 5,209 Times in 4,085 Posts
 
Default

Search for "500" in the error logs.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
500, internal server error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Random Questions dclardy General 9 3rd September 2009 23:39
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08
Email Clients cannot send mail iverson0881 Installation/Configuration 3 8th May 2008 08:34
Rejecting outbound mail tristanlee85 General 11 20th May 2007 17:04
Webmail Relay Error palkat General 17 23rd April 2006 18:12


All times are GMT +2. The time now is 17:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.