Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 6th February 2010, 17:40
N9XCR N9XCR is offline
Junior Member
 
Join Date: Jul 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to Create LVM-Based VM in Xen on CentOS due to "Insufficient free extents"

I installed CentOS on a Dell PowerEdge 860 with two 1TB hard drives in RAID1. This is a bare minimum install. I then installed Xen according to "Paravirtualization With Xen On CentOS 5.4 (x86_64)". Here is the output from vgdisplay and lvdisplay:

Code:
[root@serenity ~]# vgdisplay
  /dev/hda: open failed: No medium found
  --- Volume group ---
  VG Name               VolGroup00
  System ID
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  3
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                2
  Open LV               2
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               931.22 GB
  PE Size               32.00 MB
  Total PE              29799
  Alloc PE / Size       29799 / 931.22 GB
  Free  PE / Size       0 / 0
  VG UUID               Pt8lYt-vBDe-BGHH-82ee-S1qI-Rc7q-ZfKw0y

[root@serenity ~]# lvdisplay
  /dev/hda: open failed: No medium found
  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol00
  VG Name                VolGroup00
  LV UUID                dNRrkh-cgaZ-ak68-wcXY-wydS-xGIV-taAOJl
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                921.47 GB
  Current LE             29487
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:0

  --- Logical volume ---
  LV Name                /dev/VolGroup00/LogVol01
  VG Name                VolGroup00
  LV UUID                s6effT-hVcu-ICBP-NL18-2yoh-Dvba-76A5fA
  LV Write Access        read/write
  LV Status              available
  # open                 1
  LV Size                9.75 GB
  Current LE             312
  Segments               1
  Allocation             inherit
  Read ahead sectors     auto
  - currently set to     256
  Block device           253:1
This is what happens when I try to create my first LVM-based VM.
Code:
[root@serenity ~]# lvcreate -L10G -n vm01 VolGroup00
  /dev/hda: open failed: No medium found
  Insufficient free extents (0) in volume group VolGroup00: 320 required
I know I did something wrong somewhere. Please point me in the right direction.

Thank you,
Chris
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 16:22
Installing Xen 3.3 on Ubuntu 8.10-failure to create LVM image jlain HOWTO-Related Questions 2 6th April 2009 17:39
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 09:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.