#1  
Old 3rd February 2010, 11:04
rylangrant rylangrant is offline
Junior Member
 
Join Date: Dec 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Can't Connect on 8080

Hi, I'm using ISPConfig 3 on CentOS 5.4. I followed the the "The Perfect Server - CentOS 5.4 x86_64 [ISPConfig 3]" for this 5.4 and I ran into a few issues (had to change the one php file used in the install to CentOS 5.4 as it only listed upto 5.3). I finally got the install to go smoothly and I can access the /webmail and /phpmyadmin but I cannot access the ISPConfig login page on 8080. I don't have any firewalls/iptables running and I can nmap the system from a remote computer and see that there is something listening on 8080. I've checked the /etc/apache2/sites-enabled/000-ispconfig.vhost file and the port is set to 8080.

I also have a problem starting up pure-ftpd but but I'm pretty sure this is un-related and will deal with that after.

The output of iptables -L is:
Chain INPUT (policy ACCEPT)
target prot opt source destination
fail2ban-ssh tcp -- anywhere anywhere tcp dpt:ssh

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain fail2ban-ssh (1 references)
target prot opt source destination
RETURN all -- anywhere anywhere


The output of of netstat -tap is:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost.localdomain:10024 *:* LISTEN 5908/amavisd (maste
tcp 0 0 localhost.localdomain:10025 *:* LISTEN 5991/master
tcp 0 0 *:mysql *:* LISTEN 5836/mysqld
tcp 0 0 localhost.local:dyna-access *:* LISTEN 5740/clamd
tcp 0 0 virtual.saskjazz.c:webcache *:* LISTEN 6004/httpd
tcp 0 0 virtual.saskjazz.com:domain *:* LISTEN 5868/mydns
tcp 0 0 ip-97-74-204-165.ip.:domain *:* LISTEN 5868/mydns
tcp 0 0 localhost.localdomai:domain *:* LISTEN 5868/mydns
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 5718/cupsd
tcp 0 0 *:smtp *:* LISTEN 5991/master
tcp 0 0 *op3s *:* LISTEN 5939/couriertcpd
tcp 0 0 *op3 *:* LISTEN 5933/couriertcpd
tcp 0 0 *:imap *:* LISTEN 5920/couriertcpd
tcp 0 0 *:http *:* LISTEN 6004/httpd
tcp 0 0 localhost6.localdoma:domain *:* LISTEN 5868/mydns
tcp 0 0 *:ssh *:* LISTEN 5708/sshd
tcp 0 0 *:https *:* LISTEN 6004/httpd
tcp 0 0 *:imaps *:* LISTEN 5927/couriertcpd


Any help, ideas or suggestsions would be appreciated, I've googled and checked all of the forums and solutions and I'm not having any luck right now. I've also tried downloading /reinstalling ISPConfig.

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 3rd February 2010, 11:43
prisfeo prisfeo is offline
Member
 
Join Date: Jan 2010
Posts: 37
Thanks: 3
Thanked 2 Times in 2 Posts
Default

hi,

assuming that port 8080 is not blocked by any fw:
if your server is (example in order to explain):
http://server1.example.com:8080

check DNS resolution of server1.example.com
that must point to the ip setup in ispconfig..

and do the following test:

browse to:
http://IP_setup_into_ISPconfig_durin...iguration:8080

in order to bypass "dns" resolution problems..
even if i think it's right since you can access to webmail, phpmayadmin

other tests:
from a command prompt do a telnet session from a machine to ispconfig server:
telnet IP_setup_into_ISPconfig_during_configuration 8080
and see if you can see the curson blinking in the top left
(-> ok) or "connection failed"

do the same telnet test inside server itself

Last edited by prisfeo; 3rd February 2010 at 11:56.
Reply With Quote
  #3  
Old 3rd February 2010, 12:09
rylangrant rylangrant is offline
Junior Member
 
Join Date: Dec 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

If I try going to the http://theServerIP:8080, no luck.

If I telnet in from a remote machine to either the domain, or theServerIP on 8080 it times out

If i telnet locally from the server into either the domain or theServerIP on 8080 I do get the HTML info echoed back.

I'm assuming that implies that there is some kind of firewall or something blocking it? It is a virtual server with Godaddy so there is no router/NAT blocking it and I don't think there should be any firewalls on their side. Any suggestions?

Thanks!
Reply With Quote
  #4  
Old 3rd February 2010, 12:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

As you dont run a firewall on your server, you will ahve to ask godaddy if they block port 8080.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 3rd February 2010, 12:21
rylangrant rylangrant is offline
Junior Member
 
Join Date: Dec 2009
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Assuming they do block port 8080 i should be able to just go in via another port, right? What is the best way to change the listening port?

Last edited by rylangrant; 3rd February 2010 at 12:23. Reason: posted wrong info
Reply With Quote
  #6  
Old 3rd February 2010, 12:50
prisfeo prisfeo is offline
Member
 
Join Date: Jan 2010
Posts: 37
Thanks: 3
Thanked 2 Times in 2 Posts
 
Default

i think you can easily try to set another port(change the "8080" value) inside your:
/etc/apache2/sites-enabled/000-ispconfig.vhost
and restart apache.

but you have to ensure tahe the "new" port
is opened/reachable and not blocked from outside
your ispconfig server
and ensure the new port is not already used by other services
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig 3 cant receive emails lishaw1968 Installation/Configuration 25 19th August 2013 10:37
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Debian Lenny apt-get update failed to fetch qriz Installation/Configuration 3 31st October 2009 22:19
Mail not working epicuniversal General 5 13th June 2009 08:24


All times are GMT +2. The time now is 13:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.