Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st February 2010, 13:04
prisfeo prisfeo is offline
Member
 
Join Date: Jan 2010
Posts: 38
Thanks: 3
Thanked 2 Times in 2 Posts
Default Spamfilter policy - question about spam actions (amavisd config bug ?)

ispconfig3 on Cento5.4, all works.
...
i am testing antispam sending to preconfigured email accounts
some mail containing "triggers text" in order to verify/test spam actions.
i have chosen inside "Spamfilter policy" the "Normal" policy,
here it is preconfigured default settings of the "Tag Level" tab:

SPAM tag level: 3
SPAM tag2 level: 6.9
SPAM kill level: 6.9
SPAM dsn cutoff level: 0
SPAM quarantine cutoff level: 0
SPAM modifies subject: Yes
SPAM subject tag: (blank)
SPAM subject tag2: (blank)

i have noticed that sending an email with spam hits equal to "4" (created for this purpose), i can see in mail log that mail is correctly detected as SPAM,
but it's not marked (rewritten in the subject i mean) and normally delivered.
i think it's normal (pls confirm if i am right) since the SPAM subject tags
are "blank" and so there is not subject rewrite.
..
well, so i have modified the SPAM subject tags settings above into:
SPAM subject tag: SPAM:
SPAM subject tag2: SPAM:

now the spam email with "4" spam hits is marked in the subject with "SPAM: original subject" and delivered.

is this the right procedure in order to deliver SPAM emails, detected between the tag level 1 and 2, and mark them spam in the subject ?
..
other questions:
how can i do in order to not deliver SPAM emails between tag level 1 and 2 and quarantine them ?
i have to deal with "SPAM quarantine cutoff level" setting ?
..
what does it mean "SPAM dsn cutoff level"
it's related to "notifications" ?
...
mails that have spam hits > "SPAM kill level"
are quaratined & not trashed (deleted), am i right ?

thanks in advance.
bye.

Last edited by prisfeo; 1st February 2010 at 14:53. Reason: group related info in the same thread
Reply With Quote
Sponsored Links
  #2  
Old 1st February 2010, 14:52
prisfeo prisfeo is offline
Member
 
Join Date: Jan 2010
Posts: 38
Thanks: 3
Thanked 2 Times in 2 Posts
Default

i update this thread since i have discovered something "wrong" (i think)
in amavisd.conf;

inside this file i saw "two" times (placed in different lines i mean)
these groups of statements:

starting at line 157:

$final_virus_destiny = D_REJECT;
$final_banned_destiny = D_REJECT;
$final_spam_destiny = D_PASS;
$final_bad_header_destiny = D_PASS;


and after,
starting at line 775:

$final_virus_destiny = D_BOUNCE;
$final_spam_destiny = D_DISCARD;
$final_banned_destiny = D_BOUNCE;
$final_bad_header_destiny = D_PASS;


(note that are all not commented)
the bad thing is that are different settings of same directives

i think i have to delete one group of them, right ?
which one ?
can be an installation/configuration bug ?

thanks in advance.

Last edited by prisfeo; 1st February 2010 at 14:58.
Reply With Quote
  #3  
Old 2nd February 2010, 15:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

I'd comment out the first section. Might be a problem in the ISPConfig installer for CentOS - we will check that.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 2nd February 2010, 15:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Quote:
i think i have to delete one group of them, right ?
No, thats not nescessary. Amavis will only use the last lines, the first one will be ignored.

Anyway, the configuration that you do in ispconfig when you select a policy overrides these, so they do not matter for all emails domains or mailboxes that you assigned a policy.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 2nd February 2010, 16:17
prisfeo prisfeo is offline
Member
 
Join Date: Jan 2010
Posts: 38
Thanks: 3
Thanked 2 Times in 2 Posts
 
Default

Quote:
Originally Posted by falko View Post
I'd comment out the first section. Might be a problem in the ISPConfig installer for CentOS - we will check that.
thanks Falko..
check also this strange behaviour i posted here:

http://www.howtoforge.com/forums/showthread.php?t=42965
(about the "double" amavisd.conf files)

since it can lead not to use correctly amavis...
i think it can be related to some installation issue.

Quote:
Originally Posted by till View Post
No, thats not nescessary. Amavis will only use the last lines, the first one will be ignored.
thanks Till..yes i confirm since i have changed & made some
tests in that direction..

Quote:
Anyway, the configuration that you do in ispconfig when you select a policy overrides these, so they do not matter for all emails domains or mailboxes that you assigned a policy.
uhmm..me too thought that, but from the test i made, have to say that it does not ovveride..
let me explain:

in the amavis conf file i have deleted the two statements groups above
and wrote one group with the following settings:

$final_virus_destiny = D_DISCARD;
$final_spam_destiny = D_DISCARD;
$final_banned_destiny = D_BOUNCE;
$final_bad_header_destiny = D_PASS;

well,
now if i change
$final_spam_destiny = D_DISCARD;
into
$final_spam_destiny = D_PASS;

and i send a spam gtube test email to account inside ispconfig,
(see above ispconfig tab settings), are not killed (deleted), but
tagged as "SPAM: subject"
even if "SPAM kill level: 6.9"

only putting $final_spam_destiny = D_DISCARD;
i obtain that email with spam hits > 6.9 are killed(deleted)..

so, do you think it's not normal or there's something wrong
into my ispconfig/amavis integration ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 mail server SPAM question sheshes Installation/Configuration 4 12th May 2010 19:11
ayuda politica spam no funciona / help policy spam not working shackdie General 1 24th April 2009 10:59
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 17:37
Reject/Discard Spam Question lewis_saint General 3 25th December 2007 17:28
Upgrade from 2.2.0 to 2.2.1 successful but SSL and IMAP stopped working teleriddler Installation/Configuration 8 29th April 2006 14:25


All times are GMT +2. The time now is 11:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.