Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th January 2010, 19:10
KaiserGimmel KaiserGimmel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default [Solved]Maildrop: unable to open mailbox

Hello,

yesterday I did a big misstake - i added the unstable sources to the sources.lst (to update my mumble server) and my apt-auto updater did a complete update of my server tonight. Its a debian lenny machine. With the old setup everything worked fine

The Problem is now that maildrop cant deliver new emails to the maildir:

Quote:
Jan 24 17:54:33 torchwood postfix/pipe[17056]: 37ACA19CE099: to=<xxx@xxx.com>, relay=maildrop, delay=0.06, delay
s=0.03/0.01/0/0.03, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox. )
I didnt alter the permission and they are still correct. vmail is the owner of the /var/vmail folder.

I tried to deliver a recent mail to the maildir:

Quote:
maildrop -V9 -d xxx@xxx.xxx < /var/vmail/xxx/xxx/.Archives.2010/cur/1262701017.M786815P10300V0000000000000801I00000000 01BE213A_1.torchwood\,S\=19707\:2\,S

...
.mailfilter(5): LOGNAME=""
.mailfilter(6): EXTENSION=""
.mailfilter(7): RECIPIENT=""
.mailfilter(8): USER=""
.mailfilter(9): HOST=""
...
maildrop: Delivering to /var/vmail///.
maildrop: Unable to open mailbox.
I think the Recipient User and Host are not passed in correctly - dont know how to fix this.
My mercurial tells me that the master.cf is not altered - but for a overview:

Quote:
alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
content_filter = amavis:[127.0.0.1]:10024
header_checks = regexp:/etc/postfix/header_checks
html_directory = /usr/share/doc/postfix/html
inet_interfaces = all
mailbox_size_limit = 0
message_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = torchwood.xxx.xxx, localhost, localhost.localdomain
myhostname = torchwood.xxx.xxx
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relayhost =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = maildrop
virtual_uid_maps = static:5000
The mysql settings work - same again nothing altered.

Anyone here can give me a clue how to fix this mess?
Would really appreciate it!
Cheers
Max

Last edited by KaiserGimmel; 25th January 2010 at 10:57. Reason: solved
Reply With Quote
Sponsored Links
  #2  
Old 25th January 2010, 08:38
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
Default

You can not test maildrop like that, so its ok that your test failed.

To your original problem. Debian has two maildrop packages, one with mysql support and a second one without maildrop support. It seems as if you replaced the maildrop on your system with the one without mysql support, this results in the problem that myaildrop can not lookup the maildir anymore in mysql and so the delivery fails. You should reinstall the original maildrop package that is used in the perfect server guide.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 25th January 2010 at 17:27. Reason: corrected some nonsense, mixed up mysql with myidrop. Do not start to write posts before you finished your cup of coffee :)
Reply With Quote
  #3  
Old 25th January 2010, 10:12
KaiserGimmel KaiserGimmel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default [Solved]Maildrop: unable to open mailbox

Hey till,

thanks for your fast answer - I did a downgrade of maildrop, and it fixed my problem!

For the history:

from the aptitude logs: courier-maildrop 0.60.0-2 -> 0.63.0-2 - so i removed the unstable sources and reinstalled courier-maildrop with that version.

After i entered "postfix flush" I even got all my emails

You made my day!
Cheers
Max
Reply With Quote
The Following User Says Thank You to KaiserGimmel For This Useful Post:
falko (26th January 2010)
  #4  
Old 1st February 2010, 23:23
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Default

Can you tell me the commands you used to fix this. I have the same problem.
I did do a apt-get remove maildrop and then did a apt-get install maildrop and still no go. I did disable the sources that I had enabled before so not sure what else to do??


--Steve
Reply With Quote
  #5  
Old 1st February 2010, 23:46
KaiserGimmel KaiserGimmel is offline
Junior Member
 
Join Date: Oct 2009
Posts: 14
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hello Steve,

I think you either forgot the apt-get update to get the old packages into the cache or you have a diffrent problem.

Try
Quote:
maildrop -v
- if you have another version then 0.60.0-2 you have still the wrong one. Remove it - apt-get update && apt-get install courier-maildrop and verify again.
If you got it you can hold the package (i would use aptitude instead of apt) so it keeps the current version until you say so. Its
Quote:
aptitude hold courier-maildrop
Cheers
Max
Reply With Quote
  #6  
Old 1st February 2010, 23:54
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Default

I did do the apt-get update after I posted and tried again to no avail. I did you what you suggested and still no go. The difference is that when I did it I only did apt-get install maildrop, you suggested courier-maildrop.

Code:
root@wci:~# maildrop -v
maildrop 2.0.4 Copyright 1998-2005 Double Precision, Inc.
GDBM/DB extensions enabled.
Maildir quota extension enabled.
This program is distributed under the terms of the GNU General Public
License. See COPYING for additional information.
root@wci:~#
This is after I ran

Code:
apt-get update && apt-get install courier-maildrop
help!
Reply With Quote
  #7  
Old 1st February 2010, 23:59
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Default

and just so you can see the error in the mail log.

Code:
Feb  1 14:50:48 wci postfix/qmgr[3164]: 1AB0EAC1CF: removed
Feb  1 14:50:48 wci maildrop[4548]: Unable to open mailbox.
Feb  1 14:50:48 wci postfix/pipe[4547]: 72A5AAC1D8: to=<alexis@mydomain.com>, relay=maildrop, delay=0.13, delays=0.04/0.02/0/0.07, dsn=4.3.0, status=deferred (temporary failure. Command output: /usr/bin/maildrop: Unable to open mailbox. )
Reply With Quote
  #8  
Old 2nd February 2010, 00:35
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Default

I tried it all again. It is installing the correct version, but when I do maildrop -v it says somethign else?????

Code:
root@wci:~# apt-get install courier-maildrop
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  courier-doc
The following NEW packages will be installed:
  courier-maildrop
0 upgraded, 1 newly installed, 0 to remove and 15 not upgraded.
Need to get 0B/951kB of archives.
After this operation, 2597kB of additional disk space will be used.
Selecting previously deselected package courier-maildrop.
(Reading database ... 45905 files and directories currently installed.)
Unpacking courier-maildrop (from .../courier-maildrop_0.60.0-2ubuntu1_i386.deb) ...
Processing triggers for man-db ...
Setting up courier-maildrop (0.60.0-2ubuntu1) ...

root@wci:~# maildrop -v
maildrop 2.0.4 Copyright 1998-2005 Double Precision, Inc.
GDBM/DB extensions enabled.
Maildir quota extension enabled.
This program is distributed under the terms of the GNU General Public
License. See COPYING for additional information.
root@wci:~#
Reply With Quote
  #9  
Old 2nd February 2010, 03:27
rforsythe rforsythe is offline
Junior Member
 
Join Date: Nov 2009
Posts: 6
Thanks: 0
Thanked 4 Times in 2 Posts
Default

This appears related to a maildrop package update pushed out in the last day or two. I was able to downgrade it using this command:

aptitude install maildrop=2.0.4-3

Then do this:

postfix flush

And now my queues are flushing fine. I am also using the following command to prevent this from re-updating, which I will 'unhold' at some point in the future when I see the issue has been resolved...

aptitude hold maildrop

Good luck folks, I had a lot of mail getting queued but seems OK now.
Reply With Quote
The Following 2 Users Say Thank You to rforsythe For This Useful Post:
rudolfpietersma (7th February 2010), till (2nd February 2010)
  #10  
Old 2nd February 2010, 05:22
troggie_0092 troggie_0092 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

What was wrong with maildrop that the update caused it to not connect to the mailbox?

Will it be fixed in time to come?

Thank you once again
Reply With Quote
Reply

Bookmarks

Tags
lenny, mailbox, maildrop, update

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
libWand.so.10 error Taxick Installation/Configuration 8 3rd May 2009 01:27
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 20:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.